summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorWilhelm Schuster2022-08-27 00:18:18 +0200
committerWilhelm Schuster2022-08-27 00:18:18 +0200
commit0953d932d0b427fae204ee61cc04ce340babec17 (patch)
tree9b924612587fb92fc840fd9e37bb0ae85837f6ca
parent95e73b06468f3adeeb1687d3dcfaff93faaf9d70 (diff)
downloadaur-0953d932d0b427fae204ee61cc04ce340babec17.tar.gz
Update to 2.0.4
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD9
2 files changed, 8 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 14bf5869cb42..dba115539002 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = klipper-estimator
pkgdesc = A tool for determining the time a print will take on a 3D printer running Klipper firmware
- pkgver = 2.0.3
+ pkgver = 2.0.4
pkgrel = 1
url = https://github.com/Annex-Engineering/klipper_estimator
arch = x86_64
@@ -10,7 +10,7 @@ pkgbase = klipper-estimator
arch = aarch64
license = custom:MIT
makedepends = cargo
- source = klipper-estimator-2.0.3.tar.gz::https://github.com/Annex-Engineering/klipper_estimator/archive/v2.0.3.tar.gz
- sha512sums = 237bc958048cce5cd98ae1b849d5236626100fafe1bf6a6a8576d4ee834aa888b99d8b93a17d188269047f08453967795d0d21b963a46783dd370b72bdc7307d
+ source = klipper-estimator-2.0.4.tar.gz::https://github.com/Annex-Engineering/klipper_estimator/archive/v2.0.4.tar.gz
+ sha512sums = de0f3472379f839d0b2b34a98eabc838af5a7ba61160fed7d57e83f94a8b154be2a6e626b262384c197f9423b44628e3a3793caf9edccd34e71faec561f9c217
pkgname = klipper-estimator
diff --git a/PKGBUILD b/PKGBUILD
index a9d884d2d24a..99ddeeeb81a0 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=klipper-estimator
_pkgname=${pkgname/-/_}
-pkgver=2.0.3
+pkgver=2.0.4
pkgrel=1
pkgdesc="A tool for determining the time a print will take on a 3D printer running Klipper firmware"
url="https://github.com/Annex-Engineering/klipper_estimator"
@@ -10,7 +10,7 @@ arch=('x86_64' 'i686' 'armv6h' 'armv7h' 'aarch64')
license=("custom:MIT")
makedepends=(cargo)
source=("${pkgname}-${pkgver}.tar.gz::https://github.com/Annex-Engineering/${_pkgname}/archive/v${pkgver}.tar.gz")
-sha512sums=('237bc958048cce5cd98ae1b849d5236626100fafe1bf6a6a8576d4ee834aa888b99d8b93a17d188269047f08453967795d0d21b963a46783dd370b72bdc7307d')
+sha512sums=('de0f3472379f839d0b2b34a98eabc838af5a7ba61160fed7d57e83f94a8b154be2a6e626b262384c197f9423b44628e3a3793caf9edccd34e71faec561f9c217')
prepare() {
cd "$_pkgname-$pkgver"
@@ -24,8 +24,8 @@ build() {
export RUSTUP_TOOLCHAIN=stable
export CARGO_TARGET_DIR=target
- # The build expects git metadata to generate version string, building from
- # .tar.gz we don't have that so fall back onto defining an environment
+ # The build expects git metadata to generate the version string, but building
+ # from .tar.gz we don't have that so fall back onto defining an environment
# variable.
export TOOL_VERSION=${pkgver}
cargo build --frozen --release --all-features
@@ -37,4 +37,5 @@ package() {
install -Dm755 target/release/$_pkgname -T "${pkgdir}/usr/bin/$pkgname"
install -Dm644 LICENSE.txt -t "${pkgdir}/usr/share/licenses/${pkgname}"
install -Dm644 compat/CuraPostProcessing/KlipperEstimator.py "${pkgdir}/usr/lib/cura/plugins/PostProcessingPlugin/scripts/KlipperEstimator.py"
+ install -Dm755 contrib/klipper_estimator.sh "${pkgdir}/usr/share/klipper-estimator/contrib/klipper_estimator.sh"
}