summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAntonio Cardace2016-04-23 12:58:27 +0200
committerAntonio Cardace2016-04-23 12:58:27 +0200
commitab2973dfc719783ef400711ea4f9f5b498737cdc (patch)
tree266d38ca315ed938e99d50e487a956e8e0a1067f
downloadaur-ab2973dfc719783ef400711ea4f9f5b498737cdc.tar.gz
Init commit
-rw-r--r--.SRCINFO21
-rw-r--r--PKGBUILD28
2 files changed, 49 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..b07ca7856ef1
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,21 @@
+pkgbase = kmailapplet-git
+ pkgdesc = A Mail Applet for the system tray to watch your Maildir box and get notifications whenever there's a new mail.
+ pkgver = 1.0
+ pkgrel = 1
+ url = https://gitlab.students.cs.unibo.it/cardace/KMailApplet
+ arch = any
+ license = GPL3
+ makedepends = git
+ makedepends = make
+ makedepends = qt5-base
+ depends = glibc
+ depends = gcc-libs
+ depends = boost-libs
+ depends = qt5-base
+ provides = kmailapplet-git=1.0
+ conflicts = kmailapplet-git
+ source = kmailapplet-git::git+https://gitlab.students.cs.unibo.it/cardace/KMailApplet.git
+ md5sums = SKIP
+
+pkgname = kmailapplet-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..d55ea0d6eeb6
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+# Maintainer: Antonio Cardace <anto.cardace@gmail.com>
+pkgname=kmailapplet-git
+pkgver=1.0
+pkgrel=1
+pkgdesc="A Mail Applet for the system tray to watch your Maildir box and get notifications whenever there's a new mail."
+arch=('any')
+url="https://gitlab.students.cs.unibo.it/cardace/KMailApplet"
+license=('GPL3')
+depends=('glibc' 'gcc-libs' 'boost-libs' 'qt5-base')
+makedepends=('git' 'make' 'qt5-base')
+provides=("$pkgname=$pkgver")
+conflicts=("$pkgname")
+source=("$pkgname::git+https://gitlab.students.cs.unibo.it/cardace/KMailApplet.git")
+md5sums=("SKIP")
+
+build() {
+ cd "$srcdir/$pkgname"
+ qmake -o Makefile build.pro
+ make
+}
+
+package() {
+ cd "$srcdir/$pkgname"
+ cp -r usr etc $pkgdir
+ chmod -R 755 "$pkgdir/usr" "$pkgdir/etc"
+ mkdir -p "$pkgdir/usr/bin/"
+ cp KMailApplet "$pkgdir/usr/bin/"
+}