summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorcobalt2015-07-05 23:28:07 +0300
committercobalt2015-07-05 23:28:07 +0300
commitaf61c01e59e5a126711b53c2bc585097f3656b0d (patch)
tree9e87f8890e48cf51cc95e02df0a281947293a9d2
downloadaur-af61c01e59e5a126711b53c2bc585097f3656b0d.tar.gz
Initial import
-rw-r--r--.SRCINFO17
-rw-r--r--Makefile14
-rw-r--r--PKGBUILD30
3 files changed, 61 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..01192e1ef13f
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = kmailpt
+ pkgdesc = KMail Power Tools
+ pkgver = 0.3
+ pkgrel = 1
+ url = http://jice.free.fr/kmailpt/
+ arch = i686
+ arch = x86_64
+ license = GPL
+ depends = perl-mime-tools
+ options = !libtool
+ source = http://jice.free.fr/kmailpt/kmailpt-0.3.tar.bz2
+ source = Makefile
+ md5sums = c8cff48f33223262d25440a0db01bd10
+ md5sums = 23e464c03778228badb091c4dd6ffe73
+
+pkgname = kmailpt
+
diff --git a/Makefile b/Makefile
new file mode 100644
index 000000000000..b6702f0330d7
--- /dev/null
+++ b/Makefile
@@ -0,0 +1,14 @@
+# kmailpt makefile
+#
+
+PREFIX = $(DESTDIR)usr/local/
+ICOPREFIX = $(DESTDIR)usr/share/icons/
+
+INSTALL = install --group=0 --owner=0 --mode=0755
+INSTALL2 = install --group=0 --owner=0 --mode=0644
+
+install: kmailpt.pl attach_delete.png attach_save.png
+ mkdir -p $(PREFIX)bin/ $(ICOPREFIX) ; \
+ $(INSTALL) kmailpt.pl $(PREFIX)bin/ ; \
+ $(INSTALL2) attach_delete.png $(ICOPREFIX) ; \
+ $(INSTALL2) attach_save.png $(ICOPREFIX)
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..edcda297ba1e
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,30 @@
+# This is an example PKGBUILD file. Use this as a start to creating your own,
+# and remove these comments. For more information, see 'man PKGBUILD'.
+# NOTE: Please fill out the license field for your package! If it is unknown,
+# then please put 'unknown'.
+
+# Maintainer: Your Name <youremail@domain.com>
+pkgname=kmailpt
+pkgver=0.3
+pkgrel=1
+pkgdesc="KMail Power Tools"
+arch=('i686' 'x86_64')
+url="http://jice.free.fr/kmailpt/"
+license=('GPL')
+depends=('perl-mime-tools')
+options=('!libtool')
+#install=
+#changelog=
+source=(http://jice.free.fr/kmailpt/$pkgname-$pkgver.tar.bz2 Makefile)
+#noextract=()
+md5sums=('c8cff48f33223262d25440a0db01bd10' '23e464c03778228badb091c4dd6ffe73') #generate with 'makepkg -g'
+
+build() {
+ cp -f $srcdir/Makefile $srcdir/$pkgname-$pkgver/
+ cd "$srcdir/$pkgname-$pkgver"
+# ./configure --prefix=/usr
+# make install
+ make DESTDIR="$pkgdir/" install
+}
+
+# vim:set ts=2 sw=2 et: