summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authororhun2020-02-04 10:42:19 +0300
committerorhun2020-02-04 10:42:19 +0300
commit0236edfc9f0ed779882ad268781333cf6ba8788f (patch)
treeb9a627d8baf15b089dc713a9a83e7a7eac481dcf
downloadaur-0236edfc9f0ed779882ad268781333cf6ba8788f.tar.gz
Initial release
-rw-r--r--.SRCINFO19
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD18
3 files changed, 41 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..9dc443056226
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = kmon
+ pkgdesc = Linux kernel manager and activity monitor
+ pkgver = v0.1.0
+ pkgrel = 1
+ url = https://github.com/orhun/kmon
+ arch = x86_64
+ license = GPL3
+ makedepends = cargo
+ makedepends = git
+ depends = libxcb
+ provides = kmon
+ conflicts = kmon
+ conflicts = kmon-git
+ conflicts = kmon-bin
+ source = https://github.com/orhun/kmon/releases/download/v0.1.0/kmon-0.1.0.tar.gz
+ sha256sums = 4162894077d31ea000d18ae501adbd62e87835f584ae2d1f1fb4e849926e7bdf
+
+pkgname = kmon
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..ba7822d168fd
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+/pkg/
+/src/
+*.tar.xz
+*.tar.gz
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..6e3636577a53
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,18 @@
+# Maintainer: orhun <orhunparmaksiz@gmail.com>
+pkgname=kmon
+pkgver=v0.1.0
+pkgrel=1
+pkgdesc="Linux kernel manager and activity monitor"
+arch=('x86_64')
+url="https://github.com/orhun/kmon"
+license=('GPL3')
+depends=('libxcb')
+makedepends=('cargo' 'git')
+provides=("$pkgname")
+conflicts=("$pkgname" "${pkgname}-git" "${pkgname}-bin")
+source=("https://github.com/orhun/$pkgname/releases/download/$pkgver/$pkgname-${pkgver#v}.tar.gz")
+sha256sums=('4162894077d31ea000d18ae501adbd62e87835f584ae2d1f1fb4e849926e7bdf')
+
+package() {
+ install -Dt "$pkgdir/usr/bin/" "$srcdir/kmon"
+} \ No newline at end of file