summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authororhun2020-07-30 01:48:19 +0300
committerorhun2020-07-30 01:48:19 +0300
commit1ea92bf19a7b027c7442f53b7dd428fb0ccfa015 (patch)
treea2d40989bfe5ebf42f3216881511363311eea3c3
parent5509ec4cdfcbc24176a75eb95baf2034383033e0 (diff)
downloadaur-1ea92bf19a7b027c7442f53b7dd428fb0ccfa015.tar.gz
Update PKGBUILD about project source
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD11
2 files changed, 11 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index cbdde598ea10..a226278128a6 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -6,12 +6,15 @@ pkgbase = kmon-bin
arch = x86_64
license = GPL3
makedepends = cargo
- makedepends = git
depends = libxcb
conflicts = kmon
conflicts = kmon-git
+ options = zipman
source = https://github.com/orhun/kmon/releases/download/v1.3.4/kmon-1.3.4.tar.gz
- sha256sums = e5d29deb9758c31e705b065798c1e15059ead4d0e5f692750a2638fd89c4aa92
+ source = https://github.com/orhun/kmon/releases/download/v1.3.4/kmon-1.3.4.tar.gz.sig
+ validpgpkeys = C4B2D24CF87CD188C79D00BB485B7C52E9EC0DC6
+ sha512sums = d509cf9c3978f1e940304508dd4f68f6f12e6b78c8deae56049ebcc19c50ed3a896cfa6e675e0aab6a0b7f8e677641139f5aa2a1ce65ad1623ccff54fd46244e
+ sha512sums = SKIP
pkgname = kmon-bin
diff --git a/PKGBUILD b/PKGBUILD
index 7bf3bd8fa8da..c35c6da7a380 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,15 +7,16 @@ arch=('x86_64')
url="https://github.com/orhun/kmon"
license=('GPL3')
depends=('libxcb')
-makedepends=('cargo' 'git')
+makedepends=('cargo')
+options=('zipman')
conflicts=("${pkgname%-bin}" "${pkgname%-bin}-git")
-source=("https://github.com/orhun/${pkgname%-bin}/releases/download/v$pkgver/${pkgname%-bin}-${pkgver#v}.tar.gz")
-sha256sums=('e5d29deb9758c31e705b065798c1e15059ead4d0e5f692750a2638fd89c4aa92')
+source=("https://github.com/orhun/kmon/releases/download/v$pkgver/${pkgname%-bin}-$pkgver.tar.gz"{,.sig})
+sha512sums=('d509cf9c3978f1e940304508dd4f68f6f12e6b78c8deae56049ebcc19c50ed3a896cfa6e675e0aab6a0b7f8e677641139f5aa2a1ce65ad1623ccff54fd46244e'
+ 'SKIP')
+validpgpkeys=('C4B2D24CF87CD188C79D00BB485B7C52E9EC0DC6') # kmon releases <kmonlinux@protonmail.com>
package() {
install -Dt "$pkgdir/usr/bin/" "$srcdir/kmon"
install -Dm 644 README.md -t "$pkgdir/usr/share/doc/${pkgname%-bin}"
- install -Dm 644 LICENSE -t "$pkgdir/usr/share/licenses/${pkgname%-bin}"
install -Dm 644 "man/${pkgname%-bin}.8" -t "$pkgdir/usr/share/man/man8"
- gzip "$pkgdir/usr/share/man/man8/${pkgname%-bin}.8"
} \ No newline at end of file