summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authororhun2021-07-17 00:40:18 +0300
committerorhun2021-07-17 00:40:18 +0300
commit89e93a25502946c4d2b81530d6d4a0f336ba694d (patch)
treebc33b18bf7c1880cc5dfb361d379201367a6dca5
parent7d1bd9bd49ae0527d53acba2e166d7db0f47d75e (diff)
downloadaur-89e93a25502946c4d2b81530d6d4a0f336ba694d.tar.gz
upgpkg: kmon-bin 1.5.4-1
upstream release
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD24
2 files changed, 20 insertions, 20 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 6d3cb63d6341..fd6bdca94b63 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,20 +1,18 @@
pkgbase = kmon-bin
pkgdesc = Linux kernel manager and activity monitor
- pkgver = 1.4.0
+ pkgver = 1.5.4
pkgrel = 1
url = https://github.com/orhun/kmon
arch = x86_64
license = GPL3
- makedepends = cargo
+ depends = gcc-libs
depends = libxcb
+ provides = kmon
conflicts = kmon
- conflicts = kmon-git
- options = zipman
- source = https://github.com/orhun/kmon/releases/download/v1.4.0/kmon-1.4.0.tar.gz
- source = https://github.com/orhun/kmon/releases/download/v1.4.0/kmon-1.4.0.tar.gz.sig
validpgpkeys = C4B2D24CF87CD188C79D00BB485B7C52E9EC0DC6
- sha512sums = 1dc841640c4d2291de5c45c7a7e115c39bdc00ad3d4950e1b17e71998195d0d88fd5ffbf4cfb5756aee5ff689386986e5c30bd2590ef674025af0915a4ed9153
- sha512sums = SKIP
+ source_x86_64 = https://github.com/orhun/kmon/releases/download/v1.5.4/kmon-1.5.4-x86_64-unknown-linux-gnu.tar.gz
+ source_x86_64 = https://github.com/orhun/kmon/releases/download/v1.5.4/kmon-1.5.4-x86_64-unknown-linux-gnu.tar.gz.sig
+ sha512sums_x86_64 = 6407f328140ae1858e5cf7183b31b0f67ea84b7aab7a2e98b07279b875ef542003430c6862fb73af26efead0bbad59398b7c41cc0dd8473c820ec5c41b64eacd
+ sha512sums_x86_64 = SKIP
pkgname = kmon-bin
-
diff --git a/PKGBUILD b/PKGBUILD
index 74c32740b85b..9c8594ac2fa7 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,22 +1,24 @@
# Maintainer: orhun <orhunparmaksiz@gmail.com>
+# https://github.com/orhun/pkgbuilds
+
pkgname=kmon-bin
-pkgver=1.4.0
+pkgver=1.5.4
pkgrel=1
pkgdesc="Linux kernel manager and activity monitor"
arch=('x86_64')
url="https://github.com/orhun/kmon"
license=('GPL3')
-depends=('libxcb')
-makedepends=('cargo')
-options=('zipman')
-conflicts=("${pkgname%-bin}" "${pkgname%-bin}-git")
-source=("$url/releases/download/v$pkgver/${pkgname%-bin}-$pkgver.tar.gz"{,.sig})
-sha512sums=('1dc841640c4d2291de5c45c7a7e115c39bdc00ad3d4950e1b17e71998195d0d88fd5ffbf4cfb5756aee5ff689386986e5c30bd2590ef674025af0915a4ed9153'
- 'SKIP')
+depends=('gcc-libs' 'libxcb')
+conflicts=("${pkgname%-bin}")
+provides=("${pkgname%-bin}")
+source_x86_64=("$url/releases/download/v$pkgver/${pkgname%-bin}-$pkgver-x86_64-unknown-linux-gnu.tar.gz"{,.sig})
+sha512sums_x86_64=('6407f328140ae1858e5cf7183b31b0f67ea84b7aab7a2e98b07279b875ef542003430c6862fb73af26efead0bbad59398b7c41cc0dd8473c820ec5c41b64eacd'
+ 'SKIP')
validpgpkeys=('C4B2D24CF87CD188C79D00BB485B7C52E9EC0DC6') # kmon releases <kmonlinux@protonmail.com>
package() {
- install -Dt "$pkgdir/usr/bin/" "$srcdir/${pkgname%-bin}"
- install -Dm 644 README.md -t "$pkgdir/usr/share/doc/${pkgname%-bin}"
+ cd "${pkgname%-bin}-$pkgver"
+ install -Dm 755 "${pkgname%-bin}" -t "${pkgdir}/usr/bin"
+ install -Dm 644 README.md -t "$pkgdir/usr/share/doc/$pkgname"
install -Dm 644 "man/${pkgname%-bin}.8" -t "$pkgdir/usr/share/man/man8"
-} \ No newline at end of file
+}