summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authororhun2020-02-04 17:49:33 +0300
committerorhun2020-02-04 17:49:33 +0300
commitb08006b286b0216661dd1934b0a8545e22aa8092 (patch)
tree4d6e846a3f59a720d2ae82e26fb5deafd7900d94
parent82ed76e57943a61769e5a4976e3fac3340170b01 (diff)
downloadaur-b08006b286b0216661dd1934b0a8545e22aa8092.tar.gz
Fix provide info & install README and LICENSE
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD4
2 files changed, 4 insertions, 2 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ac0788469aef..75f126f0355b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -8,7 +8,7 @@ pkgbase = kmon-bin
makedepends = cargo
makedepends = git
depends = libxcb
- provides = kmon-bin
+ provides = kmon
conflicts = kmon-bin
conflicts = kmon-bin-git
conflicts = kmon-bin-bin
diff --git a/PKGBUILD b/PKGBUILD
index 55e56004b818..d13a0f7bdd40 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -8,11 +8,13 @@ url="https://github.com/orhun/kmon"
license=('GPL3')
depends=('libxcb')
makedepends=('cargo' 'git')
-provides=("$pkgname")
+provides=("${pkgname%-bin}")
conflicts=("$pkgname" "${pkgname}-git" "${pkgname}-bin")
source=("https://github.com/orhun/${pkgname%-bin}/releases/download/$pkgver/${pkgname%-bin}-${pkgver#v}.tar.gz")
sha256sums=('5d2310fbae32ba3cba0f37ffa4420692e5ba6c64d5c23f3c3e7207b68b78b610')
package() {
install -Dt "$pkgdir/usr/bin/" "$srcdir/kmon"
+ install -Dm 644 README.md -t "$pkgdir/usr/share/doc/${pkgname%-bin}"
+ install -Dm 644 LICENSE -t "$pkgdir/usr/share/licenses/${pkgname%-bin}"
} \ No newline at end of file