summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorOliver Mangold2020-04-22 13:34:18 +0200
committerOliver Mangold2020-04-22 14:05:36 +0200
commit09598a5201170ccef645563013041a1096a69e61 (patch)
tree78f17474c73cf761d19a6d5f5fd00be5b59cfba8
parent69c9f01871050e604d834db1972a2244f5eb2f17 (diff)
downloadaur-09598a5201170ccef645563013041a1096a69e61.tar.gz
- major rework
- update to version 6.13.0
-rw-r--r--.SRCINFO46
-rw-r--r--PKGBUILD75
-rw-r--r--cmake-boost.patch11
-rw-r--r--kmselements.c.patch10
-rw-r--r--kmsrecorderendpoint.c.patch10
-rw-r--r--kmsrtpendpoint.c.patch10
-rw-r--r--kmswebrtc.c.patch11
-rw-r--r--kmswebrtcendpoint.c.patch10
8 files changed, 88 insertions, 95 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 22e2df686170..c6624eef02a5 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,40 +1,30 @@
pkgbase = kms-elements
- pkgdesc = Kurento elements module
- pkgver = 6.7.1
+ pkgdesc = Kurento server media elements
+ pkgver = 6.13.0
pkgrel = 1
- url = http://www.kurento.org/
+ url = https://github.com/Kurento/kms-elements
arch = any
- license = LGPL v2.1
- makedepends = cmake
- makedepends = libnice
- makedepends = boost-libs
- makedepends = gstreamer
- makedepends = gst-plugins-openwebrtc
- makedepends = libsoup
- makedepends = openssl-1.0
- makedepends = kms-core>=6.7.0
- makedepends = valgrind
- depends = boost-libs
+ license = apache
+ makedepends = kms-cmake-utils
+ makedepends = kurento-module-creator
+ depends = boost
+ depends = kms-core
depends = libnice
depends = gstreamer
- depends = gst-plugins-openwebrtc
- depends = libsoup
- depends = openssl-1.0
- depends = kms-core>=6.7.0
- provides = kms-elements
- conflicts = kms-elements
- source = https://github.com/Kurento/kms-elements/archive/6.7.1.tar.gz
+ depends = gst-plugins-base
+ depends = gst-plugins-bad
+ source = git://github.com/Kurento/kms-elements.git#tag=6.13.0
+ source = cmake-boost.patch
source = kmselements.c.patch
source = kmsrecorderendpoint.c.patch
source = kmsrtpendpoint.c.patch
source = kmswebrtcendpoint.c.patch
- source = kmswebrtc.c.patch
- sha256sums = 880f37343aed8165aa08e8b8f05a99455cfd1f37e59bebc224bf77737ac5d147
- sha256sums = a158f1da9ae727523da02b53b2014fdc5de0a2239b0b187771f3eec6d85defee
- sha256sums = e705e135da4dea3197967ab067c2dde898197b054548baa3337930ca727328c0
- sha256sums = 02e6075f1f29a46a2df13655d3186ac23535de24489047126ed7c25d77afbcf3
- sha256sums = a923b2ebd0cb8ee332c7e5ce7d76d8fa2558c67ddfb1cdeaadb8774853f3cb66
- sha256sums = aa12fece95385cfc6c7522b2afe6101220fa3215b9d03fcb30de7eb1cd06032a
+ sha256sums = SKIP
+ sha256sums = SKIP
+ sha256sums = SKIP
+ sha256sums = SKIP
+ sha256sums = SKIP
+ sha256sums = SKIP
pkgname = kms-elements
diff --git a/PKGBUILD b/PKGBUILD
index 6d7e5ec09250..96f944f26760 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,49 +1,44 @@
-# Maintainer: Alexander Susha <isushik94@gmail.com>
pkgname=kms-elements
-pkgver=6.7.1
+pkgver=6.13.0
pkgrel=1
-pkgdesc='Kurento elements module'
-arch=('any')
-url='http://www.kurento.org/'
-license=('LGPL v2.1')
-depends=('boost-libs' 'libnice' 'gstreamer' 'gst-plugins-openwebrtc' 'libsoup' 'openssl-1.0' 'kms-core>=6.7.0')
-makedepends=('cmake' 'libnice' 'boost-libs' 'gstreamer' 'gst-plugins-openwebrtc' 'libsoup' 'openssl-1.0' 'kms-core>=6.7.0' 'valgrind')
-provides=(${pkgname})
-conflicts=(${pkgname})
-source=("https://github.com/Kurento/${pkgname}/archive/${pkgver}.tar.gz"
- 'kmselements.c.patch'
- 'kmsrecorderendpoint.c.patch'
- 'kmsrtpendpoint.c.patch'
- 'kmswebrtcendpoint.c.patch'
- 'kmswebrtc.c.patch')
-sha256sums=('880f37343aed8165aa08e8b8f05a99455cfd1f37e59bebc224bf77737ac5d147'
- 'a158f1da9ae727523da02b53b2014fdc5de0a2239b0b187771f3eec6d85defee'
- 'e705e135da4dea3197967ab067c2dde898197b054548baa3337930ca727328c0'
- '02e6075f1f29a46a2df13655d3186ac23535de24489047126ed7c25d77afbcf3'
- 'a923b2ebd0cb8ee332c7e5ce7d76d8fa2558c67ddfb1cdeaadb8774853f3cb66'
- 'aa12fece95385cfc6c7522b2afe6101220fa3215b9d03fcb30de7eb1cd06032a')
+pkgdesc="Kurento server media elements"
+arch=(any)
+url="https://github.com/Kurento/kms-elements"
+license=(apache)
+depends=(boost kms-core libnice gstreamer gst-plugins-base gst-plugins-bad)
+makedepends=(kms-cmake-utils kurento-module-creator)
+source=(
+ "git://github.com/Kurento/$pkgname.git#tag=$pkgver"
+ cmake-boost.patch
+ kmselements.c.patch
+ kmsrecorderendpoint.c.patch
+ kmsrtpendpoint.c.patch
+ kmswebrtcendpoint.c.patch
+)
+sha256sums=(SKIP SKIP SKIP SKIP SKIP SKIP)
-prepare(){
- cd ${srcdir}/${pkgname}-${pkgver}
-
- patch -Nup0 < ../kmselements.c.patch
- patch -Nup0 < ../kmsrecorderendpoint.c.patch
- patch -Nup0 < ../kmsrtpendpoint.c.patch
- patch -Nup0 < ../kmswebrtcendpoint.c.patch
- patch -Nup0 < ../kmswebrtc.c.patch
-
- for FILE in $(find . -type f)
- do
- sed -i -E "s/gstreamer\-((\w|\d)+\-)?1\.5/gstreamer-\11.0/g" $FILE
- done
+prepare() {
+ cd "$srcdir/$pkgname"
+ patch -p0 <"$srcdir/cmake-boost.patch"
+ patch -p1 <"$srcdir/kmselements.c.patch"
+ patch -p1 <"$srcdir/kmsrecorderendpoint.c.patch"
+ patch -p1 <"$srcdir/kmsrtpendpoint.c.patch"
+ patch -p1 <"$srcdir/kmswebrtcendpoint.c.patch"
+ sed -ri -e 's#gstreamer((-[-a-z]+)?)-1\.5#gstreamer\1-1.0#g' {,*/,*/*/,*/*/*/,*/*/*/*/}CMakeLists.txt
}
+
build() {
- mkdir -p "build"
- cd "build"
- cmake ${srcdir}/${pkgname}-${pkgver}/. -DCMAKE_BUILD_TYPE=RELEASE -DCMAKE_INSTALL_PREFIX=/usr -DCMAKE_INSTALL_LIBDIR=lib -DCMAKE_C_FLAGS="-Wno-incompatible-pointer-types" -DCMAKE_CXX_FLAGS="-Wno-deprecated-declarations"
+ local builddir=$srcdir/$pkgname/build
+ rm -rf "$builddir"
+ mkdir "$builddir"
+ cd "$builddir"
+ cmake -DCMAKE_MODULE_PATH=/usr/share/cmake/Modules -DCMAKE_INSTALL_PREFIX=/usr -DCMAKE_INSTALL_SYSCONFDIR=/etc -DCMAKE_BUILD_TYPE=Release ..
+ make
}
+
package() {
- make -C build DESTDIR="${pkgdir}" install
- mv ${pkgdir}/usr/etc ${pkgdir}/
+ local builddir=$srcdir/$pkgname/build
+ cd "$builddir"
+ make install DESTDIR="$pkgdir"
}
diff --git a/cmake-boost.patch b/cmake-boost.patch
new file mode 100644
index 000000000000..f49ec020a974
--- /dev/null
+++ b/cmake-boost.patch
@@ -0,0 +1,11 @@
+--- CMakeLists.txt.orig 2020-04-21 14:32:35.483126663 +0200
++++ CMakeLists.txt 2020-04-21 14:33:16.373591566 +0200
+@@ -55,7 +55,7 @@
+ set(GLIBMM_REQUIRED ^2.37)
+
+ include(GenericFind)
+-generic_find(LIBNAME Boost REQUIRED COMPONENTS unit_test_framework)
++find_package(Boost REQUIRED COMPONENTS unit_test_framework)
+ generic_find(LIBNAME gstreamer-1.5 VERSION ${GST_REQUIRED} REQUIRED)
+ generic_find(LIBNAME gstreamer-base-1.5 VERSION ${GST_REQUIRED} REQUIRED)
+ generic_find(LIBNAME gstreamer-video-1.5 VERSION ${GST_REQUIRED} REQUIRED)
diff --git a/kmselements.c.patch b/kmselements.c.patch
index 17a7f58b5cac..37dff58949b0 100644
--- a/kmselements.c.patch
+++ b/kmselements.c.patch
@@ -1,7 +1,9 @@
---- src/gst-plugins/kmselements.c 2018-04-13 16:19:22.852964568 +0300
-+++ src/gst-plugins/kmselements.c 2018-04-14 13:42:12.896190528 +0300
-@@ -65,7 +65,7 @@
-
+diff --git a/src/gst-plugins/kmselements.c b/src/gst-plugins/kmselements.c
+index 51283aa..8d3f00f 100644
+--- a/src/gst-plugins/kmselements.c
++++ b/src/gst-plugins/kmselements.c
+@@ -65,7 +65,7 @@ kurento_init (GstPlugin * kurento)
+
GST_PLUGIN_DEFINE (GST_VERSION_MAJOR,
GST_VERSION_MINOR,
- kmselements,
diff --git a/kmsrecorderendpoint.c.patch b/kmsrecorderendpoint.c.patch
index cfc1f8a529b8..bb1aae1be30f 100644
--- a/kmsrecorderendpoint.c.patch
+++ b/kmsrecorderendpoint.c.patch
@@ -1,7 +1,9 @@
---- src/gst-plugins/recorderendpoint/kmsrecorderendpoint.c 2018-04-13 16:19:22.782963282 +0300
-+++ src/gst-plugins/recorderendpoint/kmsrecorderendpoint.c 2018-04-14 13:45:24.649708246 +0300
-@@ -2049,7 +2049,7 @@
-
+diff --git a/src/gst-plugins/recorderendpoint/kmsrecorderendpoint.c b/src/gst-plugins/recorderendpoint/kmsrecorderendpoint.c
+index 0751d40..296fbc2 100644
+--- a/src/gst-plugins/recorderendpoint/kmsrecorderendpoint.c
++++ b/src/gst-plugins/recorderendpoint/kmsrecorderendpoint.c
+@@ -2050,7 +2050,7 @@ kms_recorder_endpoint_plugin_init (GstPlugin * plugin)
+
GST_PLUGIN_DEFINE (GST_VERSION_MAJOR,
GST_VERSION_MINOR,
- kmsrecorderendpoint,
diff --git a/kmsrtpendpoint.c.patch b/kmsrtpendpoint.c.patch
index a2b3c9167715..0eae4905de5d 100644
--- a/kmsrtpendpoint.c.patch
+++ b/kmsrtpendpoint.c.patch
@@ -1,7 +1,9 @@
---- src/gst-plugins/rtpendpoint/kmsrtpendpoint.c 2018-04-13 16:19:22.822964018 +0300
-+++ src/gst-plugins/rtpendpoint/kmsrtpendpoint.c 2018-04-14 13:46:45.411190394 +0300
-@@ -1160,7 +1160,7 @@
-
+diff --git a/src/gst-plugins/rtpendpoint/kmsrtpendpoint.c b/src/gst-plugins/rtpendpoint/kmsrtpendpoint.c
+index 0e3de82..1ded70b 100644
+--- a/src/gst-plugins/rtpendpoint/kmsrtpendpoint.c
++++ b/src/gst-plugins/rtpendpoint/kmsrtpendpoint.c
+@@ -1183,7 +1183,7 @@ kms_rtp_endpoint_plugin_init (GstPlugin * plugin)
+
GST_PLUGIN_DEFINE (GST_VERSION_MAJOR,
GST_VERSION_MINOR,
- kmsrtpendpoint,
diff --git a/kmswebrtc.c.patch b/kmswebrtc.c.patch
deleted file mode 100644
index bf4db14b3dcc..000000000000
--- a/kmswebrtc.c.patch
+++ /dev/null
@@ -1,11 +0,0 @@
---- src/gst-plugins/webrtcendpoint/kmswebrtc.c 2018-04-14 14:21:33.219543274 +0300
-+++ src/gst-plugins/webrtcendpoint/kmswebrtc.c 2018-04-14 14:25:01.733374656 +0300
-@@ -20,7 +20,7 @@
-
- GST_PLUGIN_DEFINE (GST_VERSION_MAJOR,
- GST_VERSION_MINOR,
-- kmswebrtcendpoint,
-+ webrtcendpoint,
- "Kurento WebRTC endpoint",
- kms_webrtc_endpoint_plugin_init, VERSION, GST_LICENSE_UNKNOWN,
- "Kurento Elements", "http://kurento.com/")
diff --git a/kmswebrtcendpoint.c.patch b/kmswebrtcendpoint.c.patch
index ce769ee15072..ae7147d1fa97 100644
--- a/kmswebrtcendpoint.c.patch
+++ b/kmswebrtcendpoint.c.patch
@@ -1,7 +1,9 @@
---- src/gst-plugins/webrtcendpoint/kmswebrtcendpoint.c 2018-04-13 16:19:22.882965121 +0300
-+++ src/gst-plugins/webrtcendpoint/kmswebrtcendpoint.c 2018-04-14 13:47:11.081661559 +0300
-@@ -861,7 +861,7 @@
-
+diff --git a/src/gst-plugins/webrtcendpoint/kmswebrtcendpoint.c b/src/gst-plugins/webrtcendpoint/kmswebrtcendpoint.c
+index 1884d40..0ef1038 100644
+--- a/src/gst-plugins/webrtcendpoint/kmswebrtcendpoint.c
++++ b/src/gst-plugins/webrtcendpoint/kmswebrtcendpoint.c
+@@ -904,7 +904,7 @@ kms_webrtc_endpoint_plugin_init (GstPlugin * plugin)
+
GST_PLUGIN_DEFINE (GST_VERSION_MAJOR,
GST_VERSION_MINOR,
- kmswebrtcendpoint,