summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlexander Susha2018-04-14 14:56:47 +0300
committerAlexander Susha2018-04-14 14:56:47 +0300
commit4d337ce21bafb9eb80da127e7fb15c99df0506f1 (patch)
tree1d3e25e129662235282c859d610dcd7d8c653391
parent86d06bea0b3ab065927b25095153bc9c81f4f420 (diff)
downloadaur-4d337ce21bafb9eb80da127e7fb15c99df0506f1.tar.gz
Upgrade. Added patches for gstreamer plugins
-rw-r--r--PKGBUILD28
-rw-r--r--kmselements.c.patch11
-rw-r--r--kmsrecorderendpoint.c.patch11
-rw-r--r--kmsrtpendpoint.c.patch11
-rw-r--r--kmswebrtc.c.patch11
-rw-r--r--kmswebrtcendpoint.c.patch11
6 files changed, 77 insertions, 6 deletions
diff --git a/PKGBUILD b/PKGBUILD
index afc75f18ad3b..a5cb40088952 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,21 +1,37 @@
# Maintainer: Alexander Susha <isushik94@gmail.com>
pkgname=kms-elements
-pkgver=6.6.3
+pkgver=6.7.1
pkgrel=1
pkgdesc='Kurento elements module'
arch=('any')
url='http://www.kurento.org/'
license=('LGPL v2.1')
-depends=('boost-libs' 'libnice' 'gstreamer' 'gst-plugins-openwebrtc' 'libsoup' 'openssl-1.0' 'kms-core')
-makedepends=('cmake' 'libnice' 'boost-libs' 'gstreamer' 'gst-plugins-openwebrtc' 'libsoup' 'openssl-1.0' 'kms-core' 'valgrind')
+depends=('boost-libs' 'libnice' 'gstreamer' 'gst-plugins-openwebrtc' 'libsoup' 'openssl-1.0' 'kms-core>=6.7.0')
+makedepends=('cmake' 'libnice' 'boost-libs' 'gstreamer' 'gst-plugins-openwebrtc' 'libsoup' 'openssl-1.0' 'kms-core>=6.7.0' 'valgrind')
provides=(${pkgname})
conflicts=(${pkgname})
-source=("https://github.com/Kurento/${pkgname}/archive/${pkgver}.tar.gz")
-sha256sums=('38b69a36009a17f3f74d822a594bb1faff7e0859733893667bcd936e10dfe26d')
+source=("https://github.com/Kurento/${pkgname}/archive/${pkgver}.tar.gz"
+ 'kmselements.c.patch'
+ 'kmsrecorderendpoint.c.patch'
+ 'kmsrtpendpoint.c.patch'
+ 'kmswebrtcendpoint.c.patch'
+ 'kmswebrtc.c.patch')
+sha256sums=('880f37343aed8165aa08e8b8f05a99455cfd1f37e59bebc224bf77737ac5d147'
+ 'a158f1da9ae727523da02b53b2014fdc5de0a2239b0b187771f3eec6d85defee'
+ 'e705e135da4dea3197967ab067c2dde898197b054548baa3337930ca727328c0'
+ '02e6075f1f29a46a2df13655d3186ac23535de24489047126ed7c25d77afbcf3'
+ 'a923b2ebd0cb8ee332c7e5ce7d76d8fa2558c67ddfb1cdeaadb8774853f3cb66'
+ 'aa12fece95385cfc6c7522b2afe6101220fa3215b9d03fcb30de7eb1cd06032a')
prepare(){
cd ${srcdir}/${pkgname}-${pkgver}
+ patch -Nup0 < ../kmselements.c.patch
+ patch -Nup0 < ../kmsrecorderendpoint.c.patch
+ patch -Nup0 < ../kmsrtpendpoint.c.patch
+ patch -Nup0 < ../kmswebrtcendpoint.c.patch
+ patch -Nup0 < ../kmswebrtc.c.patch
+
for FILE in $(find . -type f)
do
sed -i -E "s/gstreamer\-((\w|\d)+\-)?1\.5/gstreamer-\11.0/g" $FILE
@@ -25,7 +41,7 @@ build() {
mkdir -p "build"
cd "build"
- cmake ${srcdir}/${pkgname}-${pkgver}/. -DCMAKE_BUILD_TYPE=RELEASE -DCMAKE_INSTALL_PREFIX=/usr -DCMAKE_INSTALL_LIBDIR=lib -DCMAKE_CXX_FLAGS="-Wno-deprecated-declarations"
+ cmake ${srcdir}/${pkgname}-${pkgver}/. -DCMAKE_BUILD_TYPE=RELEASE -DCMAKE_INSTALL_PREFIX=/usr -DCMAKE_INSTALL_LIBDIR=lib -DCMAKE_C_FLAGS="-Wno-incompatible-pointer-types" # -DCMAKE_CXX_FLAGS="-Wno-deprecated-declarations"
}
package() {
make -C build DESTDIR="${pkgdir}" install
diff --git a/kmselements.c.patch b/kmselements.c.patch
new file mode 100644
index 000000000000..17a7f58b5cac
--- /dev/null
+++ b/kmselements.c.patch
@@ -0,0 +1,11 @@
+--- src/gst-plugins/kmselements.c 2018-04-13 16:19:22.852964568 +0300
++++ src/gst-plugins/kmselements.c 2018-04-14 13:42:12.896190528 +0300
+@@ -65,7 +65,7 @@
+
+ GST_PLUGIN_DEFINE (GST_VERSION_MAJOR,
+ GST_VERSION_MINOR,
+- kmselements,
++ kmselementsplugins,
+ "Kurento elements",
+ kurento_init, VERSION, GST_LICENSE_UNKNOWN, "Kurento Elements",
+ "http://kurento.com/")
diff --git a/kmsrecorderendpoint.c.patch b/kmsrecorderendpoint.c.patch
new file mode 100644
index 000000000000..cfc1f8a529b8
--- /dev/null
+++ b/kmsrecorderendpoint.c.patch
@@ -0,0 +1,11 @@
+--- src/gst-plugins/recorderendpoint/kmsrecorderendpoint.c 2018-04-13 16:19:22.782963282 +0300
++++ src/gst-plugins/recorderendpoint/kmsrecorderendpoint.c 2018-04-14 13:45:24.649708246 +0300
+@@ -2049,7 +2049,7 @@
+
+ GST_PLUGIN_DEFINE (GST_VERSION_MAJOR,
+ GST_VERSION_MINOR,
+- kmsrecorderendpoint,
++ recorderendpoint,
+ "Kurento recorder endpoint",
+ kms_recorder_endpoint_plugin_init, VERSION, GST_LICENSE_UNKNOWN,
+ "Kurento Elements", "http://kurento.com/")
diff --git a/kmsrtpendpoint.c.patch b/kmsrtpendpoint.c.patch
new file mode 100644
index 000000000000..a2b3c9167715
--- /dev/null
+++ b/kmsrtpendpoint.c.patch
@@ -0,0 +1,11 @@
+--- src/gst-plugins/rtpendpoint/kmsrtpendpoint.c 2018-04-13 16:19:22.822964018 +0300
++++ src/gst-plugins/rtpendpoint/kmsrtpendpoint.c 2018-04-14 13:46:45.411190394 +0300
+@@ -1160,7 +1160,7 @@
+
+ GST_PLUGIN_DEFINE (GST_VERSION_MAJOR,
+ GST_VERSION_MINOR,
+- kmsrtpendpoint,
++ rtpendpoint,
+ "Kurento rtp endpoint",
+ kms_rtp_endpoint_plugin_init, VERSION, GST_LICENSE_UNKNOWN,
+ "Kurento Elements", "http://kurento.com/")
diff --git a/kmswebrtc.c.patch b/kmswebrtc.c.patch
new file mode 100644
index 000000000000..bf4db14b3dcc
--- /dev/null
+++ b/kmswebrtc.c.patch
@@ -0,0 +1,11 @@
+--- src/gst-plugins/webrtcendpoint/kmswebrtc.c 2018-04-14 14:21:33.219543274 +0300
++++ src/gst-plugins/webrtcendpoint/kmswebrtc.c 2018-04-14 14:25:01.733374656 +0300
+@@ -20,7 +20,7 @@
+
+ GST_PLUGIN_DEFINE (GST_VERSION_MAJOR,
+ GST_VERSION_MINOR,
+- kmswebrtcendpoint,
++ webrtcendpoint,
+ "Kurento WebRTC endpoint",
+ kms_webrtc_endpoint_plugin_init, VERSION, GST_LICENSE_UNKNOWN,
+ "Kurento Elements", "http://kurento.com/")
diff --git a/kmswebrtcendpoint.c.patch b/kmswebrtcendpoint.c.patch
new file mode 100644
index 000000000000..ce769ee15072
--- /dev/null
+++ b/kmswebrtcendpoint.c.patch
@@ -0,0 +1,11 @@
+--- src/gst-plugins/webrtcendpoint/kmswebrtcendpoint.c 2018-04-13 16:19:22.882965121 +0300
++++ src/gst-plugins/webrtcendpoint/kmswebrtcendpoint.c 2018-04-14 13:47:11.081661559 +0300
+@@ -861,7 +861,7 @@
+
+ GST_PLUGIN_DEFINE (GST_VERSION_MAJOR,
+ GST_VERSION_MINOR,
+- kmswebrtcendpoint,
++ webrtcendpoint,
+ "Kurento webrtc endpoint",
+ kms_webrtc_endpoint_plugin_init, VERSION, GST_LICENSE_UNKNOWN,
+ "Kurento Elements", "http://kurento.com/")