summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorOliver Mangold2020-04-22 16:03:48 +0200
committerOliver Mangold2020-04-22 16:03:48 +0200
commit188f6f6b0a53679eda8dee416af9c29cb72e70d8 (patch)
treeebb4179777fdbf0137426f3813261fa395580655
parent7b1b5333027b6ca27e19f71aab8b0e6226fec0bd (diff)
downloadaur-188f6f6b0a53679eda8dee416af9c29cb72e70d8.tar.gz
- recreate from scratch
- update to version 6.13.0
-rw-r--r--.SRCINFO43
-rw-r--r--PKGBUILD72
-rw-r--r--cmake-opencv.patch13
-rw-r--r--facedetector.c.patch12
-rw-r--r--faceoverlay.c.patch12
-rw-r--r--imageoverlay.c.patch12
-rw-r--r--logooverlay.c.patch12
-rw-r--r--movementdetector.c.patch12
-rw-r--r--opencvfilter.c.patch10
9 files changed, 139 insertions, 59 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d80554ad9562..1f1a6b471ad2 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,26 +1,31 @@
pkgbase = kms-filters
- pkgdesc = Kurento filters module
- pkgver = 6.7.1
+ pkgdesc = Kurento server AV filters
+ pkgver = 6.13.0
pkgrel = 1
- url = http://www.kurento.org/
+ url = https://github.com/Kurento/kms-filters
arch = any
- license = LGPL v2.1
- makedepends = cmake
- makedepends = pkg-config
- makedepends = libsoup
- makedepends = kms-core>=6.7.0
- makedepends = kms-elements>=6.7.0
- makedepends = opencv
- depends = libsoup
- depends = kms-core>=6.7.0
- depends = kms-elements>=6.7.0
- depends = opencv
- provides = kms-filters
- conflicts = kms-filters
- source = https://github.com/Kurento/kms-filters/archive/6.7.1.tar.gz
+ license = apache
+ makedepends = kms-cmake-utils
+ makedepends = kurento-module-creator
+ depends = kms-core
+ depends = kms-elements
+ depends = opencv3-opt
+ source = git://github.com/Kurento/kms-filters.git#tag=6.13.0
+ source = cmake-opencv.patch
+ source = facedetector.c.patch
+ source = faceoverlay.c.patch
+ source = imageoverlay.c.patch
+ source = logooverlay.c.patch
+ source = movementdetector.c.patch
source = opencvfilter.c.patch
- sha256sums = d26b751e282657c8406bdf6d0d39b8c3472132d7692375437c72ec52adc1b13f
- sha256sums = 36f865b924dcb2fc85e9c00bd06a47daeeccbf633085886b21c288ae5000564a
+ sha256sums = SKIP
+ sha256sums = SKIP
+ sha256sums = SKIP
+ sha256sums = SKIP
+ sha256sums = SKIP
+ sha256sums = SKIP
+ sha256sums = SKIP
+ sha256sums = SKIP
pkgname = kms-filters
diff --git a/PKGBUILD b/PKGBUILD
index 5eacf4575d5e..0d8e2863e43b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,45 +1,45 @@
-# Maintainer: Alexander Susha <isushik94@gmail.com>
pkgname=kms-filters
-pkgver=6.7.1
+pkgver=6.13.0
pkgrel=1
-pkgdesc='Kurento filters module'
-arch=('any')
-url='http://www.kurento.org/'
-license=('LGPL v2.1')
-depends=('libsoup' 'kms-core>=6.7.0' 'kms-elements>=6.7.0' 'opencv')
-makedepends=('cmake' 'pkg-config' 'libsoup' 'kms-core>=6.7.0' 'kms-elements>=6.7.0' 'opencv')
-provides=(${pkgname})
-conflicts=(${pkgname})
-source=("https://github.com/Kurento/${pkgname}/archive/${pkgver}.tar.gz"
- 'opencvfilter.c.patch')
-sha256sums=('d26b751e282657c8406bdf6d0d39b8c3472132d7692375437c72ec52adc1b13f'
- '36f865b924dcb2fc85e9c00bd06a47daeeccbf633085886b21c288ae5000564a')
+pkgdesc="Kurento server AV filters"
+arch=(any)
+url="https://github.com/Kurento/kms-filters"
+license=(apache)
+depends=(kms-core kms-elements opencv3-opt)
+makedepends=(kms-cmake-utils kurento-module-creator)
+source=(
+ "git://github.com/Kurento/$pkgname.git#tag=$pkgver"
+ cmake-opencv.patch
+ facedetector.c.patch
+ faceoverlay.c.patch
+ imageoverlay.c.patch
+ logooverlay.c.patch
+ movementdetector.c.patch
+ opencvfilter.c.patch
+)
+sha256sums=(SKIP SKIP SKIP SKIP SKIP SKIP SKIP SKIP)
-prepare(){
- cd ${srcdir}/${pkgname}-${pkgver}
-
- patch -Nup0 < ../opencvfilter.c.patch
-
- for FILE in $(find . -type f)
- do
- sed -i -E "s/gstreamer\-((\w|\d)+\-)?1\.5/gstreamer-\11.0/g" $FILE
+prepare() {
+ cd "$srcdir/$pkgname"
+ for p in "${source[@]:1}"; do
+ patch -p1 <"$srcdir/$p"
done
-
- sed -i -E "s/set\(OPENCV_REQUIRED \^2\.0\.0\)/set(OPENCV_REQUIRED ^3.0.0)/g" CMakeLists.txt
-
- sed -i -E "s/add_subdirectory\(facedetector\)/#add_subdirectory(facedetector)/g" src/gst-plugins/CMakeLists.txt
- sed -i -E "s/add_subdirectory\(faceoverlay\)/#add_subdirectory(faceoverlay)/g" src/gst-plugins/CMakeLists.txt
- sed -i -E "s/add_subdirectory\(imageoverlay\)/#add_subdirectory(imageoverlay)/g" src/gst-plugins/CMakeLists.txt
- sed -i -E "s/add_subdirectory\(movementdetector\)/#add_subdirectory(movementdetector)/g" src/gst-plugins/CMakeLists.txt
- #sed -i -E "s/add_subdirectory\(opencvfilter\)/#add_subdirectory(opencvfilter)/g" src/gst-plugins/CMakeLists.txt
- sed -i -E "s/add_subdirectory\(logooverlay\)/#add_subdirectory(logooverlay)/g" src/gst-plugins/CMakeLists.txt
+ sed -ri -e 's#gstreamer((-[-a-z]+)?)-1\.5#gstreamer\1-1.0#g' {,*/,*/*/,*/*/*/}CMakeLists.txt
+ sed -ri -e 's#opencv_INCLUDE_DIRS#OpenCV_INCLUDE_DIRS#g' {,*/,*/*/,*/*/*/}CMakeLists.txt
+ sed -ri -e 's#opencv_LIBRARIES#OpenCV_LIBRARIES#g' {,*/,*/*/,*/*/*/}CMakeLists.txt
}
-build() {
- mkdir -p "build"
- cd "build"
- cmake ${srcdir}/${pkgname}-${pkgver}/. -DCMAKE_BUILD_TYPE=RELEASE -DCMAKE_INSTALL_PREFIX=/usr -DCMAKE_INSTALL_LIBDIR=lib -DCMAKE_CXX_FLAGS="-Wno-deprecated-declarations -Wno-catch-value"
+build() {
+ local builddir=$srcdir/$pkgname/build
+ rm -rf "$builddir"
+ mkdir "$builddir"
+ cd "$builddir"
+ cmake -DCMAKE_MODULE_PATH=/usr/share/cmake/Modules -DCMAKE_INSTALL_PREFIX=/usr -DCMAKE_INSTALL_SYSCONFDIR=/etc -DCMAKE_BUILD_TYPE=Release ..
+ make
}
+
package() {
- make -C build DESTDIR="${pkgdir}" install
+ local builddir=$srcdir/$pkgname/build
+ cd "$builddir"
+ make install DESTDIR="$pkgdir"
}
diff --git a/cmake-opencv.patch b/cmake-opencv.patch
new file mode 100644
index 000000000000..8e54f0dcd70b
--- /dev/null
+++ b/cmake-opencv.patch
@@ -0,0 +1,13 @@
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index 8a7196c..bfc3d50 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -59,7 +59,7 @@ generic_find(LIBNAME gstreamer-1.5 VERSION ${GST_REQUIRED} REQUIRED)
+ generic_find(LIBNAME gstreamer-base-1.5 VERSION ${GST_REQUIRED} REQUIRED)
+ generic_find(LIBNAME gstreamer-video-1.5 VERSION ${GST_REQUIRED} REQUIRED)
+ generic_find(LIBNAME gstreamer-check-1.5 VERSION ${GST_REQUIRED})
+-generic_find(LIBNAME opencv VERSION ${OPENCV_REQUIRED} REQUIRED)
++find_package(OpenCV REQUIRED NO_DEFAULT_PATH PATHS /opt/opencv3/share)
+ generic_find(LIBNAME libsoup-2.4 VERSION ${LIBSOUP_REQUIRED} REQUIRED)
+
+ set(CMAKE_INSTALL_GST_PLUGINS_DIR ${CMAKE_INSTALL_LIBDIR}/gstreamer-1.5)
diff --git a/facedetector.c.patch b/facedetector.c.patch
new file mode 100644
index 000000000000..fca707a0f9f9
--- /dev/null
+++ b/facedetector.c.patch
@@ -0,0 +1,12 @@
+diff --git a/src/gst-plugins/facedetector/facedetector.c b/src/gst-plugins/facedetector/facedetector.c
+index 0cab5aa..1e70554 100644
+--- a/src/gst-plugins/facedetector/facedetector.c
++++ b/src/gst-plugins/facedetector/facedetector.c
+@@ -30,6 +30,6 @@ init (GstPlugin * plugin)
+
+ GST_PLUGIN_DEFINE (GST_VERSION_MAJOR,
+ GST_VERSION_MINOR,
+- kmsfacedetector,
++ facedetector,
+ "Kurento facedetector filter",
+ init, VERSION, GST_LICENSE_UNKNOWN, "Kurento", "http://kurento.com/")
diff --git a/faceoverlay.c.patch b/faceoverlay.c.patch
new file mode 100644
index 000000000000..07a16c48eff9
--- /dev/null
+++ b/faceoverlay.c.patch
@@ -0,0 +1,12 @@
+diff --git a/src/gst-plugins/faceoverlay/faceoverlay.c b/src/gst-plugins/faceoverlay/faceoverlay.c
+index 3be7d08..a6162c9 100644
+--- a/src/gst-plugins/faceoverlay/faceoverlay.c
++++ b/src/gst-plugins/faceoverlay/faceoverlay.c
+@@ -30,6 +30,6 @@ init (GstPlugin * plugin)
+
+ GST_PLUGIN_DEFINE (GST_VERSION_MAJOR,
+ GST_VERSION_MINOR,
+- kmsfaceoverlay,
++ faceoverlay,
+ "Kurento faceoverlay filter",
+ init, VERSION, GST_LICENSE_UNKNOWN, "Kurento", "http://kurento.com/")
diff --git a/imageoverlay.c.patch b/imageoverlay.c.patch
new file mode 100644
index 000000000000..116f26e4d1c6
--- /dev/null
+++ b/imageoverlay.c.patch
@@ -0,0 +1,12 @@
+diff --git a/src/gst-plugins/imageoverlay/imageoverlay.c b/src/gst-plugins/imageoverlay/imageoverlay.c
+index a4de535..93ddfdd 100644
+--- a/src/gst-plugins/imageoverlay/imageoverlay.c
++++ b/src/gst-plugins/imageoverlay/imageoverlay.c
+@@ -30,6 +30,6 @@ init (GstPlugin * plugin)
+
+ GST_PLUGIN_DEFINE (GST_VERSION_MAJOR,
+ GST_VERSION_MINOR,
+- kmsimageoverlay,
++ imageoverlay,
+ "Kurento imageoverlay filter",
+ init, VERSION, GST_LICENSE_UNKNOWN, "Kurento", "http://kurento.com/")
diff --git a/logooverlay.c.patch b/logooverlay.c.patch
new file mode 100644
index 000000000000..169c814625a0
--- /dev/null
+++ b/logooverlay.c.patch
@@ -0,0 +1,12 @@
+diff --git a/src/gst-plugins/logooverlay/logooverlay.c b/src/gst-plugins/logooverlay/logooverlay.c
+index ff3910b..4ed7e3d 100644
+--- a/src/gst-plugins/logooverlay/logooverlay.c
++++ b/src/gst-plugins/logooverlay/logooverlay.c
+@@ -30,6 +30,6 @@ init (GstPlugin * plugin)
+
+ GST_PLUGIN_DEFINE (GST_VERSION_MAJOR,
+ GST_VERSION_MINOR,
+- kmslogooverlay,
++ logooverlay,
+ "Kurento logooverlay filter",
+ init, VERSION, GST_LICENSE_UNKNOWN, "Kurento", "http://kurento.com/")
diff --git a/movementdetector.c.patch b/movementdetector.c.patch
new file mode 100644
index 000000000000..9e86ee6ce638
--- /dev/null
+++ b/movementdetector.c.patch
@@ -0,0 +1,12 @@
+diff --git a/src/gst-plugins/movementdetector/movementdetector.c b/src/gst-plugins/movementdetector/movementdetector.c
+index 6cd01fa..6024274 100644
+--- a/src/gst-plugins/movementdetector/movementdetector.c
++++ b/src/gst-plugins/movementdetector/movementdetector.c
+@@ -30,6 +30,6 @@ init (GstPlugin * plugin)
+
+ GST_PLUGIN_DEFINE (GST_VERSION_MAJOR,
+ GST_VERSION_MINOR,
+- kmsmovementdetector,
++ movementdetector,
+ "Kurento movement filter",
+ init, VERSION, GST_LICENSE_UNKNOWN, "Kurento", "http://kurento.com/")
diff --git a/opencvfilter.c.patch b/opencvfilter.c.patch
index 1a2f1f61c69d..7674a36d81af 100644
--- a/opencvfilter.c.patch
+++ b/opencvfilter.c.patch
@@ -1,7 +1,9 @@
---- src/gst-plugins/opencvfilter/opencvfilter.c 2018-04-13 16:22:46.256710296 +0300
-+++ src/gst-plugins/opencvfilter/opencvfilter.c 2018-04-14 14:39:23.549210435 +0300
-@@ -33,6 +33,6 @@
-
+diff --git a/src/gst-plugins/opencvfilter/opencvfilter.c b/src/gst-plugins/opencvfilter/opencvfilter.c
+index f56c0f2..1f2b2aa 100644
+--- a/src/gst-plugins/opencvfilter/opencvfilter.c
++++ b/src/gst-plugins/opencvfilter/opencvfilter.c
+@@ -33,6 +33,6 @@ init (GstPlugin * plugin)
+
GST_PLUGIN_DEFINE (GST_VERSION_MAJOR,
GST_VERSION_MINOR,
- kmsopencvfilter,