summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDāvis Mosāns2022-09-04 20:16:27 +0300
committerDāvis Mosāns2022-09-04 20:23:22 +0300
commitc704f44d1a760e3db6e67d1fb04e21ca657a986d (patch)
tree6e416dd5f794d1236d5ed14ced772c810d03c89b
parent5a239324a700d232c6ee2ca0c9e0dc1a2e9915b4 (diff)
downloadaur-kms-jsonrpc.tar.gz
Fixes
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD13
2 files changed, 11 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 612f38a7dc47..ce1c79443e51 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -9,6 +9,8 @@ pkgbase = kms-jsonrpc
depends = boost
depends = kms-jsoncpp
source = git+https://github.com/Kurento/kms-jsonrpc.git#tag=6.17.0
+ source = cmake-jsoncpp.patch
+ sha256sums = SKIP
sha256sums = SKIP
pkgname = kms-jsonrpc
diff --git a/PKGBUILD b/PKGBUILD
index 6a86f6dba882..31e040aa9476 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,15 +7,20 @@ url="https://github.com/Kurento/kms-jsonrpc"
license=(apache)
depends=(boost kms-jsoncpp)
makedepends=(kms-cmake-utils)
-source=("git+https://github.com/Kurento/$pkgname.git#tag=$pkgver")
-sha256sums=(SKIP)
+source=("git+https://github.com/Kurento/$pkgname.git#tag=$pkgver" 'cmake-jsoncpp.patch')
+sha256sums=(SKIP SKIP)
build() {
- local builddir=$srcdir/$pkgname/build
+ cd "$srcdir/$pkgname"
+
+ # Sadly can't use regular jsoncpp because kms-core depends on some differences
+ #patch -p0 <"../cmake-jsoncpp.patch"
+
+ local builddir="build"
rm -rf "$builddir"
mkdir -p "$builddir"
cd "$builddir"
- cmake -DCMAKE_MODULE_PATH=/usr/share/cmake/Modules -DCMAKE_INSTALL_PREFIX=/usr -DCMAKE_BUILD_TYPE=Release ..
+ cmake -DCMAKE_MODULES_INSTALL_DIR=/usr/share/cmake/Modules -DCMAKE_INSTALL_PREFIX=/usr -DCMAKE_BUILD_TYPE=Release ..
make
}