summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJoão Figueiredo2021-07-09 01:02:21 +0100
committerJoão Figueiredo2021-07-09 01:02:21 +0100
commitade3882a8219185776e4f26b95a0f06f8d5c368f (patch)
tree79856a994f74d4aa9df4142ef49575fc16cca66f
parent71156f096758ca921c5047eeed07ad4989158630 (diff)
downloadaur-ade3882a8219185776e4f26b95a0f06f8d5c368f.tar.gz
Use latest branches
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD37
-rw-r--r--knemo-gcc6.patch31
3 files changed, 18 insertions, 62 deletions
diff --git a/.SRCINFO b/.SRCINFO
index df7eee711b24..f4bcf2dd4982 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,15 +1,15 @@
pkgbase = knemo
pkgdesc = The KDE Network Monitor
- pkgver = 0.7.7.git20151003
- pkgrel = 7
+ pkgver = 1.7.7.1_git20191016
+ pkgrel = 1
url = https://www.linux-apps.com/content/show.php?content=12956
arch = x86_64
license = GPL
+ makedepends = git
makedepends = extra-cmake-modules
makedepends = kcmutils
makedepends = plasma-framework
makedepends = kdoctools
- makedepends = git
makedepends = kdesignerplugin
makedepends = kinit
depends = kdelibs4support
@@ -19,11 +19,7 @@ pkgbase = knemo
depends = iw
depends = plasma-framework
depends = hicolor-icon-theme
- options = libtool
- source = git+https://github.com/KDE/knemo.git#commit=f3afe2e4b6f091f21a64905965abafd2ef46826d
- source = knemo-gcc6.patch
+ source = git+https://github.com/KDE/knemo.git
sha256sums = SKIP
- sha256sums = 840fe4f68ff6b9e801d98482a0b76f42764332d81071589ac3bc5632bfc49d92
pkgname = knemo
-
diff --git a/PKGBUILD b/PKGBUILD
index bf77c9f66334..e4e5a0207836 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,4 +1,4 @@
-# Maintainer: João Figueiredo <jf dot mundox at gmail dot com> (29/05/2020)
+# Maintainer: João Figueiredo <islandc0der@chaotic.cx> (29/05/2020)
# Contributor: Xwang (Fixed a compiling issue, 30/05/2020)
# Contributor: Laurent Carlier <lordheavym@gmail.com>
# Contributor: Andrea Scarpino <andrea@archlinux.org>
@@ -6,40 +6,31 @@
# Contributor: Stefano Zamprogno <stefano dot zamprogno at gmail dot com>
pkgname=knemo
-pkgver=0.7.7.git20151003
-pkgrel=7
+pkgver=1.7.7.1_git20191016
+pkgrel=1
pkgdesc="The KDE Network Monitor"
-arch=('x86_64')
+arch=($CARCH)
url="https://www.linux-apps.com/content/show.php?content=12956"
-license=('GPL')
-depends=('kdelibs4support' 'libksysguard' 'knotifyconfig' 'wireless_tools' 'iw' 'plasma-framework' 'hicolor-icon-theme')
-makedepends=('extra-cmake-modules' 'kcmutils' 'plasma-framework' 'kdoctools' 'git' 'kdesignerplugin' 'kinit')
-options=('libtool')
-_commit=f3afe2e4b6f091f21a64905965abafd2ef46826d # frameworks
-source=("git+https://github.com/KDE/knemo.git#commit=$_commit" 'knemo-gcc6.patch')
-sha256sums=('SKIP'
- '840fe4f68ff6b9e801d98482a0b76f42764332d81071589ac3bc5632bfc49d92')
+license=(GPL)
+depends=(kdelibs4support libksysguard knotifyconfig wireless_tools iw plasma-framework hicolor-icon-theme)
+makedepends=(git extra-cmake-modules kcmutils plasma-framework kdoctools kdesignerplugin kinit)
+source=("git+https://github.com/KDE/$pkgname.git")
+sha256sums=('SKIP')
prepare() {
- mkdir -p build
-
- cd knemo
-# Fix build with GCC 6
- patch -p1 -i ../knemo-gcc6.patch
+ cd $pkgname
+ git merge --no-edit origin/topic-llvm+freebsd_ipv6 origin/frameworks
}
build() {
- cd build
-
- cmake ../${pkgname} \
+ cmake -B build -S $pkgname \
-DCMAKE_BUILD_TYPE=Release \
-DCMAKE_INSTALL_PREFIX=/usr \
-DCMAKE_INSTALL_LIBDIR=lib \
-DBUILD_TESTING=OFF
- make
+ cmake --build build
}
package() {
- cd build
- make DESTDIR="${pkgdir}" install
+ DESTDIR="$pkgdir" cmake --install build
}
diff --git a/knemo-gcc6.patch b/knemo-gcc6.patch
deleted file mode 100644
index cb07b2ac0f05..000000000000
--- a/knemo-gcc6.patch
+++ /dev/null
@@ -1,31 +0,0 @@
---- knemo.orig/src/common/utils.cpp 2016-05-07 14:30:45.888889978 +0000
-+++ knemo/src/common/utils.cpp 2016-05-07 14:32:06.985290816 +0000
-@@ -41,6 +41,7 @@
- #include <KSharedConfig>
- #include <Plasma/Theme>
- #include "data.h"
-+#include "math.h"
- #include "utils.h"
-
- #ifdef __linux__
---- knemo.orig/src/knemod/trayicon.cpp 2015-10-03 17:22:07.000000000 +0000
-+++ knemo/src/knemo/src/knemod/trayicon.cpp 2016-05-07 14:42:30.796566437 +0000
-@@ -22,6 +22,7 @@
- #include "global.h"
- #include "interface.h"
- #include "knemodaemon.h"
-+#include "math.h"
- #include "utils.h"
-
- #ifdef __linux__
---- knemo.orig/src/knemod/trayicon.h 2020-05-30 12:12:20.000000000 +0200
-+++ knemo/src/knemod/trayicon.h 2020-05-30 11:57:03.000000000 +0200
-@@ -24,6 +24,8 @@
-
- #include <KStatusNotifierItem>
-
-+#include <QMap>
-+
- class Interface;
-
- class TrayIcon : public KStatusNotifierItem