summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorNorbert Pfeiler2016-08-04 15:31:55 +0200
committerNorbert Pfeiler2016-08-04 15:31:55 +0200
commit1650616204b1c3b6c756727fb92dc443812fcd1a (patch)
treeed6f6c71e77352a1384d04ab5b51240f0496a588
parenteab680759f360b3ce66c0a2937ceeee9d428a2c2 (diff)
downloadaur-1650616204b1c3b6c756727fb92dc443812fcd1a.tar.gz
workaround redeclaration error
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD5
-rw-r--r--curl.patch13
3 files changed, 21 insertions, 3 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 07503ab3b035..d652c2e85f34 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,9 @@
# Generated by mksrcinfo v8
-# Sat Jul 9 23:59:33 UTC 2016
+# Thu Aug 4 13:28:24 UTC 2016
pkgbase = knossos
pkgdesc = A software tool for the visualization and annotation of 3D image data. It was developed for the rapid reconstruction of neural morphology and connectivity.
pkgver = 4.1.2
- pkgrel = 8
+ pkgrel = 9
url = http://www.knossostool.org/
arch = x86_64
license = GPL2
@@ -19,10 +19,12 @@ pkgbase = knossos
depends = quazip-qt5
depends = snappy
source = https://github.com/knossos-project/knossos/archive/v4.1.2.tar.gz
+ source = curl.patch
source = knossos.desktop
source = qt-5.7.patch
source = quazip.patch
md5sums = c648b510bcec05a914540eea7f577bfa
+ md5sums = 07e9b7ac1ed5ecd0185ae92e61e97bbb
md5sums = 1a2b3733cf5fcb3e1845ce771abb58e9
md5sums = 10ac71de3331013293518da4be88cde6
md5sums = be06cd6e91c80b63b9bfe4184b537d7e
diff --git a/PKGBUILD b/PKGBUILD
index b4dc0d027a82..5e5ef368336a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,7 +5,7 @@
pkgname=knossos
pkgver=4.1.2
-pkgrel=8
+pkgrel=9
arch=('x86_64')
pkgdesc="A software tool for the visualization and annotation of 3D image data. It was developed for the rapid reconstruction of neural morphology and connectivity."
url="http://www.knossostool.org/"
@@ -24,17 +24,20 @@ makedepends=("boost"
"ninja"
)
source=("https://github.com/knossos-project/knossos/archive/v$pkgver.tar.gz"
+ "curl.patch"
"knossos.desktop"
"qt-5.7.patch"
"quazip.patch"
)
md5sums=('c648b510bcec05a914540eea7f577bfa'
+ '07e9b7ac1ed5ecd0185ae92e61e97bbb'
'1a2b3733cf5fcb3e1845ce771abb58e9'
'10ac71de3331013293518da4be88cde6'
'be06cd6e91c80b63b9bfe4184b537d7e')
prepare() {
cd "knossos-$pkgver"
+ patch -p 1 -i ../curl.patch
patch -p 1 -i ../quazip.patch
patch -p 1 -i ../qt-5.7.patch
}
diff --git a/curl.patch b/curl.patch
new file mode 100644
index 000000000000..205b30e2e1af
--- /dev/null
+++ b/curl.patch
@@ -0,0 +1,13 @@
+diff --git a/loader.h b/loader.h
+index ee7f155..e185c2b 100644
+--- a/loader.h
++++ b/loader.h
+@@ -54,7 +54,7 @@
+
+ #define FTP_RETRY_NUM 3
+
+-using CURL = void;
++#include <curl/curl.h>
+
+ struct C_Element {
+ Coordinate coordinate; // coordinate * cubeEdgeLength = minimal coordinate in the cube; NOT center coordinate