summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorNorbert Pfeiler2016-04-09 23:05:30 +0200
committerNorbert Pfeiler2016-04-09 23:05:30 +0200
commit23f0e424252d2fedcec03089e85ac5c35c2df145 (patch)
treea89a3c770afb3f8e183344aed115938ecaffa144
parentf098161880c51c04e8573662eacea43cb304fcc5 (diff)
downloadaur-23f0e424252d2fedcec03089e85ac5c35c2df145.tar.gz
use ninja and remove boost (it actually isn’t needed at runtime either)
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD15
2 files changed, 13 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 5b503663ecd9..71f468f6b540 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,16 +1,16 @@
# Generated by mksrcinfo v8
-# Fri Apr 8 00:43:40 UTC 2016
+# Sat Apr 9 21:05:13 UTC 2016
pkgbase = knossos
pkgdesc = A software tool for the visualization and annotation of 3D image data. It was developed for the rapid reconstruction of neural morphology and connectivity.
pkgver = 4.1.2
- pkgrel = 5
+ pkgrel = 6
url = http://www.knossostool.org/
arch = x86_64
license = GPL2
- makedepends = cmake
makedepends = boost
+ makedepends = cmake
makedepends = libxmu
- depends = boost-libs
+ makedepends = ninja
depends = curl
depends = freeglut
depends = glu
diff --git a/PKGBUILD b/PKGBUILD
index c08cefe76b82..eefcd75f69bf 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,13 +4,12 @@
pkgname=knossos
pkgver=4.1.2
-pkgrel=5
+pkgrel=6
arch=('x86_64')
pkgdesc="A software tool for the visualization and annotation of 3D image data. It was developed for the rapid reconstruction of neural morphology and connectivity."
url="http://www.knossostool.org/"
license=("GPL2")
-depends=("boost-libs"
- "curl"
+depends=("curl"
"freeglut"
"glu"
"glut"
@@ -20,7 +19,11 @@ depends=("boost-libs"
"quazip-qt5"
"snappy"
)
-makedepends=("cmake" "boost" "libxmu") # CMake wants libxmu for GLUT
+makedepends=("boost"
+ "cmake"
+ "libxmu" # CMake wants libxmu for GLUT
+ "ninja"
+)
source=("https://github.com/knossos-project/knossos/archive/v$pkgver.tar.gz"
"knossos.desktop"
"quazip.patch"
@@ -37,8 +40,8 @@ prepare() {
build() {
mkdir -p "build-$CHOST-$pkgname-$pkgver"
cd "build-$CHOST-$pkgname-$pkgver"
- cmake ../knossos-$pkgver
- make
+ cmake -G Ninja ../knossos-$pkgver
+ ninja
}
package() {