summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorNorbert Pfeiler2020-10-21 01:09:09 +0200
committerNorbert Pfeiler2020-10-21 01:10:30 +0200
commit65a980bc5cb53964a89c4d69d632a0440d179da2 (patch)
tree072f54349ef6476835e277b92713326b96bd6c75
parentd6d6c64e24604c72a26da0af1856122bb128b0e2 (diff)
downloadaur-65a980bc5cb53964a89c4d69d632a0440d179da2.tar.gz
accomodate QuaZip 1.0 + compile fixes
-rw-r--r--.SRCINFO4
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD14
3 files changed, 20 insertions, 2 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 6dda6183778a..5c2a8f4fc57f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -18,9 +18,13 @@ pkgbase = knossos
source = https://github.com/knossos-project/knossos/archive/v5.1.tar.gz
source = knossos.desktop
source = GCC8-combat-K5.patch
+ source = https://raw.githubusercontent.com/knossos-project/knossos/f3bfcd80dc582248a59b857609a796d133bb1fa5/CMake/Modules/FindQuaZip.cmake
+ source = https://github.com/knossos-project/knossos/commit/b6f40b52.patch
md5sums = fd97340a07b58b3f1b1543405d893c35
md5sums = 1a2b3733cf5fcb3e1845ce771abb58e9
md5sums = 9e6daa1198b3f819379995d37178e3d1
+ md5sums = b7f68f267e26f86db118cfafbb006ec9
+ md5sums = 64544b58149bc2e0cd7be42944082310
pkgname = knossos
diff --git a/.gitignore b/.gitignore
index c6abb4782e71..e0803717be2d 100644
--- a/.gitignore
+++ b/.gitignore
@@ -4,3 +4,7 @@ pkg
# source archives and generated packages
*.tar.*
+
+# downloaded files
+FindQuaZip.cmake
+b6f40b52.patch
diff --git a/PKGBUILD b/PKGBUILD
index 8ebbedaf6ffa..919b54b760d6 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,7 +5,7 @@
pkgname=knossos
pkgver=5.1
-pkgrel=3
+pkgrel=4
arch=("x86_64")
pkgdesc="A software tool for the visualization and annotation of 3D image data. It was developed for the rapid reconstruction of neural morphology and connectivity."
url="https://knossos.app"
@@ -26,14 +26,24 @@ optdepends=("qt5-imageformats" # Jp2
source=("https://github.com/knossos-project/knossos/archive/v$pkgver.tar.gz"
"knossos.desktop"
"GCC8-combat-K5.patch"
+ "https://raw.githubusercontent.com/knossos-project/knossos/f3bfcd80dc582248a59b857609a796d133bb1fa5/CMake/Modules/FindQuaZip.cmake"
+ "https://github.com/knossos-project/knossos/commit/b6f40b52.patch"
)
md5sums=('fd97340a07b58b3f1b1543405d893c35'
'1a2b3733cf5fcb3e1845ce771abb58e9'
- '9e6daa1198b3f819379995d37178e3d1')
+ '9e6daa1198b3f819379995d37178e3d1'
+ 'b7f68f267e26f86db118cfafbb006ec9'
+ '64544b58149bc2e0cd7be42944082310')
prepare() {
cd "knossos-$pkgver"
patch -p1 -i ../GCC8-combat-K5.patch
+ cp -v ../FindQuaZip.cmake CMake/Modules
+ patch -p 1 -i ../b6f40b52.patch
+ sed 's/auto createGlobalAction/static auto createGlobalAction/' -i widgets/mainwindow.h
+ sed 's/auto threeWaySorting/static auto threeWaySorting/' -i widgets/tools/model_helper.h
+ sed 's/auto blockSelection/static auto blockSelection/' -i widgets/tools/model_helper.h
+ sed 's/auto deltaBlockSelection/static auto deltaBlockSelection/' -i widgets/tools/model_helper.h
}
build() {