summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorNorbert Pfeiler2019-05-02 03:34:45 +0200
committerNorbert Pfeiler2019-05-02 03:34:45 +0200
commita45ad0aae5cc5464502cccd4a81f9183c9fbea36 (patch)
treeab3ccf7eed3dab3a4636622128e185d656a3688a
parentb77b3dd579d0a9623352308212cc22c2de8d3fea (diff)
downloadaur-a45ad0aae5cc5464502cccd4a81f9183c9fbea36.tar.gz
backport GCC8 fix
-rw-r--r--.SRCINFO8
-rw-r--r--GCC8-combat-K5.patch16
-rw-r--r--PKGBUILD23
3 files changed, 36 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 0c5ae719e222..33f858fe6f79 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,10 +1,10 @@
# Generated by mksrcinfo v8
-# Sun Oct 29 12:50:51 UTC 2017
+# Thu May 2 01:34:31 UTC 2019
pkgbase = knossos
pkgdesc = A software tool for the visualization and annotation of 3D image data. It was developed for the rapid reconstruction of neural morphology and connectivity.
pkgver = 5.1
- pkgrel = 1
- url = https://www.knossostool.org/
+ pkgrel = 2
+ url = https://knossos.app
arch = x86_64
license = GPL2
makedepends = boost
@@ -19,8 +19,10 @@ pkgbase = knossos
optdepends = qt5-imageformats
source = https://github.com/knossos-project/knossos/archive/v5.1.tar.gz
source = knossos.desktop
+ source = GCC8-combat-K5.patch
md5sums = fd97340a07b58b3f1b1543405d893c35
md5sums = 1a2b3733cf5fcb3e1845ce771abb58e9
+ md5sums = 9e6daa1198b3f819379995d37178e3d1
pkgname = knossos
diff --git a/GCC8-combat-K5.patch b/GCC8-combat-K5.patch
new file mode 100644
index 000000000000..d38a6d9b691e
--- /dev/null
+++ b/GCC8-combat-K5.patch
@@ -0,0 +1,16 @@
+diff --git a/hash_list.h b/hash_list.h
+index 5e817c6e..94921f83 100644
+--- a/hash_list.h
++++ b/hash_list.h
+@@ -42,9 +42,9 @@ class hash_list {
+ using value_type = T;
+ using size_type = std::size_t;
+ using difference_type = std::ptrdiff_t;
+- using reference = reference;
++// using reference = reference;
+ using const_reference = const T &;
+- using iterator = iterator;
++// using iterator = iterator;
+ using const_iterator = typename decltype(data)::const_iterator;
+ using reverse_iterator = std::reverse_iterator<iterator>;
+ using const_reverse_iterator = std::reverse_iterator<const_iterator>;
diff --git a/PKGBUILD b/PKGBUILD
index 46e536fa6404..e404f65453db 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,17 +5,17 @@
pkgname=knossos
pkgver=5.1
-pkgrel=1
-arch=('x86_64')
+pkgrel=2
+arch=("x86_64")
pkgdesc="A software tool for the visualization and annotation of 3D image data. It was developed for the rapid reconstruction of neural morphology and connectivity."
-url="https://www.knossostool.org/"
+url="https://knossos.app"
license=("GPL2")
depends=("glu"
"qt5-base"
- "qt5-python27-git" # qt5-python27
- "qt5-tools" # Qt5Help
- "quazip-qt5"
- "snappy"
+ "qt5-python27-git" # qt5-python27
+ "qt5-tools" # Qt5Help
+ "quazip-qt5"
+ "snappy"
)
makedepends=("boost"
"cmake"
@@ -25,9 +25,16 @@ optdepends=("qt5-imageformats" # Jp2
)
source=("https://github.com/knossos-project/knossos/archive/v$pkgver.tar.gz"
"knossos.desktop"
+ "GCC8-combat-K5.patch"
)
md5sums=('fd97340a07b58b3f1b1543405d893c35'
- '1a2b3733cf5fcb3e1845ce771abb58e9')
+ '1a2b3733cf5fcb3e1845ce771abb58e9'
+ '9e6daa1198b3f819379995d37178e3d1')
+
+prepare() {
+ cd "knossos-$pkgver"
+ patch -p1 -i ../GCC8-combat-K5.patch
+}
build() {
mkdir -p "build-$CHOST-$pkgname-$pkgver"