summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorNorbert Pfeiler2017-02-12 14:57:29 +0100
committerNorbert Pfeiler2017-02-12 14:57:29 +0100
commitb4b6bfbc54b51b6c6642c8e6b060909ae10dfa67 (patch)
tree48afec596d3520ca0cfea186bfdfb07f866bf989
downloadaur-b4b6bfbc54b51b6c6642c8e6b060909ae10dfa67.tar.gz
v4.1.2 reupload
-rw-r--r--.SRCINFO33
-rw-r--r--.gitignore6
-rw-r--r--PKGBUILD56
-rw-r--r--curl.patch13
-rw-r--r--knossos4.desktop8
-rw-r--r--qt-5.7.patch21
-rw-r--r--quazip.patch43
7 files changed, 180 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..b2c749cefdcc
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,33 @@
+# Generated by mksrcinfo v8
+# Fri Feb 3 11:09:49 UTC 2017
+pkgbase = knossos4
+ pkgdesc = A software tool for the visualization and annotation of 3D image data. It was developed for the rapid reconstruction of neural morphology and connectivity.
+ pkgver = 4.1.2
+ pkgrel = 10
+ url = http://www.knossostool.org/
+ arch = x86_64
+ license = GPL2
+ makedepends = boost
+ makedepends = cmake
+ makedepends = libxmu
+ makedepends = ninja
+ depends = curl
+ depends = glu
+ depends = glut
+ depends = qt5-python27
+ depends = qt5-tools
+ depends = quazip-qt5
+ depends = snappy
+ source = https://github.com/knossos-project/knossos/archive/v4.1.2.tar.gz
+ source = curl.patch
+ source = knossos4.desktop
+ source = qt-5.7.patch
+ source = quazip.patch
+ md5sums = c648b510bcec05a914540eea7f577bfa
+ md5sums = 07e9b7ac1ed5ecd0185ae92e61e97bbb
+ md5sums = 1b91bbbcdc3e18e6686b5a61f0f587e4
+ md5sums = 10ac71de3331013293518da4be88cde6
+ md5sums = be06cd6e91c80b63b9bfe4184b537d7e
+
+pkgname = knossos4
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..c6abb4782e71
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,6 @@
+# makepkg folders
+src
+pkg
+
+# source archives and generated packages
+*.tar.*
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..a4c20e290dbc
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,56 @@
+# Maintainer: KNOSSOS-Team <knossos-team ät mpimf-heidelberg.mpg.de>
+# Contributor: Martin Drawitsch <mdraw.gh ät gmail.com>
+#
+# KNOSSOS saves its user preferences in $HOME/.config/MPIMF/
+
+pkgname=knossos4
+pkgver=4.1.2
+pkgrel=10
+arch=('x86_64')
+pkgdesc="A software tool for the visualization and annotation of 3D image data. It was developed for the rapid reconstruction of neural morphology and connectivity."
+url="http://www.knossostool.org/"
+license=("GPL2")
+depends=("curl"
+ "glu"
+ "glut"
+ "qt5-python27"
+ "qt5-tools"
+ "quazip-qt5"
+ "snappy"
+)
+makedepends=("boost"
+ "cmake"
+ "libxmu" # CMake wants libxmu for GLUT
+ "ninja"
+)
+source=("https://github.com/knossos-project/knossos/archive/v$pkgver.tar.gz"
+ "curl.patch"
+ "knossos4.desktop"
+ "qt-5.7.patch"
+ "quazip.patch"
+)
+md5sums=('c648b510bcec05a914540eea7f577bfa'
+ '07e9b7ac1ed5ecd0185ae92e61e97bbb'
+ '1b91bbbcdc3e18e6686b5a61f0f587e4'
+ '10ac71de3331013293518da4be88cde6'
+ 'be06cd6e91c80b63b9bfe4184b537d7e')
+
+prepare() {
+ cd "knossos-$pkgver"
+ patch -p 1 -i ../curl.patch
+ patch -p 1 -i ../quazip.patch
+ patch -p 1 -i ../qt-5.7.patch
+}
+
+build() {
+ mkdir -p "build-$CHOST-$pkgname-$pkgver"
+ cd "build-$CHOST-$pkgname-$pkgver"
+ cmake -G Ninja ../knossos-$pkgver
+ ninja
+}
+
+package() {
+ install -Dm755 "build-$CHOST-$pkgname-$pkgver/knossos" "$pkgdir/usr/bin/knossos4"
+ install -Dm644 "knossos-$pkgver/resources/icons/knossos.png" "$pkgdir/usr/share/pixmaps/knossos4.png"
+ install -Dm644 "knossos4.desktop" "$pkgdir/usr/share/applications/knossos4.desktop"
+}
diff --git a/curl.patch b/curl.patch
new file mode 100644
index 000000000000..205b30e2e1af
--- /dev/null
+++ b/curl.patch
@@ -0,0 +1,13 @@
+diff --git a/loader.h b/loader.h
+index ee7f155..e185c2b 100644
+--- a/loader.h
++++ b/loader.h
+@@ -54,7 +54,7 @@
+
+ #define FTP_RETRY_NUM 3
+
+-using CURL = void;
++#include <curl/curl.h>
+
+ struct C_Element {
+ Coordinate coordinate; // coordinate * cubeEdgeLength = minimal coordinate in the cube; NOT center coordinate
diff --git a/knossos4.desktop b/knossos4.desktop
new file mode 100644
index 000000000000..a446c9ba8f32
--- /dev/null
+++ b/knossos4.desktop
@@ -0,0 +1,8 @@
+[Desktop Entry]
+Type=Application
+Name=KNOSSOS 4
+Comment=3D image visualisation and annotation tool
+Categories=Qt;Science;
+Exec=/usr/bin/knossos4
+Icon=/usr/share/pixmaps/knossos4.png
+Terminal=false
diff --git a/qt-5.7.patch b/qt-5.7.patch
new file mode 100644
index 000000000000..2859de80db76
--- /dev/null
+++ b/qt-5.7.patch
@@ -0,0 +1,21 @@
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index 55cf225..270b4b1 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -25,6 +25,8 @@ file(GLOB_RECURSE widgets ./widgets/*.cpp ./widgets/*.h)
+ file(GLOB_RECURSE docimages ./resources/doc/images/*)
+ set(SRC_LIST ${openjpeg} ${root} ${segmentation} ${scriptengine} ${skeleton} ${widgets})
+
++set(CMAKE_CXX_STANDARD 11)
++set(CMAKE_CXX_EXTENSIONS OFF)
+ set(CMAKE_AUTOMOC ON)
+ set(CMAKE_AUTORCC ON)#resources.qrc
+ set(CMAKE_INCLUDE_CURRENT_DIR ON)
+@@ -156,7 +158,6 @@ set_target_properties(${PROJECT_NAME} PROPERTIES INSTALL_RPATH "$ORIGIN")
+ #uncomment if you are to lazy to do »ninja install« to get the RPATH
+ set_target_properties(${PROJECT_NAME} PROPERTIES BUILD_WITH_INSTALL_RPATH TRUE)
+
+-set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -std=c++11")
+ #target_compile_options(${PROJECT_NAME} PRIVATE "-fcolor-diagnostics")
+ target_compile_options(${PROJECT_NAME} PRIVATE "-Wall" "-Wextra" "-Wpedantic")
+
diff --git a/quazip.patch b/quazip.patch
new file mode 100644
index 000000000000..977beb0acfec
--- /dev/null
+++ b/quazip.patch
@@ -0,0 +1,43 @@
+diff --git a/cmake/Modules/FindQuaZip.cmake b/cmake/Modules/FindQuaZip.cmake
+index 2f543c0..d882d23 100644
+--- a/cmake/Modules/FindQuaZip.cmake
++++ b/cmake/Modules/FindQuaZip.cmake
+@@ -2,8 +2,8 @@
+
+ find_package(ZLIB REQUIRED)
+
+-find_library(QUAZIP_LIBRARY quazip PATH_SUFFIXES "QuaZip")
+-find_path(QUAZIP_INCLUDE_DIR quazip/quazip.h)
++find_library(QUAZIP_LIBRARY NAMES quazip quazip5 PATH_SUFFIXES "QuaZip")
++find_path(QUAZIP_INCLUDE_DIR quazip.h PATH_SUFFIXES quazip quazip5)
+
+ include(FindPackageHandleStandardArgs)
+ find_package_handle_standard_args(QUAZIP
+diff --git a/file_io.cpp b/file_io.cpp
+index 02673f3..6a62dad 100644
+--- a/file_io.cpp
++++ b/file_io.cpp
+@@ -6,7 +6,7 @@
+
+ #include <QStandardPaths>
+
+-#include <quazip/quazipfile.h>
++#include <quazipfile.h>
+
+ #include "segmentation/segmentation.h"
+ #include "skeleton/skeletonizer.h"
+diff --git a/loader.cpp b/loader.cpp
+index 90ef79f..7e47224 100644
+--- a/loader.cpp
++++ b/loader.cpp
+@@ -29,8 +29,8 @@
+ #include "session.h"
+ #include "viewer.h"
+
+-#include <quazip/quazip.h>
+-#include <quazip/quazipfile.h>
++#include <quazip.h>
++#include <quazipfile.h>
+
+ #include <snappy.h>
+