summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorOndřej Surý2016-02-10 21:49:32 +0100
committerOndřej Surý2016-02-10 21:50:06 +0100
commit20377fcd048c2fd12f27d029f82b9df0482ed945 (patch)
tree6ee2355270eb2e109ae490a9ca97931ffba57b12
parentcc1b4823da4d4126498b90bb519cbfd4f70efe5f (diff)
downloadaur-20377fcd048c2fd12f27d029f82b9df0482ed945.tar.gz
Update knot to 2.1.1
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD17
-rw-r--r--nettle-3.2.patch37
3 files changed, 10 insertions, 56 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 02e495854f4e..4575114ee0fd 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,9 @@
# Generated by mksrcinfo v8
-# Fri Feb 5 14:58:39 UTC 2016
+# Wed Feb 10 20:49:59 UTC 2016
pkgbase = knot
pkgdesc = high-performance authoritative-only DNS server
- pkgver = 2.1.0
- pkgrel = 4
+ pkgver = 2.1.1
+ pkgrel = 1
url = https://www.knot-dns.cz/
install = install
arch = i686
@@ -19,14 +19,12 @@ pkgbase = knot
depends = zlib
depends = lmdb
depends = jansson
- source = https://secure.nic.cz/files/knot-dns/knot-2.1.0.tar.xz
+ source = https://secure.nic.cz/files/knot-dns/knot-2.1.1.tar.xz
source = knot.service
source = knot.tmpfiles
- source = nettle-3.2.patch
- sha256sums = 1f6ea98da000386bf86e015655a9ec974d361b62711caf06b55f3d9bb2aa85a9
+ sha256sums = e110d11d4a4c4b5abb091b32fcb073934fb840046e975234323e0fc15f2f8f5b
sha256sums = caa870a9c93c57c6311f9e8fb5685a9179bb9839a27a30cc1712c91df0d15090
sha256sums = 592ffb904b697b8c09ab95b3874ad00637333f1805ab2ab0ee50b4f484108ee2
- sha256sums = 568f8d0e4a535b23ac3c00c62957ab3ec99b64a69c6f5d5613cb4b8caedd45e6
pkgname = knot
diff --git a/PKGBUILD b/PKGBUILD
index 0664dfb1a51d..67b87e9d3ecc 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,8 +4,8 @@
srcname=knot
pkgname=${srcname}
-pkgver=2.1.0
-pkgrel=4
+pkgver=2.1.1
+pkgrel=1
pkgdesc='high-performance authoritative-only DNS server'
url='https://www.knot-dns.cz/'
arch=('i686' 'x86_64')
@@ -15,17 +15,10 @@ depends=('liburcu>=0.5.4' 'gnutls>=3.0' 'zlib' 'lmdb' 'jansson')
makedepends=('autoconf>=2.65' 'libtool' 'flex>=2.5.3' 'bison>=2.3', 'pkg-config')
source=("https://secure.nic.cz/files/knot-dns/${srcname}-${pkgver}.tar.xz"
'knot.service'
- 'knot.tmpfiles'
- 'nettle-3.2.patch')
-sha256sums=('1f6ea98da000386bf86e015655a9ec974d361b62711caf06b55f3d9bb2aa85a9'
+ 'knot.tmpfiles')
+sha256sums=('e110d11d4a4c4b5abb091b32fcb073934fb840046e975234323e0fc15f2f8f5b'
'caa870a9c93c57c6311f9e8fb5685a9179bb9839a27a30cc1712c91df0d15090'
- '592ffb904b697b8c09ab95b3874ad00637333f1805ab2ab0ee50b4f484108ee2'
- '568f8d0e4a535b23ac3c00c62957ab3ec99b64a69c6f5d5613cb4b8caedd45e6')
-
-prepare() {
- cd "${srcdir}"/${pkgname}-${pkgver}
- patch -Np1 -i ../nettle-3.2.patch
-}
+ '592ffb904b697b8c09ab95b3874ad00637333f1805ab2ab0ee50b4f484108ee2')
build() {
cd "${srcdir}/${srcname}-${pkgver}"
diff --git a/nettle-3.2.patch b/nettle-3.2.patch
deleted file mode 100644
index f1fd4415dfad..000000000000
--- a/nettle-3.2.patch
+++ /dev/null
@@ -1,37 +0,0 @@
-diff --git a/src/dnssec/lib/binary.c b/src/dnssec/lib/binary.c
-index 454dc5a..f462006 100644
---- a/src/dnssec/lib/binary.c
-+++ b/src/dnssec/lib/binary.c
-@@ -15,25 +15,21 @@
- */
-
- #include <assert.h>
--#include <nettle/base64.h>
- #include <string.h>
-+#include <nettle/base64.h>
-+#ifdef HAVE_NETTLE_VERSION_H
-+#include <nettle/version.h>
-+#endif
-
- #include "binary.h"
- #include "error.h"
- #include "shared.h"
-
--typedef
--#ifdef HAVE_NETTLE_VERSION_H
-- #include <nettle/version.h>
-- #if NETTLE_VERSION_MAJOR >= 3
-- size_t
-- #else
-- unsigned
-- #endif
-+#if NETTLE_VERSION_MAJOR >= 3
-+typedef size_t nettle_len;
- #else
-- unsigned
-+typedef unsigned nettle_len;
- #endif
--nettle_len;
-
- static size_t base64_decode_raw(const uint8_t *src, size_t src_len,
- uint8_t *dst, size_t dst_max_size)