summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorOndřej Surý2016-01-21 10:07:49 +0100
committerOndřej Surý2016-01-21 10:14:00 +0100
commit6eb8130086203e7a0a6fa9c35bf1343afa5bf940 (patch)
treef35570634b0038df32a78776b2ff09258a724eac
parent3226b269d9c48ae949969c632b8e56e5995f752d (diff)
downloadaur-6eb8130086203e7a0a6fa9c35bf1343afa5bf940.tar.gz
Update knot to 2.1.0-1
-rw-r--r--.SRCINFO11
-rw-r--r--PKGBUILD21
-rw-r--r--install7
3 files changed, 25 insertions, 14 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d0240da0b9eb..de45453d94fb 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,8 @@
+# Generated by mksrcinfo v8
+# Thu Jan 21 09:13:52 UTC 2016
pkgbase = knot
pkgdesc = high-performance authoritative-only DNS server
- pkgver = 1.6.4
+ pkgver = 2.1.0
pkgrel = 1
url = https://www.knot-dns.cz/
install = install
@@ -12,12 +14,13 @@ pkgbase = knot
makedepends = flex>=2.5.3
makedepends = bison>=2.3
depends = liburcu>=0.5.4
- depends = openssl>=1.0.0
+ depends = gnutls>=3.0
depends = zlib
depends = liblmdb
- source = https://secure.nic.cz/files/knot-dns/knot-1.6.4.tar.xz
+ depends = jansson
+ source = https://secure.nic.cz/files/knot-dns/knot-2.1.0.tar.xz
source = knot.service
- sha256sums = 7d0809ad489bbbc3f7904687559ee750f3c1f3a7180fab238ba06fcedd00d8af
+ sha256sums = 1f6ea98da000386bf86e015655a9ec974d361b62711caf06b55f3d9bb2aa85a9
sha256sums = caa870a9c93c57c6311f9e8fb5685a9179bb9839a27a30cc1712c91df0d15090
pkgname = knot
diff --git a/PKGBUILD b/PKGBUILD
index d3c0551a62e3..690f9bec2f5f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,23 +2,24 @@
# Contributor: Oleander Reis <oleander@oleander.cc>
# Contributor: Otto Sabart <seberm[at]gmail[dot]com>
-pkgname=knot
-pkgver=1.6.4
+srcname=knot
+pkgname=${srcname}
+pkgver=2.1.0
pkgrel=1
pkgdesc='high-performance authoritative-only DNS server'
url='https://www.knot-dns.cz/'
arch=('i686' 'x86_64')
license=('GPL3')
install=install
-depends=('liburcu>=0.5.4' 'openssl>=1.0.0' 'zlib' 'liblmdb')
+depends=('liburcu>=0.5.4' 'gnutls>=3.0' 'zlib' 'liblmdb' 'jansson')
makedepends=('autoconf>=2.65' 'libtool' 'flex>=2.5.3' 'bison>=2.3')
-source=("https://secure.nic.cz/files/knot-dns/${pkgname}-${pkgver}.tar.xz"
+source=("https://secure.nic.cz/files/knot-dns/${srcname}-${pkgver}.tar.xz"
'knot.service')
-sha256sums=('7d0809ad489bbbc3f7904687559ee750f3c1f3a7180fab238ba06fcedd00d8af'
+sha256sums=('1f6ea98da000386bf86e015655a9ec974d361b62711caf06b55f3d9bb2aa85a9'
'caa870a9c93c57c6311f9e8fb5685a9179bb9839a27a30cc1712c91df0d15090')
build() {
- cd "${srcdir}/${pkgname}-${pkgver}"
+ cd "${srcdir}/${srcname}-${pkgver}"
./configure \
--prefix /usr \
@@ -34,18 +35,18 @@ build() {
}
check() {
- cd "${srcdir}/${pkgname}-${pkgver}"
- make check
+ cd "${srcdir}/${srcname}-${pkgver}"
+ make check
}
package() {
- cd "${srcdir}/${pkgname}-${pkgver}"
+ cd "${srcdir}/${srcname}-${pkgver}"
make DESTDIR="${pkgdir}/" install
install -Dm 644 "${srcdir}/knot.service" "${pkgdir}/usr/lib/systemd/system/knot.service"
}
check() {
- cd "${srcdir}/${pkgname}-${pkgver}"
+ cd "${srcdir}/${srcname}-${pkgver}"
make check
}
diff --git a/install b/install
index 90ece5b423ff..04c6b71c6ffc 100644
--- a/install
+++ b/install
@@ -3,6 +3,13 @@ post_install() {
getent passwd knot &>/dev/null || useradd -r -g knot -d /dev/null -s /bin/false -c knot knot >/dev/null
chown knot:knot /var/lib/knot
chmod 700 /var/lib/knot
+
+ if [ -r /etc/knot/knot.conf -a ! -r /etc/knot/knot.conf.pacorig ]; then
+ knot1to2 --in /etc/knot/knot.conf --out /etc/knot/knot.conf.pacnew
+ mv /etc/knot/knot.conf /etc/knot/knot.conf.pacorig
+ mv /etc/knot/knot.conf.pacnew /etc/knot/knot.conf
+ echo 'warning: Old Knot DNS 1.6 configuration has beend saved as /etc/knot/knot.conf.pacorig'
+ fi
}
post_remove() {