summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTomas Krizek2020-08-06 17:07:36 +0200
committerTomas Krizek2020-08-06 17:07:36 +0200
commit30c6f62e94a30e9e95b8beb9599ab18c96191ac5 (patch)
tree98d06ab95580f59dbce62ddb1f46eabb31ed7d59
parent828a47ce91118efd1353668c06845bc30133b05c (diff)
downloadaur-30c6f62e94a30e9e95b8beb9599ab18c96191ac5.tar.gz
generate stable pkgver from git
-rw-r--r--PKGBUILD6
1 files changed, 3 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 22fb4c6d83da..8420d6a68e7e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,7 +6,7 @@
# Contributor: Otto Sabart <seberm[at]gmail[dot]com>
pkgname=knot-git
-pkgver=3.0.dev.1577784203.e80907080
+pkgver=3.0.dev.r527.1e6928a83
pkgrel=1
pkgdesc="High-performance authoritative-only DNS server, development build"
arch=('x86_64')
@@ -43,12 +43,12 @@ prepare() {
}
pkgver() {
- grep 'PACKAGE_VERSION' "${_gitname}/src/config.h" | sed 's/.*"\(.*\)"/\1/'
+ cd "${_gitname}"
+ printf "%s" "$(git describe --match 'v*' --long | sed 's/^v//;s/\([^-]*-\)g/r\1/;s/-/./g')"
}
build() {
cd "${_gitname}"
-
make
}