summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPetr Špaček2022-10-20 14:59:35 +0200
committerPetr Špaček2022-10-20 14:59:35 +0200
commit7e7a2440baca3081da9427beaf83fb355a98696e (patch)
tree56ff8f0a8511eebe9a978ab11478c5667f16eab5
parent931d982b17d44173ea265f2c1e9465e75d9bed7c (diff)
downloadaur-7e7a2440baca3081da9427beaf83fb355a98696e.tar.gz
enable QUIC support, add libxdp required for libbpf >= 1.0.0
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD10
2 files changed, 14 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 88a5d066c23e..9250f3d0079a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = knot-git
pkgdesc = High-performance authoritative-only DNS server, development build
- pkgver = 3.0.dev.r527.1e6928a83
+ pkgver = 3.3.dev.r78.f6670ca01
pkgrel = 1
url = https://www.knot-dns.cz/
arch = x86_64
@@ -21,7 +21,12 @@ pkgbase = knot-git
depends = fstrm
depends = protobuf-c
depends = libmaxminddb
- provides = knot=3.0.dev.r527.1e6928a83
+ depends = libbpf
+ depends = libxdp
+ depends = libnghttp2
+ depends = libmnl
+ depends = ngtcp2-git
+ provides = knot=3.3.dev.r78.f6670ca01
conflicts = knot
options = !strip
options = debug
@@ -30,4 +35,3 @@ pkgbase = knot-git
sha256sums = SKIP
pkgname = knot-git
-
diff --git a/PKGBUILD b/PKGBUILD
index 8420d6a68e7e..c630211815b6 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,7 +6,7 @@
# Contributor: Otto Sabart <seberm[at]gmail[dot]com>
pkgname=knot-git
-pkgver=3.0.dev.r527.1e6928a83
+pkgver=3.3.dev.r78.f6670ca01
pkgrel=1
pkgdesc="High-performance authoritative-only DNS server, development build"
arch=('x86_64')
@@ -14,7 +14,8 @@ url="https://www.knot-dns.cz/"
license=('GPL3')
depends=('libedit' 'gnutls' 'liburcu' 'lmdb'
'libidn2' 'systemd' 'libcap-ng'
- 'fstrm' 'protobuf-c' 'libmaxminddb')
+ 'fstrm' 'protobuf-c' 'libmaxminddb'
+ 'libbpf' 'libxdp' 'libnghttp2' 'libmnl' 'ngtcp2-git')
makedepends=('git' 'automake' 'autoconf' 'make' 'libtool' 'pkg-config')
provides=("${pkgname%-git}=${pkgver}")
conflicts=("${pkgname%-git}")
@@ -37,9 +38,11 @@ prepare() {
--with-storage=/var/lib/knot \
--enable-recvmmsg \
--enable-dnstap \
+ --enable-quic \
--enable-systemd \
--enable-reuseport \
- --disable-silent-rules &>/dev/null
+ --disable-silent-rules \
+ --enable-fastparser
}
pkgver() {
@@ -49,6 +52,7 @@ pkgver() {
build() {
cd "${_gitname}"
+
make
}