summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPetr Špaček2019-02-26 11:47:57 +0100
committerPetr Špaček2019-02-26 11:48:05 +0100
commitcf023bce2423cb250264b96ce58b0039b9ada0f1 (patch)
treea5bed37398f4b256099957c565b40c66d80662f7
downloadaur-cf023bce2423cb250264b96ce58b0039b9ada0f1.tar.gz
development version of Knot DNS from Git repo
-rw-r--r--.SRCINFO33
-rw-r--r--PKGBUILD72
2 files changed, 105 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..219c7f7201f7
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,33 @@
+pkgbase = knot-git
+ pkgdesc = High-performance authoritative-only DNS server, development build
+ pkgver = 2.8_git
+ pkgrel = 1
+ url = https://www.knot-dns.cz/
+ arch = x86_64
+ license = GPL3
+ makedepends = git
+ makedepends = automake
+ makedepends = autoconf
+ makedepends = make
+ makedepends = libtool
+ makedepends = pkg-config
+ depends = libedit
+ depends = gnutls
+ depends = liburcu
+ depends = lmdb
+ depends = libidn2
+ depends = systemd
+ depends = libcap-ng
+ depends = fstrm
+ depends = protobuf-c
+ depends = libmaxminddb
+ conflicts = knot
+ options = !strip
+ options = debug
+ backup = etc/knot/knot.conf
+ source = git+https://gitlab.labs.nic.cz/knot/knot-dns.git
+ sha256sums = SKIP
+
+pkgname = knot-git
+ provides = knot=2.8_git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..2eb816f739f1
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,72 @@
+# Maintainer: Petr Špaček <petr.spacek@nic.cz>
+# Contributor: Bruno Pagani <archange@archlinux.org>
+# Contributor: Ondřej Surý <ondrej@sury.org>
+# Contributor: Julian Brost <julian@0x4a42.net>
+# Contributor: Oleander Reis <oleander@oleander.cc>
+# Contributor: Otto Sabart <seberm[at]gmail[dot]com>
+
+pkgname=knot-git
+pkgver=2.8_git # overriden by hack in package()
+pkgrel=1
+pkgdesc="High-performance authoritative-only DNS server, development build"
+conflicts=('knot')
+# provides=('knot') # see packaging()
+arch=('x86_64')
+url="https://www.knot-dns.cz/"
+license=('GPL3')
+depends=('libedit' 'gnutls' 'liburcu' 'lmdb'
+ 'libidn2' 'systemd' 'libcap-ng'
+ 'fstrm' 'protobuf-c' 'libmaxminddb')
+makedepends=('git' 'automake' 'autoconf' 'make' 'libtool' 'pkg-config')
+backup=('etc/knot/knot.conf')
+source=("git+https://gitlab.labs.nic.cz/knot/knot-dns.git")
+sha256sums=('SKIP')
+options=(!strip debug)
+_gitname='knot-dns'
+
+build() {
+ cd "${_gitname}"
+
+ ./autogen.sh
+ ./configure \
+ --prefix=/usr \
+ --sbindir=/usr/bin \
+ --sysconfdir=/etc \
+ --localstatedir=/var/lib \
+ --libexecdir=/usr/lib/knot \
+ --with-rundir=/run/knot \
+ --with-storage=/var/lib/knot \
+ --enable-recvmmsg \
+ --enable-dnstap \
+ --enable-systemd \
+ --enable-reuseport \
+ --disable-silent-rules
+
+ make
+}
+
+check() {
+ cd "${_gitname}"
+ make check
+}
+
+package() {
+ cd "${_gitname}"
+
+ make DESTDIR="${pkgdir}" install
+
+ # Don’t keep those empty dir, manage them with systemd-tmpfiles instead
+ rmdir "${pkgdir}"/{var/{lib/{knot/,},},run/{knot/,}}
+
+ rm "${pkgdir}"/etc/knot/example.com.zone
+ mv "${pkgdir}"/etc/knot/{knot.sample.conf,knot.conf}
+
+ install -Dm644 distro/common/knot.service -t "${pkgdir}"/usr/lib/systemd/system/
+ install -Dm644 distro/arch/knot.tmpfiles.arch "${pkgdir}"/usr/lib/tmpfiles.d/${pkgname}.conf
+ install -Dm644 distro/arch/knot.sysusers "${pkgdir}"/usr/lib/sysusers.d/${pkgname}.conf
+
+ # Pull structured version number from installation, e.g. 2.8.dev.1551174394.44b39298a
+ pkgver="$(PKG_CONFIG_PATH="${pkgdir}"/usr/lib/pkgconfig pkg-config libknot --modversion)"
+ # Add versioned "provides" so dependent packages like Knot Resolver can be installed
+ provides=("knot=${pkgver}")
+}