summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPetr Špaček2019-12-31 10:27:53 +0100
committerPetr Špaček2019-12-31 10:27:59 +0100
commite63dd67ed49cfe9da14cbaad47d7a10a3c532f79 (patch)
treec53ba993cba64e9a70f5e782aac41284ed451fb3
parent13be1a03480a8f1b4c0e93cf020b13e4487e1084 (diff)
downloadaur-e63dd67ed49cfe9da14cbaad47d7a10a3c532f79.tar.gz
fix installation using yay
According to https://aur.archlinux.org/packages/knot-git/#comment-721351 yay needs stable output from pkgver() so we now provide that.
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD9
2 files changed, 8 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 449df4696590..fa0798ee711c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = knot-git
pkgdesc = High-performance authoritative-only DNS server, development build
- pkgver = 2.8.dev.1551283912.4015475b0
+ pkgver = 3.0.dev.1577784203.e80907080
pkgrel = 1
url = https://www.knot-dns.cz/
arch = x86_64
@@ -21,7 +21,7 @@ pkgbase = knot-git
depends = fstrm
depends = protobuf-c
depends = libmaxminddb
- provides = knot=2.8.dev.1551283912.4015475b0
+ provides = knot=3.0.dev.1577784203.e80907080
conflicts = knot
options = !strip
options = debug
diff --git a/PKGBUILD b/PKGBUILD
index 493cdc3ba2ef..68f4f6c73ee6 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,7 +6,7 @@
# Contributor: Otto Sabart <seberm[at]gmail[dot]com>
pkgname=knot-git
-pkgver=2.8.dev.1551283912.4015475b0
+pkgver=3.0.dev.1577784203.e80907080
pkgrel=1
pkgdesc="High-performance authoritative-only DNS server, development build"
arch=('x86_64')
@@ -24,7 +24,7 @@ sha256sums=('SKIP')
options=(!strip debug)
_gitname='knot-dns'
-pkgver() {
+prepare() {
cd "${_gitname}"
./autogen.sh &>/dev/null
./configure \
@@ -40,7 +40,10 @@ pkgver() {
--enable-systemd \
--enable-reuseport \
--disable-silent-rules &>/dev/null
- grep 'PACKAGE_VERSION' src/config.h | sed 's/.*"\(.*\)"/\1/'
+}
+
+pkgver() {
+ grep 'PACKAGE_VERSION' "${_gitname}/src/config.h" | sed 's/.*"\(.*\)"/\1/'
}
build() {