summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTomas Krizek2018-08-21 14:30:09 +0200
committerTomas Krizek2018-08-21 14:35:20 +0200
commit34be16068bbd153d6e97d226979e3c15378345e5 (patch)
tree749e6e6cb96ae704f9e98e458363fd4453e02a41
parentaacd2045a9727842a5d7f66360875f6092c33d27 (diff)
downloadaur-34be16068bbd153d6e97d226979e3c15378345e5.tar.gz
update to 3.0.0
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD30
-rw-r--r--kresd.conf20
-rw-r--r--root.keys2
4 files changed, 17 insertions, 47 deletions
diff --git a/.SRCINFO b/.SRCINFO
index a548b7b06820..8e4496a071e9 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = knot-resolver
pkgdesc = full caching DNS resolver implementation
- pkgver = 2.4.1
+ pkgver = 3.0.0
pkgrel = 1
url = https://www.knot-resolver.cz/
install = install
@@ -8,7 +8,7 @@ pkgbase = knot-resolver
license = GPL3
depends = cmocka
depends = gnutls
- depends = knot>=2.6.7
+ depends = knot>=2.7.1
depends = libedit
depends = libsystemd
depends = libuv
@@ -19,12 +19,8 @@ pkgbase = knot-resolver
options = debug
options = strip
backup = etc/knot-resolver/kresd.conf
- source = https://secure.nic.cz/files/knot-resolver/knot-resolver-2.4.1.tar.xz
- source = kresd.conf
- source = root.keys
- sha256sums = e8044316cd897ad29b3c5284de06652e1568c4d5861e3147ec2191fbacd8d9ff
- sha256sums = 929658c7432252d5123ff11ee07759c595c8f5a3f4320a62d451a5f69cd2254a
- sha256sums = 06c74ef5ef53344c78c9af2b29dc458a2abe93f1bff429705955c033e7a0686f
+ source = https://secure.nic.cz/files/knot-resolver/knot-resolver-3.0.0.tar.xz
+ sha256sums = 68a0137e0e15061ee7dec53a2e424aa3266611720db3843853c6e7774a414f40
pkgname = knot-resolver
diff --git a/PKGBUILD b/PKGBUILD
index 3693ff17122a..24a395256c71 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
# Contributor: Ondřej Surý <ondrej@sury.org>
pkgname=knot-resolver
-pkgver=2.4.1
+pkgver=3.0.0
pkgrel=1
pkgdesc='full caching DNS resolver implementation'
url='https://www.knot-resolver.cz/'
@@ -12,24 +12,20 @@ backup=('etc/knot-resolver/kresd.conf')
options=(debug strip)
install=install
depends=('cmocka'
- 'gnutls'
- 'knot>=2.6.7'
- 'libedit'
- 'libsystemd'
+ 'gnutls'
+ 'knot>=2.7.1'
+ 'libedit'
+ 'libsystemd'
'libuv'
- 'lmdb'
- 'lua51-sec'
- 'lua51-socket'
- 'luajit')
-source=("https://secure.nic.cz/files/${pkgname}/${pkgname}-${pkgver}.tar.xz"
- "kresd.conf"
- "root.keys")
+ 'lmdb'
+ 'lua51-sec'
+ 'lua51-socket'
+ 'luajit')
+source=("https://secure.nic.cz/files/${pkgname}/${pkgname}-${pkgver}.tar.xz")
_makevars="PREFIX=/usr SBINDIR=/usr/bin LIBDIR=/usr/lib INCLUDEDIR=/usr/include ETCDIR=/etc/knot-resolver V=1"
-sha256sums=('e8044316cd897ad29b3c5284de06652e1568c4d5861e3147ec2191fbacd8d9ff'
- '929658c7432252d5123ff11ee07759c595c8f5a3f4320a62d451a5f69cd2254a'
- '06c74ef5ef53344c78c9af2b29dc458a2abe93f1bff429705955c033e7a0686f')
+sha256sums=('68a0137e0e15061ee7dec53a2e424aa3266611720db3843853c6e7774a414f40')
build() {
cd "${srcdir}/${pkgname}-${pkgver}"
@@ -55,6 +51,6 @@ package() {
install -Dm 0644 "${srcdir}/${pkgname}-${pkgver}/distro/common/systemd/kresd.systemd.7" "${pkgdir}/usr/share/man/man7/kresd.systemd.7"
install -Dm 0644 "${srcdir}/${pkgname}-${pkgver}/distro/common/tmpfiles/knot-resolver.conf" "${pkgdir}/usr/lib/tmpfiles.d/knot-resolver.conf"
install -dm 0775 "${pkgdir}/etc/knot-resolver"
- install -Dm 0644 "${srcdir}/kresd.conf" "${pkgdir}/etc/knot-resolver/kresd.conf"
- install -Dm 0664 "${srcdir}/root.keys" "${pkgdir}/etc/knot-resolver/root.keys"
+ install -Dm 0644 "${srcdir}/${pkgname}-${pkgver}/distro/common/kresd.conf" "${pkgdir}/etc/knot-resolver/kresd.conf"
+ install -Dm 0664 "${srcdir}/${pkgname}-${pkgver}/distro/common/root.keys" "${pkgdir}/etc/knot-resolver/root.keys"
}
diff --git a/kresd.conf b/kresd.conf
deleted file mode 100644
index 81034c07eadb..000000000000
--- a/kresd.conf
+++ /dev/null
@@ -1,20 +0,0 @@
--- vim:syntax=lua:
--- Refer to manual: http://knot-resolver.readthedocs.org/en/latest/daemon.html#configuration
-
--- Load useful modules
-modules = {
- 'policy', -- Block queries to local zones/bad sites
- 'hints', -- Load /etc/hosts and allow custom root hints
- 'stats', -- Track internal statistics
- 'predict', -- Prefetch expiring/frequent records
-}
-
--- See kresd.systemd(7) about configuring network interfaces when using systemd
--- Listen on localhost (default)
--- net = { '127.0.0.1', '::1' }
-
--- Enable DNSSEC validation
-trust_anchors.file = '/etc/knot-resolver/root.keys'
-
--- Cache size
-cache.size = 100 * MB
diff --git a/root.keys b/root.keys
deleted file mode 100644
index 7578e0405d9d..000000000000
--- a/root.keys
+++ /dev/null
@@ -1,2 +0,0 @@
-. IN DS 19036 8 2 49AAC11D7B6F6446702E54A1607371607A1A41855200FD2CE1CDDE32F24E8FB5
-. IN DS 20326 8 2 E06D44B80B8F1D39A95C0B0D7C65D08458E880409BBC683457104237C7F8EC8D