summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAntonio Rojas2015-06-08 22:46:27 +0200
committerAntonio Rojas2015-06-08 22:46:27 +0200
commit1ded219ea3fa1b4fde18e9a1dce87a69b1aec333 (patch)
tree8453c9a7e58ac30abb647fcce6da8273eeaf895b
downloadaur-1ded219ea3fa1b4fde18e9a1dce87a69b1aec333.tar.gz
Initial import
-rw-r--r--.SRCINFO24
-rw-r--r--PKGBUILD41
2 files changed, 65 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..72b98a134de1
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,24 @@
+pkgbase = knotifications-git
+ pkgdesc = KNotifications
+ pkgver = r108.b792a14
+ pkgrel = 1
+ url = https://projects.kde.org/projects/frameworks/knotifications
+ arch = i686
+ arch = x86_64
+ groups = kf5
+ license = LGPL
+ makedepends = extra-cmake-modules-git
+ makedepends = git
+ makedepends = qt5-tools
+ makedepends = python
+ depends = libdbusmenu-qt5
+ depends = phonon-qt5
+ depends = kservice-git
+ depends = kiconthemes-git
+ provides = knotifications
+ conflicts = knotifications
+ source = git://anongit.kde.org/knotifications.git
+ md5sums = SKIP
+
+pkgname = knotifications-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..e16d3fcd3c56
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,41 @@
+# Maintainer: Andrea Scarpino <andrea@archlinux.org>
+
+pkgname=knotifications-git
+pkgver=r108.b792a14
+pkgrel=1
+pkgdesc='KNotifications'
+arch=('i686' 'x86_64')
+url='https://projects.kde.org/projects/frameworks/knotifications'
+license=('LGPL')
+depends=('libdbusmenu-qt5' 'phonon-qt5' 'kservice-git' 'kiconthemes-git')
+makedepends=('extra-cmake-modules-git' 'git' 'qt5-tools' 'python')
+groups=('kf5')
+conflicts=(knotifications)
+provides=(knotifications)
+source=('git://anongit.kde.org/knotifications.git')
+md5sums=('SKIP')
+
+pkgver() {
+ cd knotifications
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+prepare() {
+ mkdir -p build
+}
+
+build() {
+ cd build
+ cmake ../knotifications \
+ -DCMAKE_BUILD_TYPE=Release \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DLIB_INSTALL_DIR=lib \
+ -DKDE_INSTALL_USE_QT_SYS_PATHS=ON \
+ -DBUILD_TESTING=OFF
+ make
+}
+
+package() {
+ cd build
+ make DESTDIR="$pkgdir" install
+}