summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJoão Figueiredo2021-02-01 23:29:23 +0000
committerJoão Figueiredo2021-02-01 23:29:23 +0000
commitb89362ad176e09a20cdae2eb2a4f1d3b16da0d14 (patch)
tree99764e085b369fa6944b34fb0e5fa4024e88774a
parent721bcbd4777215293a6885cf2d863d96d517a276 (diff)
downloadaur-b89362ad176e09a20cdae2eb2a4f1d3b16da0d14.tar.gz
Merged with official ABS knotifications PKGBUILD
-rw-r--r--.SRCINFO22
-rw-r--r--PKGBUILD48
2 files changed, 33 insertions, 37 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 160b93962867..ba73501fc232 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,25 +1,27 @@
pkgbase = knotifications-git
- pkgdesc = KNotifications
- pkgver = v4.100.0.rc1.r459.ged8dbab
- pkgrel = 2
- url = https://projects.kde.org/projects/frameworks/knotifications
- arch = i686
+ pkgdesc = Abstraction for system notifications
+ pkgver = 5.79.0_r609.g61a0e6e
+ pkgrel = 1
+ url = https://community.kde.org/Frameworks
arch = x86_64
+ groups = kf5-git
license = LGPL
- makedepends = extra-cmake-modules-git
makedepends = git
+ makedepends = extra-cmake-modules-git
makedepends = qt5-tools
- makedepends = python
+ makedepends = qt5-doc
+ makedepends = doxygen
+ depends = libcanberra
depends = libdbusmenu-qt5
- depends = phonon-qt5
depends = kwindowsystem-git
- depends = kcodecs-git
depends = kconfig-git
depends = kcoreaddons-git
+ depends = qt5-speech
+ depends = libxtst
provides = knotifications
conflicts = knotifications
source = git+https://github.com/KDE/knotifications.git
- md5sums = SKIP
+ sha256sums = SKIP
pkgname = knotifications-git
diff --git a/PKGBUILD b/PKGBUILD
index 572bb1503c66..4a8bf31ec831 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,41 +1,35 @@
-# Maintainer: João Figueiredo <jf dot mundox at gmail dot com>
+# Merged with official ABS knotifications PKGBUILD by João, 2021/02/01 (all respective contributors apply herein)
+# Maintainer: João Figueiredo <jf.mundox@gmail.com>
# Contributor: Andrea Scarpino <andrea@archlinux.org>
pkgname=knotifications-git
-pkgver=v4.100.0.rc1.r459.ged8dbab
-pkgrel=2
-pkgdesc='KNotifications'
-arch=(i686 x86_64)
-url='https://projects.kde.org/projects/frameworks/knotifications'
+pkgver=5.79.0_r609.g61a0e6e
+pkgrel=1
+pkgdesc='Abstraction for system notifications'
+arch=($CARCH)
+url='https://community.kde.org/Frameworks'
license=(LGPL)
-depends=(libdbusmenu-qt5 phonon-qt5 kwindowsystem-git kcodecs-git kconfig-git kcoreaddons-git)
-makedepends=(extra-cmake-modules-git git qt5-tools python)
-conflicts=(knotifications)
-provides=(knotifications)
-source=('git+https://github.com/KDE/knotifications.git')
-md5sums=('SKIP')
+depends=(libcanberra libdbusmenu-qt5 kwindowsystem-git kconfig-git kcoreaddons-git qt5-speech libxtst)
+makedepends=(git extra-cmake-modules-git qt5-tools qt5-doc doxygen)
+conflicts=(${pkgname%-git})
+provides=(${pkgname%-git})
+groups=(kf5-git)
+source=("git+https://github.com/KDE/${pkgname%-git}.git")
+sha256sums=('SKIP')
pkgver() {
cd ${pkgname%-git}
- git describe --long | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
-}
-
-prepare() {
- mkdir -p build
+ _ver="$(grep -m1 "set(KF5\?_VERSION" CMakeLists.txt | cut -d '"' -f2 | tr - .)"
+ echo "${_ver}_r$(git rev-list --count HEAD).g$(git rev-parse --short HEAD)"
}
build() {
- cd build
- cmake ../knotifications \
- -DCMAKE_BUILD_TYPE=Release \
- -DCMAKE_INSTALL_PREFIX=/usr \
- -DKDE_INSTALL_LIBDIR=lib \
- -DKDE_INSTALL_USE_QT_SYS_PATHS=ON \
- -DBUILD_TESTING=OFF
- make
+ cmake -B build -S ${pkgname%-git} \
+ -DBUILD_TESTING=OFF \
+ -DBUILD_QCH=ON
+ cmake --build build
}
package() {
- cd build
- make DESTDIR="$pkgdir" install
+ DESTDIR="$pkgdir" cmake --install build
}