summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMattia Basaglia2021-01-25 08:50:10 +0000
committerMattia Basaglia2021-01-25 08:50:10 +0000
commitf3df20afd2addab7e9d77132b945c7ed29829fc8 (patch)
treeb777aa0f1d1495cdf6693e1e3d7231fc862c279b
downloadaur-f3df20afd2addab7e9d77132b945c7ed29829fc8.tar.gz
Created the knotter package
-rw-r--r--.SRCINFO24
-rw-r--r--PKGBUILD43
2 files changed, 67 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..ef4910d0c741
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,24 @@
+pkgbase = knotter
+ pkgdesc = Editor for Celtic knots and similar designs
+ pkgver = 0.9.6_46_gef7229f
+ pkgrel = 1
+ url = https://knotter.mattbas.org/
+ arch = x86_64
+ arch = i686
+ arch = armv7h
+ arch = aarch64
+ license = GPL3
+ makedepends = git
+ makedepends = cmake
+ makedepends = qt5-tools
+ depends = qt5-base
+ depends = qt5-svg
+ depends = qt5-script
+ depends = hicolor-icon-theme
+ provides = knotter
+ conflicts = knotter
+ source = knotter::git+https://gitlab.com/mattbas/knotter/#branch=master
+ sha256sums = SKIP
+
+pkgname = knotter
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..c33dbea3b260
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,43 @@
+# Maintainer: Mattia Basaglia glax@dragon.best
+_corpname=knotter
+_pkgname='knotter'
+pkgname="$_pkgname"
+pkgver=0.9.6_46_gef7229f
+pkgrel=1
+pkgdesc="Editor for Celtic knots and similar designs"
+url="https://knotter.mattbas.org/"
+license=('GPL3')
+arch=('x86_64' 'i686' 'armv7h' 'aarch64')
+makedepends=('git' 'cmake' 'qt5-tools')
+depends=('qt5-base' 'qt5-svg' 'qt5-script' 'hicolor-icon-theme')
+provides=("$_pkgname")
+conflicts=("$_pkgname")
+source=(
+ "$_pkgname::git+https://gitlab.com/mattbas/$_pkgname/#branch=master"
+)
+sha256sums=('SKIP')
+
+prepare() {
+ cd "$_pkgname/"
+
+ git submodule update --init --recursive
+}
+
+pkgver() {
+ cd "$srcdir/$_pkgname/"
+ git describe --tags | tr - _
+}
+
+build() {
+ cd "$srcdir/$_pkgname/"
+ mkdir build
+ cd build
+ cmake .. -DCMAKE_INSTALL_PREFIX=/usr
+ make -j 4
+}
+
+package() {
+ cd "$srcdir/$_pkgname/build"
+ make install DESTDIR=$pkgdir >/dev/null
+}
+