summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorzxp198210052024-03-15 18:09:52 +0800
committerzxp198210052024-03-15 18:09:52 +0800
commitcddea1cf49d30fd212fc0b8e36ce4ac3755e24df (patch)
treed77d2618b4e8c346b8ff1ef4b7193c81b229bd3d
parent5565640a8804470889eb3b4aa30d88c7a6bfc34a (diff)
downloadaur-cddea1cf49d30fd212fc0b8e36ce4ac3755e24df.tar.gz
fix errors
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD7
-rw-r--r--knowte.sh8
3 files changed, 12 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 3e140371ef65..0d1d1a5207de 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,17 +1,17 @@
pkgbase = knowte-bin
pkgdesc = A note taking application that allows you to quickly and easily organize and find your notes.
pkgver = 3.0.0
- pkgrel = 3
+ pkgrel = 4
url = https://github.com/digimezzo/knowte
arch = x86_64
license = GPL-3.0-only
- depends = electron17
+ depends = electron17-bin
depends = hicolor-icon-theme
provides = knowte=3.0.0
conflicts = knowte
source = knowte-3.0.0.pacman::https://github.com/digimezzo/knowte/releases/download/v3.0.0/Knowte-3.0.0.pacman
source = knowte.sh
sha256sums = 6f7ad45262020e24c66536d627442b27601109d434e0d5870de2d48519fe2750
- sha256sums = 0fb7b939a071f4a08476bdd5aa143d2aa8cd335c83309f9919be16cd5c3e2014
+ sha256sums = dc0c5ca385ad81a08315a91655c7c064b5bf110eada55e61265633ae198b39f8
pkgname = knowte-bin
diff --git a/PKGBUILD b/PKGBUILD
index f48c3d28f870..371074300bdf 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@ pkgname=knowte-bin
_pkgname=Knowte
pkgver=3.0.0
_electronversion=17
-pkgrel=3
+pkgrel=4
pkgdesc="A note taking application that allows you to quickly and easily organize and find your notes."
arch=('x86_64')
url="https://github.com/digimezzo/knowte"
@@ -11,7 +11,7 @@ license=('GPL-3.0-only')
provides=("${pkgname%-bin}=${pkgver}")
conflicts=("${pkgname%-bin}")
depends=(
- "electron${_electronversion}"
+ "electron${_electronversion}-bin"
'hicolor-icon-theme'
)
source=(
@@ -19,11 +19,12 @@ source=(
"${pkgname%-bin}.sh"
)
sha256sums=('6f7ad45262020e24c66536d627442b27601109d434e0d5870de2d48519fe2750'
- '0fb7b939a071f4a08476bdd5aa143d2aa8cd335c83309f9919be16cd5c3e2014')
+ 'dc0c5ca385ad81a08315a91655c7c064b5bf110eada55e61265633ae198b39f8')
build() {
sed -e "s|@electronversion@|${_electronversion}|" \
-e "s|@appname@|${pkgname%-bin}|g" \
-e "s|@appasar@|app.asar|g" \
+ -e "s|@options@||g" \
-i "${srcdir}/${pkgname%-bin}.sh"
sed "s|/opt/${_pkgname}/${pkgname%-bin}|${pkgname%-bin}|g" -i "${srcdir}/usr/share/applications/${pkgname%-bin}.desktop"
}
diff --git a/knowte.sh b/knowte.sh
index f9ced1432cfc..7ddcaab8d734 100644
--- a/knowte.sh
+++ b/knowte.sh
@@ -1,14 +1,16 @@
-#!/bin/sh
+#!/bin/bash
set -e
_APPDIR="/usr/lib/@appname@"
_RUNNAME="${_APPDIR}/@runname@"
+_OPTIONS="@options@"
export PATH="${_APPDIR}:${PATH}"
export LD_LIBRARY_PATH="${_APPDIR}/swiftshader:${_APPDIR}/lib:${LD_LIBRARY_PATH}"
export ELECTRON_IS_DEV=0
+export ELECTRON_FORCE_IS_PACKAGED=true
export NODE_ENV=production
cd "${_APPDIR}"
if [[ $EUID -ne 0 ]] || [[ $ELECTRON_RUN_AS_NODE ]]; then
- exec electron@electronversion@ "${_RUNNAME}" "$@" || exit $?
+ exec electron@electronversion@ "${_RUNNAME}" "${_OPTIONS}" "$@" || exit $?
else
- exec electron@electronversion@ "${_RUNNAME}" --no-sandbox "$@" || exit $?
+ exec electron@electronversion@ "${_RUNNAME}" "${_OPTIONS}" --no-sandbox "$@" || exit $?
fi \ No newline at end of file