summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorzxp198210052023-10-26 16:50:02 +0800
committerzxp198210052023-10-26 16:50:02 +0800
commitf25b194c57b391b9ac130857bb8d14cd9c3bf686 (patch)
treeb8db40f6000184eaba3639525add8a3c71a3eca3
downloadaur-f25b194c57b391b9ac130857bb8d14cd9c3bf686.tar.gz
update to 3.0.0
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD34
-rw-r--r--knowte.sh11
3 files changed, 63 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..f1e299f62a30
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = knowte-bin
+ pkgdesc = A note taking application that allows you to quickly and easily organize and find your notes.
+ pkgver = 3.0.0
+ pkgrel = 1
+ url = https://github.com/digimezzo/knowte
+ arch = x86_64
+ license = GPL3
+ depends = bash
+ depends = electron17
+ depends = hicolor-icon-theme
+ provides = knowte=3.0.0
+ conflicts = knowte
+ source = knowte-3.0.0.pacman::https://github.com/digimezzo/knowte/releases/download/v3.0.0/Knowte-3.0.0.pacman
+ source = knowte.sh
+ sha256sums = 6f7ad45262020e24c66536d627442b27601109d434e0d5870de2d48519fe2750
+ sha256sums = 4e0dab5e13e4673f344daec0c791702767db3c7a1545dff5355baef378112224
+
+pkgname = knowte-bin
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..64d5a9674807
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,34 @@
+# Maintainer: zxp19821005 <zxp19821005 at 163 dot com>
+pkgname=knowte-bin
+_pkgname=Knowte
+pkgver=3.0.0
+pkgrel=1
+pkgdesc="A note taking application that allows you to quickly and easily organize and find your notes."
+arch=('x86_64')
+url="https://github.com/digimezzo/knowte"
+license=('GPL3')
+provides=("${pkgname%-bin}=${pkgver}")
+conflicts=("${pkgname%-bin}")
+depends=(
+ 'bash'
+ 'electron17'
+ 'hicolor-icon-theme'
+)
+source=("${pkgname%-bin}-${pkgver}.pacman::${url}/releases/download/v${pkgver}/${_pkgname}-${pkgver}.pacman"
+ "${pkgname%-bin}.sh")
+sha256sums=('6f7ad45262020e24c66536d627442b27601109d434e0d5870de2d48519fe2750'
+ '4e0dab5e13e4673f344daec0c791702767db3c7a1545dff5355baef378112224')
+build() {
+ sed "s|/opt/${_pkgname}/${pkgname%-bin} %U|${pkgname%-bin}|g" -i "${srcdir}/usr/share/applications/${pkgname%-bin}.desktop"
+}
+package() {
+ install -Dm755 "${srcdir}/${pkgname%-bin}.sh" "${pkgdir}/usr/bin/${pkgname%-bin}"
+ install -Dm644 "${srcdir}/opt/${_pkgname}/resources/app.asar" -t "${pkgdir}/usr/lib/${pkgname%-bin}"
+ install -Dm644 "${srcdir}/opt/${_pkgname}/swiftshader/"*.so -t "${pkgdir}/usr/lib/${pkgname%-bin}/swiftshader"
+ install -Dm644 "${srcdir}/opt/${_pkgname}/resources/LICENSE" -t "${pkgdir}/usr/share/licenses"
+ for _icons in 16x16 24x24 32x32 48x48 64x64 96x96 128x128 256x256 512x512;do
+ install -Dm644 "${srcdir}/usr/share/icons/hicolor/${_icons}/apps/${pkgname%-bin}.png" \
+ -t "${pkgdir}/usr/share/icons/hicolor/${_icons}/apps"
+ done
+ install -Dm644 "${srcdir}/usr/share/applications/${pkgname%-bin}.desktop" -t "${pkgdir}/usr/share/applications"
+} \ No newline at end of file
diff --git a/knowte.sh b/knowte.sh
new file mode 100644
index 000000000000..1d446c7ff071
--- /dev/null
+++ b/knowte.sh
@@ -0,0 +1,11 @@
+#!/bin/bash
+_ELECTRON=/usr/bin/electron17
+APPDIR="/usr/lib/knowte"
+export PATH="${APPDIR}:${PATH}"
+export LD_LIBRARY_PATH="${APPDIR}/swiftshader":"${LD_LIBRARY_PATH}"
+_ASAR="${APPDIR}/app.asar"
+if [[ $EUID -ne 0 ]] || [[ $ELECTRON_RUN_AS_NODE ]]; then
+ exec ${_ELECTRON} ${_ASAR} "$@"
+else
+ exec ${_ELECTRON} ${_ASAR} --no-sandbox "$@"
+fi \ No newline at end of file