summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorNOGISAKA Sadata2015-06-09 22:54:56 +0900
committerNOGISAKA Sadata2015-06-09 22:54:56 +0900
commit9c35e2dbe96bc06975662b2dd3b117e7a90da2a4 (patch)
treeab10d3d948e1c6c1312366ab4b2f0ee127c7a637
downloadaur-9c35e2dbe96bc06975662b2dd3b117e7a90da2a4.tar.gz
initial import
-rw-r--r--.SRCINFO15
-rw-r--r--.gitignore1
-rw-r--r--PKGBUILD33
3 files changed, 49 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..2e4c172767fa
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = knp
+ pkgdesc = KN parser (Kurohashi-Nagao parser) which detects dependency of Japanese sentences
+ pkgver = 4.12
+ pkgrel = 1
+ url = http://nlp.ist.i.kyoto-u.ac.jp/index.php?KNP
+ arch = x86_64
+ arch = i686
+ license = custom
+ depends = juman>=7.0
+ depends = tinycdb
+ source = http://nlp.ist.i.kyoto-u.ac.jp/nl-resource/knp/knp-4.12.tar.bz2
+ sha1sums = 715246971b758330714e27348e83cd95b1fa7feb
+
+pkgname = knp
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..9adf581f4c73
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1 @@
+*.tar.bz2
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..ef6a26aaffd6
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,33 @@
+# Maintainer: nosada <ngsksdt@gmail.com>
+
+# This package requires too large space (around 3GB).
+# You should check having enough space on your storage.
+
+pkgname=knp
+pkgver=4.12
+pkgrel=1
+pkgdesc="KN parser (Kurohashi-Nagao parser) which detects dependency of Japanese sentences"
+url="http://nlp.ist.i.kyoto-u.ac.jp/index.php?KNP"
+arch=("x86_64" "i686")
+license=("custom")
+depends=("juman>=7.0" "tinycdb") # if you want to use named entity extraction, append 'crfpp' in 'depends' line
+source=("http://nlp.ist.i.kyoto-u.ac.jp/nl-resource/knp/${pkgname}-${pkgver}.tar.bz2")
+sha1sums=("715246971b758330714e27348e83cd95b1fa7feb")
+
+build() {
+ cd ${srcdir}/${pkgname}-${pkgver}
+
+ ./configure --prefix=/usr
+ # if you want to use named entity extraction, comment out above and uncomment below
+ #./configure --prefix=/usr --with-crf
+ make
+}
+
+package() {
+ cd ${srcdir}/${pkgname}-${pkgver}
+
+ make DESTDIR="${pkgdir}" install
+ install -Dm644 COPYING ${pkgdir}/usr/share/licenses/${pkgname}/COPYING
+}
+
+# vim:set ts=2 sw=2 et: