summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlex Zappa2017-08-03 13:20:42 +0200
committerAlex Zappa2017-08-03 13:20:42 +0200
commite377fbb0f414579a9967508097ed33ba83d59e9d (patch)
treec5b94f1576f265fe4252eb2e354b2c132aac3280
downloadaur-e377fbb0f414579a9967508097ed33ba83d59e9d.tar.gz
release 2.2.0 rev 1
-rw-r--r--.SRCINFO22
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD38
-rw-r--r--koala.desktop11
-rw-r--r--koala.pngbin0 -> 55629 bytes
5 files changed, 75 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..3c8eed9cdba2
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,22 @@
+# Generated by makepkg 5.0.2
+# Thu Aug 3 10:24:57 UTC 2017
+pkgbase = koala-bin
+ pkgdesc = Koala is a GUI application for LESS, Sass and CoffeeScript compilation, to help web developers use these tools more efficiently for development.
+ pkgver = 2.2.0
+ pkgrel = 1
+ url = http://koala-app.com/
+ arch = x86_64
+ arch = i686
+ license = Apache License, Version 2.0
+ provides = koala
+ source = koala.png
+ source = koala.desktop
+ sha512sums = 00c273bb8b987f8909162885bf5eca48013fcc81abef0e1d6565a5bd9ce5e8071306fb8186eab790fb025ef2aa960d9770a4b6e656424d6ed92fdf769681167b
+ sha512sums = e0862ffe8fa9431c0d1147e7f3d7f6d7d13bce789f970a0d2fa2b51891eda8161965f05068f7348d7ec12cdc8840bb555532520b839833893cbbda4715e87131
+ source_x86_64 = https://github.com/oklai/koala/releases/download/v2.2.0/koala_2.2.0_x86_64.tar.gz
+ sha512sums_x86_64 = c282bfaa1af9127a005211ed67a19ac09b2c8f4cf16ae98abc959951b9ea55fb41c8bf7d9a43c9711bf6fa8dbf609c27605654b834c752a43880ab8d98fb9dd3
+ source_i686 = https://github.com/oklai/koala/releases/download/v2.2.0/koala_2.2.0_i386.tar.gz
+ sha512sums_i686 = d7084462eabee6e270986391d190889f6c555df5fad3a730e622a847dc431160de673238f936185cb26a02ca1efbdeac78d68e20981e0e67079b1ea385e3a039
+
+pkgname = koala-bin
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..87ed04bf2851
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+pkg
+src
+koala_*.tar.gz
+koala-bin-*.pkg.tar.xz
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..4ce22a75cb55
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,38 @@
+# Maintainer: Alex Zappa <reatlat@gmail.com>
+
+pkgname=koala-bin
+pkgver=2.2.0
+pkgrel=1
+pkgdesc="Koala is a GUI application for LESS, Sass and CoffeeScript compilation, to help web developers use these tools more efficiently for development."
+arch=('x86_64' 'i686')
+url="http://koala-app.com/"
+_repourl="https://github.com/oklai/koala"
+license=('Apache License, Version 2.0')
+provides=('koala')
+depends=()
+optdepends=()
+
+source=('koala.png'
+ 'koala.desktop')
+source_x86_64=("${_repourl}/releases/download/v${pkgver}/koala_${pkgver}_x86_64.tar.gz")
+source_i686=("${_repourl}/releases/download/v${pkgver}/koala_${pkgver}_i386.tar.gz")
+
+sha512sums=('00c273bb8b987f8909162885bf5eca48013fcc81abef0e1d6565a5bd9ce5e8071306fb8186eab790fb025ef2aa960d9770a4b6e656424d6ed92fdf769681167b'
+ 'e0862ffe8fa9431c0d1147e7f3d7f6d7d13bce789f970a0d2fa2b51891eda8161965f05068f7348d7ec12cdc8840bb555532520b839833893cbbda4715e87131')
+sha512sums_x86_64=('c282bfaa1af9127a005211ed67a19ac09b2c8f4cf16ae98abc959951b9ea55fb41c8bf7d9a43c9711bf6fa8dbf609c27605654b834c752a43880ab8d98fb9dd3')
+sha512sums_i686=('d7084462eabee6e270986391d190889f6c555df5fad3a730e622a847dc431160de673238f936185cb26a02ca1efbdeac78d68e20981e0e67079b1ea385e3a039')
+
+package() {
+ cd ${srcdir}/usr/share/koala
+
+ mkdir -p "${pkgdir}/usr/bin"
+ mkdir -p "${pkgdir}/usr/share/koala"
+ mkdir -p "${pkgdir}/usr/share/applications"
+
+ cp --preserve=mode -R ./* "${pkgdir}/usr/share/koala"
+ install -D -m644 "${srcdir}/koala.png" "${pkgdir}/usr/share/koala/koala.png"
+ chmod +x "${srcdir}/koala.desktop"
+ install -D -m644 "${srcdir}/koala.desktop" "${pkgdir}/usr/share/applications/koala.desktop"
+ ln -s "${pkgdir}/usr/share/koala/Koala" "${pkgdir}/usr/bin/koala"
+
+}
diff --git a/koala.desktop b/koala.desktop
new file mode 100644
index 000000000000..754c4960d587
--- /dev/null
+++ b/koala.desktop
@@ -0,0 +1,11 @@
+[Desktop Entry]
+Name=Koala
+Version=2.2.0
+Exec=koala
+Comment=A cool tool for web developers
+Icon=/usr/share/koala/koala.png
+Type=Application
+Terminal=false
+StartupNotify=true
+Encoding=UTF-8
+Categories=Development;GTK;GNOME; \ No newline at end of file
diff --git a/koala.png b/koala.png
new file mode 100644
index 000000000000..ac644fe7b18e
--- /dev/null
+++ b/koala.png
Binary files differ