summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMichele Carnaghi2023-02-16 22:18:03 +0100
committerMichele Carnaghi2023-02-16 22:18:03 +0100
commit75a1562192bb65473e6cc8c8affecc1f9cc75f39 (patch)
tree3b4770d63bb0cd02c152eeb0312259f72f882b1d
parentef0a47a2020484adef4b10fad14a1c8b0e2a483a (diff)
downloadaur-75a1562192bb65473e6cc8c8affecc1f9cc75f39.tar.gz
updated to release 1.61.0.36 and added aarch64/armv7h
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD11
2 files changed, 12 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index df4e1d6c9f94..8649bc1bcaa8 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,11 @@
pkgbase = kodi-addon-game-libretro-snes9x
- pkgdesc = Libretro wrapper for Kodi's Game API
- pkgver = 1.61.0.35
+ pkgdesc = This add-on provides a wrapper that allows Libretro cores to be loaded as game add-ons
+ pkgver = 1.61.0.36
pkgrel = 1
url = https://github.com/kodi-game/game.libretro.snes9x
arch = x86_64
+ arch = aarch64
+ arch = armv7h
groups = kodi-addons
groups = kodi-addons-game
license = GPL
@@ -13,8 +15,8 @@ pkgbase = kodi-addon-game-libretro-snes9x
makedepends = libretro-snes9x
options = !lto
options = debug
- source = kodi-addon-game-libretro-snes9x-1.61.0.35.tar.gz::https://github.com/kodi-game/game.libretro.snes9x/archive/1.61.0.35-Matrix.tar.gz
- sha512sums = 60bd5b47fcfa0eae01b7d29aefea5317ef528a57fd309ddea29c4173408d0540d40d0ca0fb3d8e072c3772ef81bcae14077cf9646ce80ea7123d71a6222e4161
+ source = kodi-addon-game-libretro-snes9x-1.61.0.36.tar.gz::https://github.com/kodi-game/game.libretro.snes9x/archive/1.61.0.36-Matrix.tar.gz
+ sha512sums = b95d2bd775b10493ad386bd18cb009d9404f31211aae99282c7b9289eddd521f8111d910b466a119da67ccc49f3efacf2a4b25d8ee5890d48a4b8277be5fb0be
pkgname = kodi-addon-game-libretro-snes9x
depends = kodi-addon-game-libretro
diff --git a/PKGBUILD b/PKGBUILD
index 62d30b035ca5..f75c6691cdb0 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,18 +1,19 @@
-# Maintainer: BlackEagle <ike.devolder@gmail.com>>
+# Maintainer: mcarni <michele DOT carnaghi AT googlemail DOT com>
+# Contributor: BlackEagle <ike DOT devolder AT gmail DOT com>
pkgname=kodi-addon-game-libretro-snes9x
-pkgver=1.61.0.35
+pkgver=1.61.0.36
_codename=Matrix
pkgrel=1
-pkgdesc="Libretro wrapper for Kodi's Game API"
-arch=('x86_64')
+pkgdesc="This add-on provides a wrapper that allows Libretro cores to be loaded as game add-ons"
+arch=('x86_64' 'aarch64' 'armv7h')
url='https://github.com/kodi-game/game.libretro.snes9x'
license=('GPL')
groups=('kodi-addons' 'kodi-addons-game')
makedepends=('cmake' 'kodi-dev' 'kodi-addon-game-libretro' 'libretro-snes9x')
options=(!lto debug)
source=("$pkgname-$pkgver.tar.gz::https://github.com/kodi-game/game.libretro.snes9x/archive/$pkgver-$_codename.tar.gz")
-sha512sums=('60bd5b47fcfa0eae01b7d29aefea5317ef528a57fd309ddea29c4173408d0540d40d0ca0fb3d8e072c3772ef81bcae14077cf9646ce80ea7123d71a6222e4161')
+sha512sums=('b95d2bd775b10493ad386bd18cb009d9404f31211aae99282c7b9289eddd521f8111d910b466a119da67ccc49f3efacf2a4b25d8ee5890d48a4b8277be5fb0be')
build() {
cd "game.libretro.snes9x-$pkgver-$_codename"