summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMichael Lass2019-02-05 20:54:29 +0100
committerMichael Lass2019-02-05 20:54:29 +0100
commit1ba8803593b2fc9f013dcecaf11a437fa79a3516 (patch)
treec99e74526f1f726c3c4b910cd6b939ff0abeb656
parent9dbfcc51be5cfe2c83c14471eaf22c0b2433d51c (diff)
downloadaur-1ba8803593b2fc9f013dcecaf11a437fa79a3516.tar.gz
Prepare for Leia and remove support for obsolete versions
-rw-r--r--PKGBUILD22
1 files changed, 8 insertions, 14 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 327477a5c100..74833b55a951 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -9,8 +9,8 @@
# #
# API changes between different Kodi versions make it necessary to specify #
# the version of Kodi you want to build this package for. You can choose #
-# between Isengard (15), Jarvis (16), Krypton (17) and git master (99). Do so #
-# in the following line. #
+# between Krypton (17), Leia (18) and git master (99). Do so in the following #
+# line. #
# #
###############################################################################
@@ -23,24 +23,18 @@ pkgdesc='Tvheadend HTSP PVR client addon for Kodi'
arch=('armv7h' 'i686' 'x86_64')
url="https://github.com/kodi-pvr/pvr.hts"
license=('GPL')
-makedepends=('cmake' 'git' 'kodi-platform-git')
-depends=('kodi')
+makedepends=('cmake' 'git' 'kodi-platform-git' 'kodi-dev')
+depends=('kodi' 'p8-platform')
provides=('kodi-addon-pvr-hts')
conflicts=('kodi-addon-pvr-hts' 'kodi-pvr-addons')
source=("${pkgname}::git+https://github.com/kodi-pvr/pvr.hts.git")
md5sums=('SKIP')
case "$API" in
- 15) depends+=('libplatform-legacy')
- source[0]="${pkgname}::git+https://github.com/kodi-pvr/pvr.hts.git#branch=Isengard" ;;
- 16) depends+=('libplatform-legacy')
- source[0]="${pkgname}::git+https://github.com/kodi-pvr/pvr.hts.git#branch=Jarvis" ;;
- 17) depends+=('p8-platform')
- makedepends+=('kodi-dev')
- source[0]="${pkgname}::git+https://github.com/kodi-pvr/pvr.hts.git#branch=Krypton" ;;
- 99) depends+=('p8-platform')
- makedepends+=('kodi-dev') ;;
- *) error "Unknown API version. Follow instructions in PKGBUILD." && false
+ 17) source[0]="${pkgname}::git+https://github.com/kodi-pvr/pvr.hts.git#branch=Krypton" ;;
+ 18) ;; #source[0]="${pkgname}::git+https://github.com/kodi-pvr/pvr.hts.git#branch=Leia" ;;
+ 99) ;;
+ *) echo "Unknown API version. Follow instructions in PKGBUILD." && false
esac
pkgver() {