summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMichael Lass2016-02-04 00:17:02 +0100
committerMichael Lass2016-02-04 00:17:02 +0100
commitbe92d47201619ed18feb83b1069ee251c2e36b65 (patch)
treebb15ed721c45ff0436b76d968c29e0f8c7b50369
parent474529bc7fe3a5379a6c3dd4a3683e870e50b1ea (diff)
downloadaur-be92d47201619ed18feb83b1069ee251c2e36b65.tar.gz
Differentiate between API versions
For each version of kodi there is a specific version of kodi-platform and a branch for each addon. We have to use the correct versions, so require users to specify their version of kodi in the PKGBUILD.
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD25
2 files changed, 26 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 9652b943ed92..23057c2dbac4 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,8 @@
+# Generated by mksrcinfo v8
+# Wed Feb 3 23:00:47 UTC 2016
pkgbase = kodi-addon-pvr-hts-git
pkgdesc = Tvheadend HTSP PVR client addon for Kodi
- pkgver = r306.9b05d4c
+ pkgver = r314.016b0b3
pkgrel = 1
url = https://github.com/kodi-pvr/pvr.hts
arch = armv7h
@@ -10,7 +12,7 @@ pkgbase = kodi-addon-pvr-hts-git
makedepends = cmake
makedepends = git
makedepends = kodi-platform-git
- depends = kodi>=15.0
+ depends = kodi
provides = kodi-addon-pvr-hts
conflicts = kodi-addon-pvr-hts
conflicts = kodi-pvr-addons
diff --git a/PKGBUILD b/PKGBUILD
index 293eccff5506..0565fc2b9545 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,8 +3,20 @@
# This PKGBUILD is maintained on github:
# https://github.com/michaellass/AUR
+###############################################################################
+# INSTRUCTIONS #
+# ------------ #
+# #
+# API changes between different Kodi versions make it necessary to specify #
+# the version of Kodi you want to build this package for. You can choose #
+# between Isengard (15), Jarvis (16) and git master (99). Do so in the #
+# following line. #
+###############################################################################
+
+API=15
+
pkgname=kodi-addon-pvr-hts-git
-pkgver=r306.9b05d4c
+pkgver=r314.016b0b3
pkgrel=1
_branch=Isengard
pkgdesc='Tvheadend HTSP PVR client addon for Kodi'
@@ -12,12 +24,19 @@ arch=('armv7h' 'i686' 'x86_64')
url="https://github.com/kodi-pvr/pvr.hts"
license=('GPL')
makedepends=('cmake' 'git' 'kodi-platform-git')
-depends=('kodi>=15.0')
+depends=('kodi')
provides=('kodi-addon-pvr-hts')
conflicts=('kodi-addon-pvr-hts' 'kodi-pvr-addons')
-source=("${pkgname}::git+https://github.com/kodi-pvr/pvr.hts.git#branch=${_branch}")
+source=("${pkgname}::git+https://github.com/kodi-pvr/pvr.hts.git")
md5sums=('SKIP')
+case "$API" in
+ 15) source[0]="${pkgname}::git+https://github.com/kodi-pvr/pvr.hts.git#branch=Isengard" ;;
+ 16) source[0]="${pkgname}::git+https://github.com/kodi-pvr/pvr.hts.git#branch=Jarvis" ;;
+ 99) ;;
+ *) error "Unknown API version. Follow instructions in PKGBUILD." && false
+esac
+
pkgver() {
cd "$pkgname"
printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"