summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorthepasto2020-09-09 15:22:03 +0200
committerthepasto2020-09-09 15:22:03 +0200
commit677cf405bffbe197fb8bbeedbcf63dda731419d2 (patch)
tree21651a9db3eaadd669a4a8b5ad19d1015f131302
parent9ded985d05c9f97c07df63518e7115481acc717f (diff)
downloadaur-677cf405bffbe197fb8bbeedbcf63dda731419d2.tar.gz
fix to build with cmake 3.18 - Kodi 18.8
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD10
2 files changed, 12 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 32b94627b74e..585784443483 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = kodi-addon-pvr-iptvsimple
pkgdesc = IPTV Simple PVR client addon for Kodi
pkgver = 3.9.8
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/kodi-pvr/pvr.iptvsimple
arch = armv6h
arch = armv7h
@@ -15,9 +15,11 @@ pkgbase = kodi-addon-pvr-iptvsimple
depends = git
conflicts = kodi-addon-pvr-iptvsimple-git
source = https://github.com/kodi-pvr/pvr.iptvsimple/archive/3.9.8-Leia.tar.gz
- source = https://github.com/xbmc/xbmc/archive/18.6-Leia.tar.gz
+ source = https://github.com/xbmc/xbmc/archive/18.8-Leia.tar.gz
+ source = https://github.com/xbmc/xbmc/commit/8f714dcc7f1a1dfa9b57ef18c3f4accc62cb0652.diff
sha256sums = 0812e359a943f4ffb763b47fc0440768a8aa09f12172ef8dff4440b0a48f9c96
- sha256sums = 47e6d7d4e01dbda92ff83a3e141ac43003e918133e78b3a4b79faff65184711c
+ sha256sums = 6deb28f725880b1ab6c5920b55ef1190a79b0684ffb30b6e13b199d23a0af296
+ sha256sums = c4ed6c685a3de5633387a8ca79c06141f643c47eace30c614223f9120f72a25a
pkgname = kodi-addon-pvr-iptvsimple
diff --git a/PKGBUILD b/PKGBUILD
index 40201d6c7c14..7bb755b32cb3 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,11 +1,11 @@
# Maintainer: thepasto <thepasto@gmail.com>
pkgname=kodi-addon-pvr-iptvsimple
pkgver=3.9.8
-pkgrel=1
+pkgrel=2
pkgdesc='IPTV Simple PVR client addon for Kodi'
_koditarget=Leia
_gitname=pvr.iptvsimple
-_kodiver=18.6
+_kodiver=18.8
arch=('armv6h' 'armv7h' 'i686' 'x86_64')
url="https://github.com/kodi-pvr/${_gitname}"
license=('GPL')
@@ -15,12 +15,16 @@ conflicts=('kodi-addon-pvr-iptvsimple-git');
depends=('kodi' 'git')
source=("https://github.com/kodi-pvr/${_gitname}/archive/${pkgver}-${_koditarget}.tar.gz"
"https://github.com/xbmc/xbmc/archive/${_kodiver}-${_koditarget}.tar.gz"
+ "https://github.com/xbmc/xbmc/commit/8f714dcc7f1a1dfa9b57ef18c3f4accc62cb0652.diff"
)
sha256sums=('0812e359a943f4ffb763b47fc0440768a8aa09f12172ef8dff4440b0a48f9c96'
- '47e6d7d4e01dbda92ff83a3e141ac43003e918133e78b3a4b79faff65184711c')
+ '6deb28f725880b1ab6c5920b55ef1190a79b0684ffb30b6e13b199d23a0af296'
+ 'c4ed6c685a3de5633387a8ca79c06141f643c47eace30c614223f9120f72a25a'
+ )
prepare() {
cd xbmc-${_kodiver}-${_koditarget}
+ patch -p1 cmake/scripts/common/HandleDepends.cmake ${srcdir}/8f714dcc7f1a1dfa9b57ef18c3f4accc62cb0652.diff
#sed -i "s|-p1 -i|--binary -p1 -i|" cmake/scripts/common/HandleDepends.cmake
#sed -i 's/GIT_SHALLOW 1/GIT_SHALLOW ""/g' cmake/scripts/common/HandleDepends.cmake
}