summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMichael Lass2016-02-04 00:17:34 +0100
committerMichael Lass2016-02-04 00:17:34 +0100
commit68dfd419b53b18adbe561f02faed816287199b27 (patch)
treed5b81719a5a6abfa7e783d745bc5f6c5f49c30a4
parentd4a3e2dd6973ac95d7ccf92a1e3e43771bba5fa1 (diff)
downloadaur-68dfd419b53b18adbe561f02faed816287199b27.tar.gz
Differentiate between API versions
For each version of kodi there is a specific version of kodi-platform and a branch for each addon. We have to use the correct versions, so require users to specify their version of kodi in the PKGBUILD.
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD23
2 files changed, 24 insertions, 3 deletions
diff --git a/.SRCINFO b/.SRCINFO
index a948982a2b5b..b545bfc5b020 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,3 +1,5 @@
+# Generated by mksrcinfo v8
+# Wed Feb 3 23:04:51 UTC 2016
pkgbase = kodi-addon-pvr-vdr-vnsi-git
pkgdesc = VDR VNSI PVR client addon for Kodi
pkgver = r295.550a4a2
@@ -10,7 +12,7 @@ pkgbase = kodi-addon-pvr-vdr-vnsi-git
makedepends = cmake
makedepends = git
makedepends = kodi-platform-git
- depends = kodi>=15.0
+ depends = kodi
provides = kodi-addon-pvr-vdr-vnsi
conflicts = kodi-addon-pvr-vdr-vnsi
conflicts = kodi-pvr-addons
diff --git a/PKGBUILD b/PKGBUILD
index c90a7531bbce..90fc0378fa3c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,6 +3,18 @@
# This PKGBUILD is maintained on github:
# https://github.com/michaellass/AUR
+###############################################################################
+# INSTRUCTIONS #
+# ------------ #
+# #
+# API changes between different Kodi versions make it necessary to specify #
+# the version of Kodi you want to build this package for. You can choose #
+# between Isengard (15), Jarvis (16) and git master (99). Do so in the #
+# following line. #
+###############################################################################
+
+API=15
+
pkgname=kodi-addon-pvr-vdr-vnsi-git
pkgver=r295.550a4a2
pkgrel=1
@@ -12,12 +24,19 @@ arch=('armv7h' 'i686' 'x86_64')
url="https://github.com/kodi-pvr/pvr.vdr.vnsi"
license=('GPL')
makedepends=('cmake' 'git' 'kodi-platform-git')
-depends=('kodi>=15.0')
+depends=('kodi')
provides=('kodi-addon-pvr-vdr-vnsi')
conflicts=('kodi-addon-pvr-vdr-vnsi' 'kodi-pvr-addons')
-source=("${pkgname}::git+https://github.com/kodi-pvr/pvr.vdr.vnsi.git#branch=${_branch}")
+source=("${pkgname}::git+https://github.com/kodi-pvr/pvr.vdr.vnsi.git")
md5sums=('SKIP')
+case "$API" in
+ 15) source[0]="${pkgname}::git+https://github.com/kodi-pvr/pvr.vdr.vnsi.git#branch=Isengard" ;;
+ 16) source[0]="${pkgname}::git+https://github.com/kodi-pvr/pvr.vdr.vnsi.git#branch=Jarvis" ;;
+ 99) ;;
+ *) error "Unknown API version. Follow instructions in PKGBUILD." && false
+esac
+
pkgver() {
cd "$pkgname"
printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"