summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorxpt2016-03-16 14:37:22 -0300
committerxpt2016-03-16 14:37:22 -0300
commit212c932b7386316f3f756d2669c2b596a1e9b451 (patch)
treea318975bb91cfe62a1f81f95cdfadd33ed3528ba
downloadaur-212c932b7386316f3f756d2669c2b596a1e9b451.tar.gz
Initial import
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD38
-rw-r--r--kodi-addon-quasar.install30
3 files changed, 83 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..7151ed836b83
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = kodi-addon-quasar
+ pkgdesc = Quasar is an torrent finding and streaming engine for Kodi (fork of Pulsar add-on)
+ pkgver = 0.9.32
+ pkgrel = 1
+ url = https://https://github.com/scakemyer/plugin.video.quasar
+ install = kodi-addon-quasar.install
+ arch = any
+ license = GPL3
+ depends = kodi
+ depends = kodi-standalone-service
+ noextract = plugin.video.quasar-0.9.32.zip
+ options = !strip
+
+pkgname = kodi-addon-quasar
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..ec108634c876
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,38 @@
+# Maintainer: xpt <user.xpt@gmail.com>
+
+pkgname=kodi-addon-quasar
+pkgver=0.9.32
+pkgrel=1
+pkgdesc='Quasar is an torrent finding and streaming engine for Kodi (fork of Pulsar add-on)'
+classname=plugin.video.quasar
+arch=('any')
+url='https://https://github.com/scakemyer/plugin.video.quasar'
+license=('GPL3')
+depends=('kodi' 'kodi-standalone-service')
+depends_arm=('kodi-rbp')
+depends_armv6h=('kodi-rbp')
+depends_armv7h=('kodi-rbp')
+options=(!strip)
+noextract=(${classname}-${pkgver}.zip)
+
+source_arm=("https://github.com/scakemyer/plugin.video.quasar/releases/download/v${pkgver}/plugin.video.quasar-${pkgver}.linux_arm.zip")
+source_armv6h=("https://github.com/scakemyer/plugin.video.quasar/releases/download/v${pkgver}/plugin.video.quasar-${pkgver}.linux_arm.zip")
+source_armv7h=("https://github.com/scakemyer/plugin.video.quasar/releases/download/v${pkgver}/plugin.video.quasar-${pkgver}.linux_armv7.zip")
+source_i686=("https://github.com/scakemyer/plugin.video.quasar/releases/download/v${pkgver}/plugin.video.quasar-${pkgver}.linux_x64.zip")
+source_x86_64=("https://github.com/scakemyer/plugin.video.quasar/releases/download/v${pkgver}/plugin.video.quasar-${pkgver}.linux_x86.zip")
+
+md5sums_arm=('73ce191de2b6d33071352fa21801fb8a')
+md5sums_armv6h=('73ce191de2b6d33071352fa21801fb8a')
+md5sums_armv7h=('a9ee51fb6f1cd67eef6ae82509497837')
+md5sums_i686=('45a59bf1d5ae06ee3b69412214c99652')
+md5sums_x86_64=('cba047f97541d8f5988e376f63f571c7')
+
+install=kodi-addon-quasar.install
+
+installpath=/var/lib/kodi/.kodi/addons/
+
+package() {
+ mkdir -p ${pkgdir}/${installpath}
+ unzip -o ${classname}-${pkgver}.linux_x86.zip -d ${pkgdir}/${installpath}
+ rm ${pkgdir}/${installpath}/${classname}/Makefile
+} \ No newline at end of file
diff --git a/kodi-addon-quasar.install b/kodi-addon-quasar.install
new file mode 100644
index 000000000000..5cbfee1f6a8f
--- /dev/null
+++ b/kodi-addon-quasar.install
@@ -0,0 +1,30 @@
+classname=plugin.video.quasar
+usr=420
+home=/var/lib/kodi/.kodi/addons
+repo=$home/repository.quasar
+addonpath=$home/${classname}
+
+_chown() {
+ chmod 755 $(find $addonpath -type d)
+ chmod 644 $(find $addonpath -type f)
+ chown -R $usr:$usr $home $addonpath
+}
+
+## arg 1: the new package version
+post_install() {
+ getent passwd $usr &> /dev/null || useradd -r -d $home -s /bin/bash $usr
+ _chown
+
+}
+
+post_upgrade() {
+ _chown
+}
+
+## arg 1: the old package version
+post_remove() {
+ rm -r $addonpath $repo
+ return 0
+}
+
+# vim:set ts=2 sw=2 et: