summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorxpt2016-03-22 21:04:40 -0300
committerxpt2016-03-22 21:04:40 -0300
commit7b5cc69203bc35d56917b3e7c53068df65305ac9 (patch)
treeadb87a198ba69fed34061da71280af443ff94318
parent583bef91eb23c329202aff684477c9f011ff1477 (diff)
downloadaur-7b5cc69203bc35d56917b3e7c53068df65305ac9.tar.gz
Fix md5sums and unzip command in package
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD41
2 files changed, 29 insertions, 18 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 775614a7762c..81979717f59a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,17 +1,17 @@
# Generated by mksrcinfo v8
-# Tue Mar 22 05:33:34 UTC 2016
+# Wed Mar 23 00:03:58 UTC 2016
pkgbase = kodi-addon-quasar
pkgdesc = Quasar is an torrent finding and streaming engine for Kodi (fork of Pulsar add-on)
pkgver = 0.9.33
- pkgrel = 1
+ pkgrel = 8
url = https://https://github.com/scakemyer/plugin.video.quasar
install = kodi-addon-quasar.install
arch = any
license = GPL3
depends = kodi
- depends = kodi-standalone-service
noextract = plugin.video.quasar-0.9.33.zip
options = !strip
+ source = https://github.com/scakemyer/plugin.video.quasar/releases/download/v0.9.33/plugin.video.quasar-0.9.33.linux_.zip
pkgname = kodi-addon-quasar
diff --git a/PKGBUILD b/PKGBUILD
index bc8dd6ce806c..46108a5ebda8 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,37 +1,48 @@
# Maintainer: xpt <user.xpt@gmail.com>
pkgname=kodi-addon-quasar
pkgver=0.9.33
-pkgrel=1
+pkgrel=8
pkgdesc='Quasar is an torrent finding and streaming engine for Kodi (fork of Pulsar add-on)'
classname=plugin.video.quasar
arch=('any')
url='https://https://github.com/scakemyer/plugin.video.quasar'
license=('GPL3')
-depends=('kodi' 'kodi-standalone-service')
+depends=('kodi')
depends_arm=('kodi-rbp')
depends_armv6h=('kodi-rbp')
depends_armv7h=('kodi-rbp')
options=(!strip)
noextract=(${classname}-${pkgver}.zip)
-source_arm=("https://github.com/scakemyer/plugin.video.quasar/releases/download/v${pkgver}/plugin.video.quasar-${pkgver}.linux_arm.zip")
-source_armv6h=("https://github.com/scakemyer/plugin.video.quasar/releases/download/v${pkgver}/plugin.video.quasar-${pkgver}.linux_arm.zip")
-source_armv7h=("https://github.com/scakemyer/plugin.video.quasar/releases/download/v${pkgver}/plugin.video.quasar-${pkgver}.linux_armv7.zip")
-source_i686=("https://github.com/scakemyer/plugin.video.quasar/releases/download/v${pkgver}/plugin.video.quasar-${pkgver}.linux_x64.zip")
-source_x86_64=("https://github.com/scakemyer/plugin.video.quasar/releases/download/v${pkgver}/plugin.video.quasar-${pkgver}.linux_x86.zip")
-
-md5sums_arm=('e2ef50ef1f271fd079cf7d1a117df5ba')
-md5sums_armv6h=('e2ef50ef1f271fd079cf7d1a117df5ba6h')
-md5sums_armv7h=('e2ef50ef1f271fd079cf7d1a117df5ba7h')
-md5sums_i686=('3304a6a44cf58743850b1fc29bc1e52b')
-md5sums_x86_64=('47196cc5dbbb6526b4dff1ee85e337cf')
+case "$CARCH" in
+ arm)
+ _pkgarch="arm"
+ md5sums=('e2ef50ef1f271fd079cf7d1a117df5ba')
+ ;;
+ armv6h)
+ _pkgarch="arm"
+ md5sums=('e2ef50ef1f271fd079cf7d1a117df5ba')
+ ;;
+ armv7h)
+ _pkgarch="armv7"
+ md5sums=('330065a8ab3fc58cd5ee306b417780bf')
+ ;;
+ i686)
+ _pkgarch="x64"
+ md5sums=('3304a6a44cf58743850b1fc29bc1e52b')
+ ;;
+ x86_64)
+ _pkgarch="x86"
+ md5sums=('47196cc5dbbb6526b4dff1ee85e337cf')
+ ;;
+esac
+source=("https://github.com/scakemyer/plugin.video.quasar/releases/download/v${pkgver}/plugin.video.quasar-${pkgver}.linux_${_pkgarch}.zip")
install=kodi-addon-quasar.install
-
installpath=/var/lib/kodi/.kodi/addons/
package() {
mkdir -p ${pkgdir}/${installpath}
- unzip -o ${classname}-${pkgver}.linux_x86.zip -d ${pkgdir}/${installpath}
+ unzip -o ${classname}-${pkgver}.linux_${_pkgarch}.zip -d ${pkgdir}/${installpath}
rm ${pkgdir}/${installpath}/${classname}/Makefile
} \ No newline at end of file