summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authort0nedef2015-08-29 17:28:44 -0400
committert0nedef2015-08-29 17:28:44 -0400
commitc44fdd366499066b0d95d2cd3b5b931296021f33 (patch)
treefab9591f594804cbb41b4c0633d38154187904e1
downloadaur-c44fdd366499066b0d95d2cd3b5b931296021f33.tar.gz
move to aur4
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD20
-rw-r--r--install11
3 files changed, 47 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..01a0cf84f554
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = kodi-addon-repo-installer
+ pkgdesc = Allows installation of unofficial KODI addon repositories (from KODI wiki)
+ pkgver = 1.0.5
+ pkgrel = 5
+ url = http://kodi-passion.fr/index.php
+ install = install
+ arch = any
+ license = GPL
+ makedepends = unzip
+ depends = kodi
+ replaces = xbmc-addon-repo-installer
+ source = http://passion-xbmc.org/addons/Download.php/plugin.program.repo.installer/plugin.program.repo.installer-1.0.5.zip
+ md5sums = 15e810a733fbf14d77b53301739a9f70
+
+pkgname = kodi-addon-repo-installer
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..8ad3d4f26970
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,20 @@
+# Contributor: Temhil and Frost
+# Maintainer: Aaron Ali <t0nedef@causal.ca>
+pkgname=kodi-addon-repo-installer
+pkgver=1.0.5
+pkgrel=5
+pkgdesc="Allows installation of unofficial KODI addon repositories (from KODI wiki)"
+arch=('any')
+url="http://kodi-passion.fr/index.php"
+license=('GPL')
+depends=('kodi')
+install=install
+makedepends=('unzip')
+source=('http://passion-xbmc.org/addons/Download.php/plugin.program.repo.installer/plugin.program.repo.installer-'$pkgver'.zip')
+replaces=(xbmc-addon-repo-installer)
+package() {
+ mkdir -p ${pkgdir}/usr/share/kodi/addons
+ unzip ${srcdir}/plugin.program.repo.installer-${pkgver}.zip -d ${pkgdir}/usr/share/kodi/addons
+}
+#
+md5sums=('15e810a733fbf14d77b53301739a9f70')
diff --git a/install b/install
new file mode 100644
index 000000000000..be36bf053119
--- /dev/null
+++ b/install
@@ -0,0 +1,11 @@
+post_install() {
+ echo "please restart kodi"
+}
+
+post_upgrade() {
+ post_install
+}
+
+post_remove() {
+ post_install
+}