summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorM0Rf302015-06-17 15:51:15 +0200
committerM0Rf302015-06-17 15:51:15 +0200
commit216b342d620c0892662cb29080669df3c336d638 (patch)
tree5917a8cc8200b1923820798e59842a75f944f08d
downloadaur-216b342d620c0892662cb29080669df3c336d638.tar.gz
Initial import
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD22
-rw-r--r--kodi-addon-stream.install32
3 files changed, 69 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..90dd88e983ee
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = kodi-addon-stream
+ pkgdesc = A cross-platform XBMC addon designed with the goal of delivering HD content from all across the web.
+ pkgver = 1.4.4
+ pkgrel = 1
+ url = http://stream.brysonreece.com/
+ install = kodi-addon-stream.install
+ arch = any
+ license = GPL3
+ depends = kodi
+ options = !strip
+ source = https://github.com/brysonreece/Stream/archive/v1.4.4.zip
+ md5sums = 5dc4cf4286a7047514b3c8e9fbac104b
+
+pkgname = kodi-addon-stream
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..e7e26314f255
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,22 @@
+# Maintainer: M0Rf30
+
+pkgname=kodi-addon-stream
+pkgver=1.4.4
+pkgrel=1
+pkgdesc='A cross-platform XBMC addon designed with the goal of delivering HD content from all across the web.'
+classname=plugin.video.stream
+arch=('any')
+url='http://stream.brysonreece.com/'
+license=('GPL3')
+depends=('kodi')
+options=(!strip)
+source=("https://github.com/brysonreece/Stream/archive/v${pkgver}.zip")
+install=kodi-addon-stream.install
+
+package() {
+ mkdir -p ${pkgdir}/usr/share/kodi/addons/
+ cp -r ${srcdir}/Stream-${pkgver}/ ${pkgdir}/usr/share/kodi/addons/${classname}
+ rm -r ${pkgdir}/usr/share/kodi/addons/${classname}/resources/bin/{android_arm,darwin_x64,windows_x86}
+}
+
+md5sums=('5dc4cf4286a7047514b3c8e9fbac104b')
diff --git a/kodi-addon-stream.install b/kodi-addon-stream.install
new file mode 100644
index 000000000000..9f1d5285a95d
--- /dev/null
+++ b/kodi-addon-stream.install
@@ -0,0 +1,32 @@
+classname=plugin.video.stream
+post_install() {
+ getent group kodi > /dev/null || groupadd -g 420 kodi
+ if ! getent passwd kodi > /dev/null; then
+ useradd -c 'XBMC user' -u 420 -g kodi -G audio,video,network,optical -d /var/lib/kodi -s /sbin/nologin kodi
+ passwd -l kodi > /dev/null
+ fi
+ chown -R kodi:kodi /usr/share/kodi/addons/${classname}
+}
+
+post_upgrade() {
+ post_install $1
+ if ! getent group kodi | cut -d: -f3 | grep 420 > /dev/null 2>&1; then
+ groupmod -g 420 kodi > /dev/null 2>&1
+ fi
+ if ! id -u kodi | grep 420 > /dev/null 2>&1; then
+ usermod -u 420 kodi > /dev/null 2>&1
+ if [[ $? -ne 0 ]]; then
+ echo "Changing uid of user kodi failed"
+ echo "It is recommended that the uid is changed."
+ echo "Stop all processes running under the kodi user and reinstall kodi"
+ echo "or change the uid manually. (usermod -u 420 kodi)"
+ fi
+ chown -R kodi:kodi /usr/share/kodi/addons/${classname}
+ fi
+}
+
+post_remove() {
+ getent passwd kodi > /dev/null 2>&1 && userdel kodi
+ getent group kodi > /dev/null 2>&1 && groupdel kodi
+}
+