summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMalte Deiseroth2019-03-11 07:16:46 +0100
committerMalte Deiseroth2019-03-11 07:19:16 +0100
commit7fef1ed0c912c780b4fe948b32bb722e2a0df92f (patch)
tree6921650c92d9b00ae6966398704341bd6b148c91
downloadaur-7fef1ed0c912c780b4fe948b32bb722e2a0df92f.tar.gz
Added vfs.sftp addon for ssh support in kodi > 18.0
-rw-r--r--.SRCINFO23
-rw-r--r--PKGBUILD37
2 files changed, 60 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..756ca40a21e1
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,23 @@
+pkgbase = kodi-addon-vfs-sftp
+ pkgdesc = SFTP Addon for Kodi
+ pkgver = 1.0.0
+ pkgrel = 1
+ url = https://github.com/xbmc/vfs.sftp
+ arch = i686
+ arch = x86_64
+ arch = armv6h
+ arch = armv7h
+ arch = aarch64
+ groups = kodi-addons
+ license = GPL
+ makedepends = cmake
+ makedepends = kodi-platform
+ makedepends = git
+ makedepends = kodi-dev>=18.0
+ depends = kodi
+ depends = p8-platform
+ source = git+https://github.com/xbmc/vfs.sftp.git#branch=master
+ md5sums = SKIP
+
+pkgname = kodi-addon-vfs-sftp
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..42ca78cea74f
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,37 @@
+# Maintainer: Malte Deiseroth <mdeiseroth88 at gmail dot com>
+
+pkgname=kodi-addon-vfs-sftp
+pkgbase=${pkgname}
+_gitname=vfs.sftp
+pkgver=1.0.0
+_gitver=branch=master
+pkgrel=1
+pkgdesc='SFTP Addon for Kodi'
+arch=('i686' 'x86_64' 'armv6h' 'armv7h' 'aarch64')
+url="https://github.com/xbmc/$_gitname"
+license=('GPL')
+groups=('kodi-addons')
+makedepends=('cmake' 'kodi-platform' 'git' 'kodi-dev>=18.0')
+depends=('kodi' 'p8-platform')
+source=("git+https://github.com/xbmc/${_gitname}.git#${_gitver}")
+md5sums=('SKIP')
+
+_prefix='/usr'
+
+build() {
+ msg "Starting make..."
+
+ cd "$srcdir/$_gitname"
+ mkdir -p build && pushd build
+ cmake \
+ -DCMAKE_INSTALL_PREFIX=$_prefix \
+ -DCMAKE_BUILD_TYPE=Release \
+ ..
+ make
+ popd
+}
+
+package() {
+ cd "$srcdir/$_gitname/build"
+ make DESTDIR="$pkgdir" install
+}