summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorgraysky2020-12-28 05:05:05 -0500
committergraysky2020-12-28 05:05:05 -0500
commit2d5fbeeb59b47111a054c0ae01ef79d9e0c0fc69 (patch)
tree5c8c3e8d413a0a927af94f08a881756f650a4ee7
parentcfdaebd82a9de64a89bc59314247f3151186204c (diff)
downloadaur-2d5fbeeb59b47111a054c0ae01ef79d9e0c0fc69.tar.gz
Update to 19.0b2-4
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD110
2 files changed, 61 insertions, 51 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d1131eb850b2..9635cc58aa3a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = kodi-devel
pkgver = 19.0b2
- pkgrel = 3
+ pkgrel = 4
url = https://kodi.tv
arch = x86_64
license = GPL2
diff --git a/PKGBUILD b/PKGBUILD
index 0f3dc764fe82..98e54014c310 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -24,7 +24,7 @@ pkgname=(
)
pkgver=19.0b2
#_major=18.7.1
-pkgrel=3
+pkgrel=4
arch=('x86_64')
url="https://kodi.tv"
license=('GPL2')
@@ -45,6 +45,10 @@ makedepends=(
_tag="$pkgver-Matrix"
#_tag="$_major-Matrix"
+_sse_workaround=1
+_build_x11=1
+_build_wayland=1
+_build_gbm=1
# Found on their respective github release pages. One can check them against
# what is pulled down when not specifying them in the cmake step.
@@ -111,6 +115,7 @@ prepare() {
mkdir kodi-build-gbm
cd "xbmc-$_tag"
+ [[ "$_sse_workaround" -eq 1 ]] && patch -p1 -i "$srcdir/cheat-sse-build.patch"
# needed for `git apply` ... if you know how to avoid this let me know
git init
@@ -140,59 +145,64 @@ build() {
# export CXXFLAGS="${CFLAGS}"
_args=(
- -DCMAKE_INSTALL_PREFIX=/usr
- -DCMAKE_INSTALL_LIBDIR=/usr/lib
- -DENABLE_EVENTCLIENTS=ON
- -DENABLE_INTERNAL_FFMPEG=ON
- -DENABLE_INTERNAL_FMT=ON
- -DENABLE_INTERNAL_CROSSGUID=ON
- -DENABLE_INTERNAL_FSTRCMP=ON
- -DENABLE_INTERNAL_FLATBUFFERS=ON
- -DENABLE_INTERNAL_SPDLOG=ON
- -DENABLE_MYSQLCLIENT=ON
- -Dlibdvdcss_URL="$srcdir/libdvdcss-$_libdvdcss_version.tar.gz"
- -Dlibdvdnav_URL="$srcdir/libdvdnav-$_libdvdnav_version.tar.gz"
- -Dlibdvdread_URL="$srcdir/libdvdread-$_libdvdread_version.tar.gz"
- -DFFMPEG_URL="$srcdir/ffmpeg-$_ffmpeg_version.tar.gz"
- -DFMT_URL="$srcdir/fmt-$_fmt_version.tar.gz"
- -DCROSSGUID_URL="$srcdir/crossguid-$_crossguid_version.tar.gz"
- -DFSTRCMP_URL="$srcdir/fstrcmp-$_fstrcmp_version.tar.gz"
- -DFLATBUFFERS_URL="$srcdir/flatbuffers-$_flatbuffers_version.tar.gz"
- -DSPDLOG_URL="$srcdir/spdlog-$_spdlog_version.tar.gz"
- )
-
- echo "building kodi-x11"
- cd "$srcdir/kodi-build-x11"
- _args+=(
- -DCORE_PLATFORM_NAME=x11
- -DAPP_RENDER_SYSTEM=gl
- )
-
- cmake "${_args[@]}" ../"xbmc-$_tag"
- make
- make preinstall
-
- echo "building kodi-wayland"
- cd "$srcdir/kodi-build-wayland"
- _args+=(
- -DCORE_PLATFORM_NAME=wayland
- -DAPP_RENDER_SYSTEM=gl
+ -DCMAKE_INSTALL_PREFIX=/usr
+ -DCMAKE_INSTALL_LIBDIR=/usr/lib
+ -DENABLE_EVENTCLIENTS=ON
+ -DENABLE_INTERNAL_FFMPEG=ON
+ -DENABLE_INTERNAL_FMT=ON
+ -DENABLE_INTERNAL_CROSSGUID=ON
+ -DENABLE_INTERNAL_FSTRCMP=ON
+ -DENABLE_INTERNAL_FLATBUFFERS=ON
+ -DENABLE_INTERNAL_SPDLOG=ON
+ -DENABLE_MYSQLCLIENT=ON
+ -Dlibdvdcss_URL="$srcdir/libdvdcss-$_libdvdcss_version.tar.gz"
+ -Dlibdvdnav_URL="$srcdir/libdvdnav-$_libdvdnav_version.tar.gz"
+ -Dlibdvdread_URL="$srcdir/libdvdread-$_libdvdread_version.tar.gz"
+ -DFFMPEG_URL="$srcdir/ffmpeg-$_ffmpeg_version.tar.gz"
+ -DFMT_URL="$srcdir/fmt-$_fmt_version.tar.gz"
+ -DCROSSGUID_URL="$srcdir/crossguid-$_crossguid_version.tar.gz"
+ -DFSTRCMP_URL="$srcdir/fstrcmp-$_fstrcmp_version.tar.gz"
+ -DFLATBUFFERS_URL="$srcdir/flatbuffers-$_flatbuffers_version.tar.gz"
+ -DSPDLOG_URL="$srcdir/spdlog-$_spdlog_version.tar.gz"
)
- cmake "${_args[@]}" ../"xbmc-$_tag"
- make
- make preinstall
+ if [[ "$_build_x11" -eq 1 ]]; then
+ echo "building kodi-x11"
+ cd "$srcdir/kodi-build-x11"
+ _args+=(
+ -DCORE_PLATFORM_NAME=x11
+ -DAPP_RENDER_SYSTEM=gl
+ )
- echo "building kodi-gbm"
- cd "$srcdir/kodi-build-gbm"
- _args+=(
- -DCORE_PLATFORM_NAME=gbm
- -DAPP_RENDER_SYSTEM=gles
- )
+ cmake "${_args[@]}" ../xbmc
+ make
+ make preinstall
+ fi
+
+ if [[ "$_build_wayland" -eq 1 ]]; then
+ echo "building kodi-wayland"
+ cd "$srcdir/kodi-build-wayland"
+ _args+=(
+ -DCORE_PLATFORM_NAME=wayland
+ -DAPP_RENDER_SYSTEM=gl
+ )
- cmake "${_args[@]}" ../"xbmc-$_tag"
- make
- make preinstall
+ cmake "${_args[@]}" ../xbmc
+ make
+ make preinstall
+ fi
+
+ if [[ "$_build_gbm" -eq 1 ]]; then
+ echo "building kodi-gbm"
+ cd "$srcdir/kodi-build-gbm"
+ _args+=(
+ -DCORE_PLATFORM_NAME=gbm
+ -DAPP_RENDER_SYSTEM=gles
+ )
+ cmake "${_args[@]}" ../xbmc
+ make
+ make preinstall
+ fi
}
# kodi