summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorgraysky2021-01-15 04:45:18 -0500
committergraysky2021-01-15 04:45:20 -0500
commit94957c43b8b265f6641e4d9bc6d89fca4d23bb7c (patch)
treee5379427d46fb88b7dc58dfd1de6bd691898d9cb
parentc72c48e91c87595ec385bb3d07f727ff5209ce4c (diff)
downloadaur-94957c43b8b265f6641e4d9bc6d89fca4d23bb7c.tar.gz
Update to 19.0b2-7
Build with native LTO enabled. On aarch64, total installed size reported by pacman vs the identical commit built without native LTO enabled is approx 10% smaller. In addition to the size savings, in general, there known gains in efficiency and speed in the executables/DSOs compiled with LTO. See the following and some of the links therein: https://fedoraproject.org/wiki/LTOByDefault
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD76
2 files changed, 35 insertions, 43 deletions
diff --git a/.SRCINFO b/.SRCINFO
index deba5717ff1b..6683a062bfa3 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = kodi-devel
pkgver = 19.0b2
- pkgrel = 6
+ pkgrel = 7
url = https://kodi.tv
arch = x86_64
license = GPL2
diff --git a/PKGBUILD b/PKGBUILD
index 33f1f337423e..32adcfe5bec1 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -24,7 +24,7 @@ pkgname=(
)
pkgver=19.0b2
#_major=18.7.1
-pkgrel=6
+pkgrel=7
arch=('x86_64')
url="https://kodi.tv"
license=('GPL2')
@@ -46,9 +46,6 @@ makedepends=(
_tag="$pkgver-Matrix"
#_tag="$_major-Matrix"
_sse_workaround=1
-_build_x11=1
-_build_wayland=1
-_build_gbm=1
# Found on their respective github release pages. One can check them against
# what is pulled down when not specifying them in the cmake step.
@@ -150,6 +147,7 @@ build() {
_args=(
-DCMAKE_INSTALL_PREFIX=/usr
-DCMAKE_INSTALL_LIBDIR=/usr/lib
+ -DUSE_LTO=$(nproc)
-DENABLE_EVENTCLIENTS=ON
-DENABLE_INTERNAL_FFMPEG=ON
-DENABLE_INTERNAL_FMT=ON
@@ -169,44 +167,38 @@ build() {
-DSPDLOG_URL="$srcdir/spdlog-$_spdlog_version.tar.gz"
)
- if [[ "$_build_x11" -eq 1 ]]; then
- echo "building kodi-x11"
- cd "$srcdir/kodi-build-x11"
- _args+=(
- -DCORE_PLATFORM_NAME=x11
- -DAPP_RENDER_SYSTEM=gl
- )
-
- cmake "${_args[@]}" ../"xbmc-$_tag"
- make
- make preinstall
- fi
-
- if [[ "$_build_wayland" -eq 1 ]]; then
- echo "building kodi-wayland"
- cd "$srcdir/kodi-build-wayland"
- _args+=(
- -DCORE_PLATFORM_NAME=wayland
- -DAPP_RENDER_SYSTEM=gl
- )
-
- cmake "${_args[@]}" ../"xbmc-$_tag"
- make
- make preinstall
- fi
-
- if [[ "$_build_gbm" -eq 1 ]]; then
- echo "building kodi-gbm"
- cd "$srcdir/kodi-build-gbm"
- _args+=(
- -DCORE_PLATFORM_NAME=gbm
- -DAPP_RENDER_SYSTEM=gles
- )
-
- cmake "${_args[@]}" ../"xbmc-$_tag"
- make
- make preinstall
- fi
+ echo "building kodi-x11"
+ cd "$srcdir/kodi-build-x11"
+ _args+=(
+ -DCORE_PLATFORM_NAME=x11
+ -DAPP_RENDER_SYSTEM=gl
+ )
+
+ cmake "${_args[@]}" ../"xbmc-$_tag"
+ make
+ make preinstall
+
+ echo "building kodi-wayland"
+ cd "$srcdir/kodi-build-wayland"
+ _args+=(
+ -DCORE_PLATFORM_NAME=wayland
+ -DAPP_RENDER_SYSTEM=gl
+ )
+
+ cmake "${_args[@]}" ../"xbmc-$_tag"
+ make
+ make preinstall
+
+ echo "building kodi-gbm"
+ cd "$srcdir/kodi-build-gbm"
+ _args+=(
+ -DCORE_PLATFORM_NAME=gbm
+ -DAPP_RENDER_SYSTEM=gles
+ )
+
+ cmake "${_args[@]}" ../"xbmc-$_tag"
+ make
+ make preinstall
}
# kodi