summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoregnappahz2022-07-13 12:01:40 +0200
committeregnappahz2022-07-13 12:01:40 +0200
commitbf23143cddf6cebf3b519f9f262e9ea9f7c7d2d5 (patch)
tree2bb43057a371daa3c49795c7ff393050869e4810
parent1e07a871fca9697ce882b5bdf79cf51019213131 (diff)
downloadaur-bf23143cddf6cebf3b519f9f262e9ea9f7c7d2d5.tar.gz
Updated to latest alpha version
-rw-r--r--.SRCINFO11
-rw-r--r--PKGBUILD33
2 files changed, 9 insertions, 35 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b46a857b97d7..d05748e9f743 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = kodi-eggz
- pkgver = 19.4
- pkgrel = 5
+ pkgver = 20.0a2
+ pkgrel = 1
url = https://kodi.tv
arch = x86_64
license = GPL2
@@ -56,14 +56,11 @@ pkgbase = kodi-eggz
depends = libcec
depends = tinyxml
depends = shairplay
- noextract = kodi-eggz-ffmpeg-4.3-kodi-dav1d-1.0.tar.gz
- source = kodi-eggz-ffmpeg-4.3-kodi-dav1d-1.0.tar.gz::https://github.com/BlackIkeEagle/kodi-FFmpeg/archive/refs/heads/fix/4.3-kodi-dav1d-1.0.tar.gz
- source = git+https://github.com/xbmc/xbmc.git#tag=19.4-Matrix
- source = git+https://github.com/xbmc/vfs.rar.git#tag=4.0.0-Matrix
+ source = git+https://github.com/xbmc/xbmc.git#tag=20.0a2-Nexus
+ source = git+https://github.com/xbmc/vfs.rar.git#tag=20.1.0-Nexus
source = removestupidremarks.patch
sha256sums = SKIP
sha256sums = SKIP
- sha256sums = SKIP
sha256sums = e89cc7c880b0b10361b882339b542ad49be91ae78de9d4b38ddc08b594734cf5
pkgname = kodi-eggz
diff --git a/PKGBUILD b/PKGBUILD
index 3978ed13a50d..7dec294597c3 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,9 +1,9 @@
pkgbase=kodi-eggz
pkgname=kodi-eggz
-pkgver=19.4
-gittag=19.4-Matrix
-gittagvfs=4.0.0-Matrix
-pkgrel=5
+pkgver=20.0a2
+gittag=20.0a2-Nexus
+gittagvfs=20.1.0-Nexus
+pkgrel=1
arch=('x86_64')
url="https://kodi.tv"
license=('GPL2')
@@ -20,23 +20,15 @@ makedepends=(
'fstrcmp' 'spdlog'
)
-_ffmpeg_version="4.3-kodi-dav1d-1.0"
-
source=(
- "$pkgbase-ffmpeg-$_ffmpeg_version.tar.gz::https://github.com/BlackIkeEagle/kodi-FFmpeg/archive/refs/heads/fix/4.3-kodi-dav1d-1.0.tar.gz"
"git+https://github.com/xbmc/xbmc.git#tag=$gittag"
"git+https://github.com/xbmc/vfs.rar.git#tag=$gittagvfs"
"removestupidremarks.patch"
)
-noextract=(
- "$pkgbase-ffmpeg-$_ffmpeg_version.tar.gz"
-)
-
sha256sums=(
'SKIP'
'SKIP'
-'SKIP'
'e89cc7c880b0b10361b882339b542ad49be91ae78de9d4b38ddc08b594734cf5'
)
@@ -56,27 +48,12 @@ prepare() {
cmake -DADDONS_TO_BUILD=vfs.rar -DADDON_SRC_PREFIX=../.. -DCMAKE_BUILD_TYPE=Debug -DCMAKE_INSTALL_PREFIX=../../xbmc/kodi-build/addons -DPACKAGE_ZIP=1 ../../xbmc/cmake/addons
make -j $threads || exit 2
-
- msg "Prepare DEPs"
- msg2 "pivot to git dir"
- cd ${srcdir}/xbmc
- msg2 "making DEP/crossguid"
- make -j $threads -C tools/depends/target/crossguid PREFIX=${srcdir}/usr
- msg2 "making DEP/flatbuffers"
- make -j $threads -C tools/depends/target/flatbuffers PREFIX=${srcdir}/usr
- msg2 "making DEP/libfmt"
- make -j $threads -C tools/depends/target/libfmt PREFIX=${srcdir}/usr
- msg2 "making DEP/libspdlog"
- make -j $threads -C tools/depends/target/libspdlog PREFIX=${srcdir}/usr
-
msg "Prepare Kodi"
msg2 "Patching Kodisource"
while read patch; do
echo "Applying $patch"
git apply $patch || exit 2
done <<< $(ls ../../*.patch)
-
-
}
build() {
@@ -87,7 +64,7 @@ build() {
cd ${srcdir}/kodi-build
msg2 "cmake configure phase"
export APP_RENDER_SYSTEM=gl
- cmake ../xbmc -DCMAKE_INSTALL_PREFIX=/usr -DX11_RENDER_SYSTEM=gl -DENABLE_INTERNAL_FMT=on -DENABLE_INTERNAL_FFMPEG=ON -DENABLE_INTERNAL_CROSSGUID=ON -DENABLE_INTERNAL_FSTRCMP=ON -DENABLE_INTERNAL_FLATBUFFERS=ON -DENABLE_INTERNAL_SPDLOG=ON -DENABLE_MYSQLCLIENT=ON -DENABLE_INTERNAL_FFMPEG=ON -DFFMPEG_URL="$srcdir/$pkgbase-ffmpeg-$_ffmpeg_version.tar.gz"
+ cmake ../xbmc -DCMAKE_INSTALL_PREFIX=/usr -DX11_RENDER_SYSTEM=gl -DENABLE_INTERNAL_FMT=on -DENABLE_INTERNAL_FFMPEG=ON -DENABLE_INTERNAL_CROSSGUID=ON -DENABLE_INTERNAL_FSTRCMP=ON -DENABLE_INTERNAL_FLATBUFFERS=ON -DENABLE_INTERNAL_SPDLOG=ON -DENABLE_MYSQLCLIENT=ON
msg2 "cmake build phase"
cmake --build . -- #VERBOSE=1