summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoregnappahz2022-12-20 12:58:34 +0100
committeregnappahz2022-12-20 12:58:34 +0100
commite8708bf85ef46637d8a88ebf63f87a593cb63b06 (patch)
tree253bcefdf1a946024165270f410a1da258cd95e5
parente6e7a0bfd9840e3334328dcca3657062bdaf2dd7 (diff)
downloadaur-e8708bf85ef46637d8a88ebf63f87a593cb63b06.tar.gz
Updated (and some fixes..)
-rw-r--r--.SRCINFO8
-rw-r--r--Fix-eglextchromium.patch70
-rw-r--r--PKGBUILD12
-rw-r--r--removestupidremarks.patch27
4 files changed, 80 insertions, 37 deletions
diff --git a/.SRCINFO b/.SRCINFO
index cf754e8bbe7b..6f17cd7e47bc 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,5 +1,5 @@
pkgbase = kodi-eggz
- pkgver = 20.0rc1
+ pkgver = 20.0rc2
pkgrel = 1
url = https://kodi.tv
arch = x86_64
@@ -57,12 +57,12 @@ pkgbase = kodi-eggz
depends = libcec
depends = tinyxml
depends = shairplay
- source = git+https://github.com/xbmc/xbmc.git#tag=20.0rc1-Nexus
+ source = git+https://github.com/xbmc/xbmc.git#tag=20.0rc2-Nexus
source = git+https://github.com/xbmc/vfs.rar.git#tag=20.1.0-Nexus
- source = removestupidremarks.patch
+ source = Fix-eglextchromium.patch
sha256sums = SKIP
sha256sums = SKIP
- sha256sums = 2b70aecae2fb11fef8f925baa8e272cacb17add58fc6fdbf791b30e7e4b2baed
+ sha256sums = faff047172c3b1cccd62aa6e30fd81e97eac7dd964ac19649755600cfe820b1f
pkgname = kodi-eggz
pkgdesc = Latest stable-ish kodi build with VFS automaticly installed
diff --git a/Fix-eglextchromium.patch b/Fix-eglextchromium.patch
new file mode 100644
index 000000000000..844ef60554d4
--- /dev/null
+++ b/Fix-eglextchromium.patch
@@ -0,0 +1,70 @@
+From 027ae633671d91b2c4ceea33f09d3311b77ca162 Mon Sep 17 00:00:00 2001
+From: egnappahz <egnappah@gmail.com>
+Date: Tue, 20 Dec 2022 12:33:42 +0100
+Subject: [PATCH] Fix eglextchromium.h
+
+Signed-off-by: egnappahz <egnappah@gmail.com>
+---
+ cmake/modules/FindEGL.cmake | 7 ++++++-
+ cmake/scripts/common/Platform.cmake | 3 ++-
+ xbmc/windowing/X11/GLContextEGL.h | 4 ++++
+ 3 files changed, 12 insertions(+), 2 deletions(-)
+
+diff --git a/cmake/modules/FindEGL.cmake b/cmake/modules/FindEGL.cmake
+index b00fe08a25..3805f41e18 100644
+--- a/cmake/modules/FindEGL.cmake
++++ b/cmake/modules/FindEGL.cmake
+@@ -9,6 +9,7 @@
+ # EGL_INCLUDE_DIRS - the EGL include directory
+ # EGL_LIBRARIES - the EGL libraries
+ # EGL_DEFINITIONS - the EGL definitions
++# HAVE_EGLEXTANGLE - if eglext_angle.h exists else use eglextchromium.h
+ #
+ # and the following imported targets::
+ #
+@@ -35,7 +36,11 @@ if(EGL_FOUND)
+ set(EGL_LIBRARIES ${EGL_LIBRARY})
+ set(EGL_INCLUDE_DIRS ${EGL_INCLUDE_DIR})
+ set(EGL_DEFINITIONS -DHAS_EGL=1)
+-
++ include(CheckIncludeFile)
++ check_include_file("EGL/eglext_angle.h" HAVE_EGLEXTANGLE)
++ if(HAVE_EGLEXTANGLE)
++ list(APPEND EGL_DEFINITIONS "-DHAVE_EGLEXTANGLE=1")
++ endif()
+ if(NOT TARGET EGL::EGL)
+ add_library(EGL::EGL UNKNOWN IMPORTED)
+ set_target_properties(EGL::EGL PROPERTIES
+diff --git a/cmake/scripts/common/Platform.cmake b/cmake/scripts/common/Platform.cmake
+index 397d8d46e8..87852ef9fc 100644
+--- a/cmake/scripts/common/Platform.cmake
++++ b/cmake/scripts/common/Platform.cmake
+@@ -8,7 +8,8 @@ if(CORE_SYSTEM_NAME STREQUAL linux OR CORE_SYSTEM_NAME STREQUAL freebsd)
+ set(_DEFAULT_PLATFORM X11 WAYLAND GBM)
+
+ if(NOT APP_RENDER_SYSTEM)
+- message(SEND_ERROR "You need to decide whether you want to use GL- or GLES-based rendering. Please set APP_RENDER_SYSTEM to either \"gl\" or \"gles\". For normal desktop systems, you will usually want to use \"gl\".")
++ # message(SEND_ERROR "You need to decide whether you want to use GL- or GLES-based rendering. Please set APP_RENDER_SYSTEM to either \"gl\" or \"gles\". For normal desktop systems, you will usually want to use \"gl\".")
++ set(APP_RENDER_SYSTEM "gl")
+ endif()
+ else()
+ string(TOLOWER ${CORE_SYSTEM_NAME} _DEFAULT_PLATFORM)
+diff --git a/xbmc/windowing/X11/GLContextEGL.h b/xbmc/windowing/X11/GLContextEGL.h
+index 99a6a9024e..afea0b7c43 100644
+--- a/xbmc/windowing/X11/GLContextEGL.h
++++ b/xbmc/windowing/X11/GLContextEGL.h
+@@ -13,7 +13,11 @@
+ #include "threads/CriticalSection.h"
+
+ #include <EGL/eglext.h>
++#ifdef HAVE_EGLEXTANGLE
++#include <EGL/eglext_angle.h>
++#else
+ #include <EGL/eglextchromium.h>
++#endif
+ #include <X11/Xutil.h>
+
+ class CGLContextEGL : public CGLContext
+--
+2.39.0
+
diff --git a/PKGBUILD b/PKGBUILD
index 2d1d51b5b706..53f78762984d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
pkgbase=kodi-eggz
pkgname=kodi-eggz
-pkgver=20.0rc1
-gittag=20.0rc1-Nexus
+pkgver=20.0rc2
+gittag=20.0rc2-Nexus
gittagvfs=20.1.0-Nexus
pkgrel=1
arch=('x86_64')
@@ -23,13 +23,13 @@ makedepends=(
source=(
"git+https://github.com/xbmc/xbmc.git#tag=$gittag"
"git+https://github.com/xbmc/vfs.rar.git#tag=$gittagvfs"
- "removestupidremarks.patch"
+ "Fix-eglextchromium.patch"
)
sha256sums=(
'SKIP'
'SKIP'
-'2b70aecae2fb11fef8f925baa8e272cacb17add58fc6fdbf791b30e7e4b2baed'
+'faff047172c3b1cccd62aa6e30fd81e97eac7dd964ac19649755600cfe820b1f'
)
pkgver() {
@@ -54,7 +54,7 @@ prepare() {
msg2 "Patching Kodisource"
while read patch; do
echo "Applying $patch"
- git apply $patch || exit 2
+ git apply $patch
done <<< $(ls ../../*.patch)
}
@@ -66,7 +66,7 @@ build() {
cd ${srcdir}/kodi-build
msg2 "cmake configure phase"
export APP_RENDER_SYSTEM=gl
- cmake ../xbmc -DCMAKE_INSTALL_PREFIX=/usr -DX11_RENDER_SYSTEM=gl -DENABLE_INTERNAL_FMT=on -DENABLE_INTERNAL_FFMPEG=ON -DENABLE_INTERNAL_CROSSGUID=ON -DENABLE_INTERNAL_FSTRCMP=ON -DENABLE_INTERNAL_SPDLOG=ON -DENABLE_MYSQLCLIENT=ON
+ cmake ../xbmc -DCMAKE_INSTALL_PREFIX=/usr -DX11_RENDER_SYSTEM=gl -DENABLE_INTERNAL_FMT=on -DENABLE_INTERNAL_FFMPEG=ON -DENABLE_INTERNAL_CROSSGUID=ON -DENABLE_INTERNAL_FSTRCMP=ON -DENABLE_INTERNAL_SPDLOG=ON -DENABLE_MYSQLCLIENT=ON -DHAVE_EGLEXTANGLE=1
msg2 "cmake build phase"
cmake --build . -- #VERBOSE=1
diff --git a/removestupidremarks.patch b/removestupidremarks.patch
deleted file mode 100644
index 7553656be223..000000000000
--- a/removestupidremarks.patch
+++ /dev/null
@@ -1,27 +0,0 @@
-From 51c182c0de4ee3a8c7056975189d0ee4afbe487a Mon Sep 17 00:00:00 2001
-From: egnappahz <egnappah@gmail.com>
-Date: Fri, 9 Sep 2022 09:25:02 +0200
-Subject: [PATCH] No.
-
-Signed-off-by: egnappahz <egnappah@gmail.com>
----
- cmake/scripts/common/Platform.cmake | 3 ++-
- 1 file changed, 2 insertions(+), 1 deletion(-)
-
-diff --git a/cmake/scripts/common/Platform.cmake b/cmake/scripts/common/Platform.cmake
-index 397d8d46e8..87852ef9fc 100644
---- a/cmake/scripts/common/Platform.cmake
-+++ b/cmake/scripts/common/Platform.cmake
-@@ -8,7 +8,8 @@ if(CORE_SYSTEM_NAME STREQUAL linux OR CORE_SYSTEM_NAME STREQUAL freebsd)
- set(_DEFAULT_PLATFORM X11 WAYLAND GBM)
-
- if(NOT APP_RENDER_SYSTEM)
-- message(SEND_ERROR "You need to decide whether you want to use GL- or GLES-based rendering. Please set APP_RENDER_SYSTEM to either \"gl\" or \"gles\". For normal desktop systems, you will usually want to use \"gl\".")
-+ # message(SEND_ERROR "You need to decide whether you want to use GL- or GLES-based rendering. Please set APP_RENDER_SYSTEM to either \"gl\" or \"gles\". For normal desktop systems, you will usually want to use \"gl\".")
-+ set(APP_RENDER_SYSTEM "gl")
- endif()
- else()
- string(TOLOWER ${CORE_SYSTEM_NAME} _DEFAULT_PLATFORM)
---
-2.37.3
-