summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorgraysky2019-11-25 13:42:17 -0500
committergraysky2019-11-25 13:42:17 -0500
commit810be3dd0992a9cb8db56d4da8d8b2412b516be3 (patch)
treee0a2291ab63129ed12e8999b23e20cbd701aa623
parent7efa8865f8883043b5afdbcd11bc5516ae28a2ad (diff)
downloadaur-810be3dd0992a9cb8db56d4da8d8b2412b516be3.tar.gz
Update to r53775.6c39aebde24-1
-rw-r--r--.SRCINFO16
-rw-r--r--000-python3.8.patch34
-rw-r--r--PKGBUILD9
3 files changed, 50 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 79e81f5d347a..bb5f324ba99e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,5 +1,5 @@
pkgbase = kodi-git
- pkgver = r53675.88fffa1392b
+ pkgver = r53775.6c39aebde24
pkgrel = 1
url = https://kodi.tv
arch = x86_64
@@ -70,6 +70,7 @@ pkgbase = kodi-git
source = http://mirrors.kodi.tv/build-deps/sources/fstrcmp-0.7.D001.tar.gz
source = http://mirrors.kodi.tv/build-deps/sources/flatbuffers-1.11.0.tar.gz
source = cpuinfo
+ source = 000-python3.8.patch
sha256sums = SKIP
sha256sums = 38816f8373e243bc5950449b4f3b18938c4e1c59348e3411e23f31db4072e40d
sha256sums = 071e414e61b795f2ff9015b21a85fc009dde967f27780d23092643916538a57a
@@ -80,6 +81,7 @@ pkgbase = kodi-git
sha256sums = e4018e850f80700acee8da296e56e15b1eef711ab15157e542e7d7e1237c3476
sha256sums = 1789b97e790da8f2cb5ff827d15580878c8629fd889f5f038d7524dca43eacc9
sha256sums = 27387e49043127f09c5ef0a931fffb864f5730e79629100a6e210b68a1b9f2c1
+ sha256sums = edff38cea510817c3682c7c6086054ac49adaa478285093ea294d83db065b83f
pkgname = kodi-git
pkgdesc = A software media player and entertainment hub for digital media (master branch)
@@ -98,7 +100,7 @@ pkgname = kodi-git
optdepends = libplist: AirPlay support
optdepends = pulseaudio: PulseAudio support
optdepends = upower: Display battery level
- provides = kodi=r53675.88fffa1392b
+ provides = kodi=r53775.6c39aebde24
conflicts = kodi
pkgname = kodi-git-bin
@@ -149,7 +151,7 @@ pkgname = kodi-git-wayland
depends = tinyxml
depends = waylandpp>=0.2.7-1
depends = kodi-git
- provides = kodi-git-bin=r53675.88fffa1392b
+ provides = kodi-git-bin=r53775.6c39aebde24
conflicts = kodi-wayland
pkgname = kodi-git-gbm
@@ -175,14 +177,14 @@ pkgname = kodi-git-gbm
depends = taglib
depends = tinyxml
depends = kodi-git
- provides = kodi-git-bin=r53675.88fffa1392b
+ provides = kodi-git-bin=r53775.6c39aebde24
provides = kodi-gbm
conflicts = kodi-gbm
pkgname = kodi-git-eventclients
pkgdesc = Kodi Event Clients (master branch)
optdepends = python: most eventclients are implemented in python
- provides = kodi-eventclients=r53675.88fffa1392b
+ provides = kodi-eventclients=r53775.6c39aebde24
conflicts = kodi-eventclients
pkgname = kodi-git-tools-texturepacker
@@ -191,12 +193,12 @@ pkgname = kodi-git-tools-texturepacker
depends = giflib
depends = libjpeg-turbo
depends = lzo
- provides = kodi-tools-texturepacker=r53675.88fffa1392b
+ provides = kodi-tools-texturepacker=r53775.6c39aebde24
conflicts = kodi-tools-texturepacker
pkgname = kodi-git-dev
pkgdesc = Kodi dev files (master branch)
depends = kodi-git
- provides = kodi-dev=r53675.88fffa1392b
+ provides = kodi-dev=r53775.6c39aebde24
conflicts = kodi-dev
diff --git a/000-python3.8.patch b/000-python3.8.patch
new file mode 100644
index 000000000000..e26dd3decd9f
--- /dev/null
+++ b/000-python3.8.patch
@@ -0,0 +1,34 @@
+Upstream bug report, https://github.com/xbmc/xbmc/issues/16560
+Patch by asavah, https://forum.kodi.tv/showthread.php?tid=349548
+
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index 2fb6bf5bed..52be5b649d 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -163,7 +163,7 @@ find_package(JsonSchemaBuilder REQUIRED)
+ core_optional_dep(${optional_deps})
+ core_require_dep(${required_deps})
+
+-SET(PYTHON_VERSION 3.7)
++SET(PYTHON_VERSION 3.8)
+
+ if(ENABLE_MARIADBCLIENT AND NOT ENABLE_MARIADBCLIENT STREQUAL AUTO AND ENABLE_MYSQLCLIENT AND NOT ENABLE_MYSQLCLIENT STREQUAL AUTO)
+ MESSAGE(FATAL_ERROR "You can not use MySql and MariaDB at the same time. Disable one by adding -DENABLE_MYSQLCLIENT=OFF or -DENABLE_MARIADBCLIENT=OFF.")
+diff --git a/xbmc/interfaces/python/PythonInvoker.cpp b/xbmc/interfaces/python/PythonInvoker.cpp
+index 4342e05dcd..660e82c254 100644
+--- a/xbmc/interfaces/python/PythonInvoker.cpp
++++ b/xbmc/interfaces/python/PythonInvoker.cpp
+@@ -8,6 +8,14 @@
+
+ // python.h should always be included first before any other includes
+ #include <Python.h>
++#if PY_VERSION_HEX >= 0x03080000
++# define Py_BUILD_CORE
++# undef HAVE_STD_ATOMIC
++/* for access to the fields of PyInterpreterState */
++# include "internal/pycore_pystate.h"
++# undef Py_BUILD_CORE
++# define HAVE_STD_ATOMIC
++#endif
+ #include <iterator>
+ #include <osdefs.h>
diff --git a/PKGBUILD b/PKGBUILD
index c672ae81d981..cc1b51fced66 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -21,7 +21,7 @@ pkgname=(
"$pkgbase-eventclients" "$pkgbase-tools-texturepacker" "$pkgbase-dev"
)
_gitname='xbmc'
-pkgver=r53675.88fffa1392b
+pkgver=r53775.6c39aebde24
pkgrel=1
arch=('x86_64')
url="https://kodi.tv"
@@ -73,6 +73,7 @@ source=(
"http://mirrors.kodi.tv/build-deps/sources/fstrcmp-$_fstrcmp_version.tar.gz"
"http://mirrors.kodi.tv/build-deps/sources/flatbuffers-$_flatbuffers_version.tar.gz"
cpuinfo
+ 000-python3.8.patch
)
noextract=(
"libdvdcss-$_libdvdcss_version.tar.gz"
@@ -93,7 +94,8 @@ sha256sums=('SKIP'
'3d77d09a5df0de510aeeb940df4cb534787ddff3bb1828779753f5dfa1229d10'
'e4018e850f80700acee8da296e56e15b1eef711ab15157e542e7d7e1237c3476'
'1789b97e790da8f2cb5ff827d15580878c8629fd889f5f038d7524dca43eacc9'
- '27387e49043127f09c5ef0a931fffb864f5730e79629100a6e210b68a1b9f2c1')
+ '27387e49043127f09c5ef0a931fffb864f5730e79629100a6e210b68a1b9f2c1'
+ 'edff38cea510817c3682c7c6086054ac49adaa478285093ea294d83db065b83f')
pkgver() {
cd "$_gitname"
@@ -116,6 +118,8 @@ prepare() {
local _replace="exec_program(cat ARGS \"/build/$pkgname/src/cpuinfo\" OUTPUT_VARIABLE CPUINFO)"
sed -i s"|$_find|$_replace|" cmake/modules/FindSSE.cmake
fi
+
+ patch -Np1 -i ../000-python3.8.patch
}
build() {
@@ -136,6 +140,7 @@ build() {
-DENABLE_INTERNAL_FSTRCMP=ON \
-DENABLE_INTERNAL_FLATBUFFERS=ON \
-DENABLE_MYSQLCLIENT=ON \
+ -DX11_RENDER_SYSTEM=gl \
-Dlibdvdcss_URL="$srcdir/libdvdcss-$_libdvdcss_version.tar.gz" \
-Dlibdvdnav_URL="$srcdir/libdvdnav-$_libdvdnav_version.tar.gz" \
-Dlibdvdread_URL="$srcdir/libdvdread-$_libdvdread_version.tar.gz" \