summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorgraysky2021-01-05 14:45:29 -0500
committergraysky2021-01-05 14:45:29 -0500
commitd304d05c413614f367e72b731597b1473b96dadf (patch)
tree8b3efdde31a5540f8125dca692e52a38102b373f
parent482793b83cda46cfe61421aa4f265d5696782fe0 (diff)
downloadaur-d304d05c413614f367e72b731597b1473b96dadf.tar.gz
Update to r56885.b783517b55d-1
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD77
2 files changed, 43 insertions, 52 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 09613c913685..dd874d125a80 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = kodi-git
- pkgver = r56865.af8aded66c1
- pkgrel = 2
+ pkgver = r56885.b783517b55d
+ pkgrel = 1
url = https://kodi.tv
arch = x86_64
license = GPL2
@@ -107,7 +107,7 @@ pkgname = kodi-git
optdepends = pulseaudio: PulseAudio support
optdepends = upower: Display battery level
provides = xbmc
- provides = kodi=r56865.af8aded66c1
+ provides = kodi=r56885.b783517b55d
conflicts = xbmc
conflicts = kodi
replaces = xbmc
@@ -137,7 +137,7 @@ pkgname = kodi-git-x11
depends = tinyxml
depends = kodi-git
provides = KODI-GIT-BIN
- provides = kodi-x11=r56865.af8aded66c1
+ provides = kodi-x11=r56885.b783517b55d
conflicts = kodi-x11
replaces = kodi-bin
@@ -165,7 +165,7 @@ pkgname = kodi-git-wayland
depends = waylandpp
depends = kodi-git
provides = KODI-GIT-BIN
- provides = kodi-wayland=r56865.af8aded66c1
+ provides = kodi-wayland=r56885.b783517b55d
conflicts = kodi-wayland
pkgname = kodi-git-gbm
@@ -193,13 +193,13 @@ pkgname = kodi-git-gbm
depends = tinyxml
depends = kodi-git
provides = KODI-GIT-BIN
- provides = kodi-gbm=r56865.af8aded66c1
+ provides = kodi-gbm=r56885.b783517b55d
conflicts = kodi-gbm
pkgname = kodi-git-eventclients
pkgdesc = Kodi Event Clients (master branch)
optdepends = python: most eventclients are implemented in python
- provides = kodi-eventclients=r56865.af8aded66c1
+ provides = kodi-eventclients=r56885.b783517b55d
conflicts = kodi-eventclients
pkgname = kodi-git-tools-texturepacker
@@ -208,12 +208,12 @@ pkgname = kodi-git-tools-texturepacker
depends = giflib
depends = libjpeg-turbo
depends = lzo
- provides = kodi-tools-texturepacker=r56865.af8aded66c1
+ provides = kodi-tools-texturepacker=r56885.b783517b55d
conflicts = kodi-tools-texturepacker
pkgname = kodi-git-dev
pkgdesc = Kodi dev files (master branch)
depends = kodi-git
- provides = kodi-dev=r56865.af8aded66c1
+ provides = kodi-dev=r56885.b783517b55d
conflicts = kodi-dev
diff --git a/PKGBUILD b/PKGBUILD
index 9499b3ca52af..b0c0c55a33c7 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -21,8 +21,8 @@ pkgname=(
"$pkgbase" "$pkgbase-x11" "$pkgbase-wayland" "$pkgbase-gbm"
"$pkgbase-eventclients" "$pkgbase-tools-texturepacker" "$pkgbase-dev"
)
-pkgver=r56865.af8aded66c1
-pkgrel=2
+pkgver=r56885.b783517b55d
+pkgrel=1
arch=('x86_64')
url="https://kodi.tv"
license=('GPL2')
@@ -41,12 +41,8 @@ makedepends=(
'libinput'
)
-_codename=Leia
_gitname='xbmc'
_sse_workaround=1
-_build_x11=1
-_build_wayland=1
-_build_gbm=1
# Found on their respective github release pages. One can check them against
# what is pulled down when not specifying them in the cmake step.
@@ -156,43 +152,38 @@ build() {
-DSPDLOG_URL="$srcdir/spdlog-$_spdlog_version.tar.gz"
)
- if [[ "$_build_x11" -eq 1 ]]; then
- echo "building kodi-x11"
- cd "$srcdir/kodi-build-x11"
- _args+=(
- -DCORE_PLATFORM_NAME=x11
- -DAPP_RENDER_SYSTEM=gl
- )
-
- cmake "${_args[@]}" ../xbmc
- make
- make preinstall
- fi
-
- if [[ "$_build_wayland" -eq 1 ]]; then
- echo "building kodi-wayland"
- cd "$srcdir/kodi-build-wayland"
- _args+=(
- -DCORE_PLATFORM_NAME=wayland
- -DAPP_RENDER_SYSTEM=gl
- )
-
- cmake "${_args[@]}" ../xbmc
- make
- make preinstall
- fi
-
- if [[ "$_build_gbm" -eq 1 ]]; then
- echo "building kodi-gbm"
- cd "$srcdir/kodi-build-gbm"
- _args+=(
- -DCORE_PLATFORM_NAME=gbm
- -DAPP_RENDER_SYSTEM=gles
- )
- cmake "${_args[@]}" ../xbmc
- make
- make preinstall
- fi
+ echo "building kodi-x11"
+ cd "$srcdir/kodi-build-x11"
+ _args+=(
+ -DCORE_PLATFORM_NAME=x11
+ -DAPP_RENDER_SYSTEM=gl
+ )
+
+ cmake "${_args[@]}" ../xbmc
+ make
+ make preinstall
+
+ echo "building kodi-wayland"
+ cd "$srcdir/kodi-build-wayland"
+ _args+=(
+ -DCORE_PLATFORM_NAME=wayland
+ -DAPP_RENDER_SYSTEM=gl
+ )
+
+ cmake "${_args[@]}" ../xbmc
+ make
+ make preinstall
+
+ echo "building kodi-gbm"
+ cd "$srcdir/kodi-build-gbm"
+ _args+=(
+ -DCORE_PLATFORM_NAME=gbm
+ -DAPP_RENDER_SYSTEM=gles
+ )
+
+ cmake "${_args[@]}" ../xbmc
+ make
+ make preinstall
}
# kodi