summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorgraysky2023-12-22 09:33:10 -0500
committergraysky2023-12-22 09:33:10 -0500
commite31f483662cbb44d38c325dc244a79fda3c26d61 (patch)
tree0f735f93db20a8404494c581199caa73f1f20926
parenta0a5f34b29ef0b808ca8e2120f5f0b538b5691c9 (diff)
downloadaur-e31f483662cbb44d38c325dc244a79fda3c26d61.tar.gz
Update to r62252.b8fafb0a41d-1
-rw-r--r--.SRCINFO69
-rw-r--r--PKGBUILD73
2 files changed, 122 insertions, 20 deletions
diff --git a/.SRCINFO b/.SRCINFO
index a15404927696..4fc3c22d1e19 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,5 +1,5 @@
pkgbase = kodi-nexus-git
- pkgver = r62217.618d1e35d89
+ pkgver = r62252.b8fafb0a41d
pkgrel = 1
url = https://kodi.tv
arch = x86_64
@@ -98,7 +98,7 @@ pkgbase = kodi-nexus-git
b2sums = 7e15afcc0cc7f529e6c491c985968bc53be413424b890e4eab2ce8e3d0f21b08347698e660e0f4f0cc50c5279f052be7a2d84d5351509d34193066d797a44130
pkgname = kodi-nexus-git
- pkgdesc = A software media player and entertainment hub for digital media (Nexus branch)
+ pkgdesc = A software media player and entertainment hub for digital media (gl renderer, Nexus branch)
depends = bluez-libs
depends = curl
depends = dav1d
@@ -118,6 +118,62 @@ pkgname = kodi-nexus-git
depends = libvdpau
depends = libxslt
depends = lirc
+ depends = lzo
+ depends = mariadb-libs
+ depends = mesa
+ depends = libpipewire
+ depends = python-pillow
+ depends = python-pycryptodomex
+ depends = python-simplejson
+ depends = shairplay
+ depends = smbclient
+ depends = sndio
+ depends = spdlog
+ depends = sqlite
+ depends = taglib
+ depends = tinyxml
+ depends = libxrandr
+ depends = libxkbcommon
+ depends = waylandpp
+ depends = libinput
+ depends = pcre
+ optdepends = afpfs-ng: Apple shares support
+ optdepends = bluez: Blutooth support
+ optdepends = python-pybluez: Bluetooth support
+ optdepends = pulseaudio: PulseAudio support
+ optdepends = pipewire: PipeWire support
+ optdepends = upower: Display battery level
+ provides = kodi-common=r62252.b8fafb0a41d
+ provides = kodi-x11
+ provides = kodi-wayland
+ provides = kodi-gbm
+ conflicts = kodi-gles
+ conflicts = kodi-x11
+ conflicts = kodi-wayland
+ conflicts = kodi-gbm
+
+pkgname = kodi-nexus-git-gles
+ pkgdesc = A software media player and entertainment hub for digital media (gles renderer, Nexus branch)
+ depends = bluez-libs
+ depends = curl
+ depends = dav1d
+ depends = desktop-file-utils
+ depends = hicolor-icon-theme
+ depends = fmt
+ depends = lcms2
+ depends = libass
+ depends = libbluray
+ depends = libcdio
+ depends = libcec
+ depends = libmicrohttpd
+ depends = libnfs
+ depends = libplist
+ depends = libpulse
+ depends = libva
+ depends = libvdpau
+ depends = libxslt
+ depends = lirc
+ depends = lzo
depends = mariadb-libs
depends = mesa
depends = libpipewire
@@ -142,7 +198,8 @@ pkgname = kodi-nexus-git
optdepends = pulseaudio: PulseAudio support
optdepends = pipewire: PipeWire support
optdepends = upower: Display battery level
- provides = kodi=r62217.618d1e35d89
+ provides = kodi-common=r62252.b8fafb0a41d
+ provides = kodi=r62252.b8fafb0a41d
provides = kodi-x11
provides = kodi-wayland
provides = kodi-gbm
@@ -155,7 +212,7 @@ pkgname = kodi-nexus-git-eventclients
pkgdesc = Kodi Event Clients (Nexus branch)
optdepends = kodi: local machine eventclient use
optdepends = python: most eventclients are implemented in python
- provides = kodi-eventclients=r62217.618d1e35d89
+ provides = kodi-eventclients=r62252.b8fafb0a41d
conflicts = kodi-eventclients
pkgname = kodi-nexus-git-tools-texturepacker
@@ -164,11 +221,11 @@ pkgname = kodi-nexus-git-tools-texturepacker
depends = giflib
depends = libjpeg-turbo
depends = lzo
- provides = kodi-tools-texturepacker=r62217.618d1e35d89
+ provides = kodi-tools-texturepacker=r62252.b8fafb0a41d
conflicts = kodi-tools-texturepacker
pkgname = kodi-nexus-git-dev
pkgdesc = Kodi dev files (Nexus branch)
depends = kodi-nexus-git
- provides = kodi-nexus-dev=r62217.618d1e35d89
+ provides = kodi-nexus-dev=r62252.b8fafb0a41d
conflicts = kodi-nexus-dev
diff --git a/PKGBUILD b/PKGBUILD
index b4f6a6e7e5a6..3803f32e74dc 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -21,8 +21,8 @@
_clangbuild=
pkgbase=kodi-nexus-git
-pkgname=("$pkgbase" "$pkgbase-eventclients" "$pkgbase-tools-texturepacker" "$pkgbase-dev")
-pkgver=r62217.618d1e35d89
+pkgname=("$pkgbase" "$pkgbase-gles" "$pkgbase-eventclients" "$pkgbase-tools-texturepacker" "$pkgbase-dev")
+pkgver=r62252.b8fafb0a41d
pkgrel=1
arch=('x86_64')
url="https://kodi.tv"
@@ -48,7 +48,6 @@ options=(!lto)
_gitname=xbmc
_codename=Nexus
-
_sse_workaround=1
# Found on their respective github release pages. One can check them against
@@ -113,13 +112,13 @@ pkgver() {
}
prepare() {
- [[ -d kodi-build ]] && rm -rf kodi-build
+ [[ -d "$srcdir/kodi-build" ]] && rm -rf "$srcdir/kodi-build"
mkdir "$srcdir/kodi-build"
+ [[ -d "$srcdir/kodi-build-gles" ]] && rm -rf "$srcdir/kodi-build-gles"
+ mkdir "$srcdir/kodi-build-gles"
cd "$_gitname"
- rm -rf system/certs # remove not needed cacert
-
[[ "$_sse_workaround" -eq 1 ]] && patch -p1 -i "$srcdir/cheat-sse-build.patch"
patch -p1 -i ../0001-ffmpeg-fix-build-with-binutils-update.patch
@@ -132,7 +131,6 @@ prepare() {
}
build() {
- cd "$srcdir/kodi-build"
_args=(
-DCMAKE_BUILD_TYPE=Release
@@ -174,26 +172,31 @@ build() {
-DFSTRCMP_URL="$srcdir/fstrcmp-$_fstrcmp_version.tar.gz"
-DFLATBUFFERS_URL="$srcdir/flatbuffers-$_flatbuffers_version.tar.gz"
-DUDFREAD_URL="$srcdir/libudfread-$_libudfread_version.tar.gz"
- -DAPP_RENDER_SYSTEM=gl
)
# https://github.com/google/flatbuffers/issues/7404
CXXFLAGS+=' -Wno-error=restrict'
echo "building kodi"
- cmake "${_args[@]}" ../"$_gitname"
+ cd "$srcdir/kodi-build"
+ cmake "${_args[@]}" -DAPP_RENDER_SYSTEM=gl ../"$_gitname"
+ make
+
+ echo "building kodi-gles"
+ cd "$srcdir/kodi-build-gles"
+ cmake "${_args[@]}" -DAPP_RENDER_SYSTEM=gles ../"$_gitname"
make
}
# kodi
# components: kodi
package_kodi-nexus-git() {
- pkgdesc="A software media player and entertainment hub for digital media (Nexus branch)"
+ pkgdesc="A software media player and entertainment hub for digital media (gl renderer, Nexus branch)"
depends=(
'bluez-libs' 'curl' 'dav1d' 'desktop-file-utils' 'hicolor-icon-theme' 'fmt'
'lcms2' 'libass' 'libbluray' 'libcdio' 'libcec' 'libmicrohttpd' 'libnfs'
- 'libplist' 'libpulse' 'libva' 'libvdpau' 'libxslt' 'lirc' 'mariadb-libs'
- 'mesa' 'libpipewire' 'python-pillow' 'python-pycryptodomex'
+ 'libplist' 'libpulse' 'libva' 'libvdpau' 'libxslt' 'lirc' 'lzo'
+ 'mariadb-libs' 'mesa' 'libpipewire' 'python-pillow' 'python-pycryptodomex'
'python-simplejson' 'shairplay' 'smbclient' 'sndio' 'spdlog' 'sqlite'
'taglib' 'tinyxml' 'libxrandr' 'libxkbcommon' 'waylandpp' 'libinput'
'pcre'
@@ -208,8 +211,8 @@ package_kodi-nexus-git() {
'pipewire: PipeWire support'
'upower: Display battery level'
)
- provides=("kodi=${pkgver}" 'kodi-x11' 'kodi-wayland' 'kodi-gbm')
- conflicts=('kodi' 'kodi-x11' 'kodi-wayland' 'kodi-gbm')
+ provides=("kodi-common=${pkgver}" 'kodi-x11' 'kodi-wayland' 'kodi-gbm')
+ conflicts=('kodi-gles' 'kodi-x11' 'kodi-wayland' 'kodi-gbm')
_components=(
'kodi'
@@ -227,6 +230,48 @@ package_kodi-nexus-git() {
# https://bugs.archlinux.org/task/77366
mkdir -p "$pkgdir"/usr/lib/kodi/addons
}
+# kodi
+# components: kodi
+package_kodi-nexus-git-gles() {
+ pkgdesc="A software media player and entertainment hub for digital media (gles renderer, Nexus branch)"
+ depends=(
+ 'bluez-libs' 'curl' 'dav1d' 'desktop-file-utils' 'hicolor-icon-theme' 'fmt'
+ 'lcms2' 'libass' 'libbluray' 'libcdio' 'libcec' 'libmicrohttpd' 'libnfs'
+ 'libplist' 'libpulse' 'libva' 'libvdpau' 'libxslt' 'lirc' 'lzo'
+ 'mariadb-libs' 'mesa' 'libpipewire' 'python-pillow' 'python-pycryptodomex'
+ 'python-simplejson' 'shairplay' 'smbclient' 'sndio' 'spdlog' 'sqlite'
+ 'taglib' 'tinyxml' 'libxrandr' 'libxkbcommon' 'waylandpp' 'libinput'
+ 'pcre'
+ )
+ [[ -n "$_clangbuild" ]] && depends+=('glu')
+
+ optdepends=(
+ 'afpfs-ng: Apple shares support'
+ 'bluez: Blutooth support'
+ 'python-pybluez: Bluetooth support'
+ 'pulseaudio: PulseAudio support'
+ 'pipewire: PipeWire support'
+ 'upower: Display battery level'
+ )
+ provides=("kodi-common=${pkgver}" "kodi=${pkgver}" 'kodi-x11' 'kodi-wayland' 'kodi-gbm')
+ conflicts=('kodi' 'kodi-x11' 'kodi-wayland' 'kodi-gbm')
+
+ _components=(
+ 'kodi'
+ 'kodi-bin'
+ )
+
+ cd kodi-build-gles
+ for _cmp in ${_components[@]}; do
+ DESTDIR="$pkgdir" /usr/bin/cmake \
+ -DCMAKE_INSTALL_COMPONENT="$_cmp" \
+ -P cmake_install.cmake
+ done
+
+ # avoid error <general>: GetDirectory - Error getting /usr/lib/kodi/addons
+ # https://bugs.archlinux.org/task/77366
+ mkdir -p "$pkgdir"/usr/lib/kodi/addons
+}
# kodi-eventclients
# components: kodi-eventclients-common kodi-eventclients-ps3 kodi-eventclients-kodi-send