summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMichael Lass2016-02-04 00:15:40 +0100
committerMichael Lass2016-02-04 00:15:40 +0100
commit504d81671d60f82b25dea82730be8ec387fce6ab (patch)
tree14e153e6ce784811d9d5137388d79cd60a15a114
parentc381328428fe99c0fc8215ca41eb529f1c15cd4f (diff)
downloadaur-504d81671d60f82b25dea82730be8ec387fce6ab.tar.gz
Differentiate between API versions
For each version of kodi there is a specific version of kodi-platform and a branch for each addon. We have to use the correct versions, so require users to specify their version of kodi in the PKGBUILD.
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD29
2 files changed, 30 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d5f09752646a..f949443c1fc5 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
# Generated by mksrcinfo v8
-# Sat Jan 9 12:37:17 UTC 2016
+# Wed Feb 3 22:53:13 UTC 2016
pkgbase = kodi-platform-git
pkgdesc = Kodi platform support library
- pkgver = r40.45d6ad1
+ pkgver = r34.054a42f
pkgrel = 1
url = https://github.com/xbmc/kodi-platform
arch = armv7h
@@ -12,10 +12,10 @@ pkgbase = kodi-platform-git
makedepends = cmake
makedepends = git
depends = kodi
- depends = libplatform
+ depends = libplatform-legacy
provides = kodi-platform
conflicts = kodi-platform
- source = kodi-platform-git::git+https://github.com/xbmc/kodi-platform.git#commit=45d6ad1
+ source = kodi-platform-git::git+https://github.com/xbmc/kodi-platform.git#commit=054a42f66
md5sums = SKIP
pkgname = kodi-platform-git
diff --git a/PKGBUILD b/PKGBUILD
index 1203c10f93c2..05565bcab6ca 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,20 +3,43 @@
# This PKGBUILD is maintained on github:
# https://github.com/michaellass/AUR
+###############################################################################
+# INSTRUCTIONS #
+# ------------ #
+# #
+# API changes between different Kodi versions make it necessary to specify #
+# the version of Kodi you want to build this package for. You can choose #
+# between Isengard (15), Jarvis (16) and git master (99). Do so in the #
+# following line. #
+###############################################################################
+
+API=15
+
pkgname=kodi-platform-git
-pkgver=r40.45d6ad1
+pkgver=r34.054a42f
pkgrel=1
pkgdesc='Kodi platform support library'
arch=('armv7h' 'i686' 'x86_64')
url="https://github.com/xbmc/kodi-platform"
license=('GPL')
makedepends=('cmake' 'git')
-depends=('kodi' 'libplatform')
+depends=('kodi')
provides=('kodi-platform')
conflicts=('kodi-platform')
-source=("${pkgname}::git+https://github.com/xbmc/kodi-platform.git#commit=45d6ad1")
+source=("${pkgname}::git+https://github.com/xbmc/kodi-platform.git")
md5sums=('SKIP')
+# Corresponding commit IDs are taken from
+# https://github.com/xbmc/xbmc/blob/$BRANCH/project/cmake/addons/depends/common/kodi-platform/kodi-platform.txt
+case "$API" in
+ 15) depends+=('libplatform-legacy')
+ source[0]="${pkgname}::git+https://github.com/xbmc/kodi-platform.git#commit=054a42f66" ;;
+ 16) depends+=('libplatform-legacy')
+ source[0]="${pkgname}::git+https://github.com/xbmc/kodi-platform.git#commit=15edaf78d" ;;
+ 99) depends+=('libplatform') ;;
+ *) error "Unknown API version. Follow instructions in PKGBUILD." && false
+esac
+
pkgver() {
cd "$pkgname"
printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"