summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMichael Lass2019-02-05 20:51:32 +0100
committerMichael Lass2019-02-05 20:51:32 +0100
commitd430ddd6abf14dea8ccfa06d9038bb2c837b6e7f (patch)
tree98e44a5f809783c0e37d7475505625d2bcf1bd7b
parentdd8ebf00bf012b2e6afd7c99a690a9c98dabb325 (diff)
downloadaur-d430ddd6abf14dea8ccfa06d9038bb2c837b6e7f.tar.gz
Prepare for Leia and remove support for obsolete versions
-rw-r--r--PKGBUILD24
1 files changed, 9 insertions, 15 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 10b1732969f9..6ce32fa4b81f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -9,8 +9,8 @@
# #
# API changes between different Kodi versions make it necessary to specify #
# the version of Kodi you want to build this package for. You can choose #
-# between Isengard (15), Jarvis (16), Krypton (17) and git master (99). Do so #
-# in the following line. #
+# between Krypton (17), Leia (18) and git master (99). Do so in the following #
+# line. #
# #
###############################################################################
@@ -23,26 +23,20 @@ pkgdesc='Kodi platform support library'
arch=('armv7h' 'i686' 'x86_64')
url="https://github.com/xbmc/kodi-platform"
license=('GPL')
-makedepends=('cmake' 'git')
-depends=('kodi')
+makedepends=('cmake' 'git' 'kodi-dev')
+depends=('kodi' 'p8-platform')
provides=('kodi-platform')
conflicts=('kodi-platform')
source=("${pkgname}::git+https://github.com/xbmc/kodi-platform.git")
md5sums=('SKIP')
# Corresponding commit IDs are taken from
-# https://github.com/xbmc/xbmc/blob/$BRANCH/project/cmake/addons/depends/common/kodi-platform/kodi-platform.txt
+# https://github.com/xbmc/xbmc/blob/$BRANCH/[project/]cmake/addons/depends/common/kodi-platform/kodi-platform.txt
case "$API" in
- 15) depends+=('libplatform-legacy')
- source[0]="${pkgname}::git+https://github.com/xbmc/kodi-platform.git#commit=054a42f66" ;;
- 16) depends+=('libplatform-legacy')
- source[0]="${pkgname}::git+https://github.com/xbmc/kodi-platform.git#commit=15edaf78d" ;;
- 17) depends+=('p8-platform')
- makedepends+=('kodi-dev')
- source[0]="${pkgname}::git+https://github.com/xbmc/kodi-platform.git#commit=c8188d826" ;;
- 99) depends+=('p8-platform')
- makedepends+=('kodi-dev') ;;
- *) error "Unknown API version. Follow instructions in PKGBUILD." && false
+ 17) source[0]="${pkgname}::git+https://github.com/xbmc/kodi-platform.git#commit=c8188d826" ;;
+ 18) source[0]="${pkgname}::git+https://github.com/xbmc/kodi-platform.git#commit=e8574b883" ;;
+ 99) ;;
+ *) echo "Unknown API version. Follow instructions in PKGBUILD." && false
esac
pkgver() {